You are not logged in.

#1 2005-04-11 16:29:29

Aletheuo
Member
Registered: 2004-03-26
Posts: 59

php and ldap functions not working

I've got a php webpage I'm developing on my Arch desktop that does ldap authentication against AD, the problem is when the ldap_connect function executes nothing happens and nothing is returned from the function.
These same files I can copy over to my Arch laptop and they work perfectly.
Both the desktop and laptop are running current php/apache packages.
php 5.0.4-1 and apache 2.0.53-2 (not that the apache package matters)
According to phpinfo the php package on both are compiled --with-ldap but I'm not sure why the ldap functions are not working on the desktop, any idea's what to try?

Thanks,
Craig


Arch Linux (Duke)
JabberID:  cgill27@jabber.org
IRC: Aletheuo
Registered Linux User #354975

Offline

#2 2005-04-11 17:18:41

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: php and ldap functions not working

try installing openldap. it has the libs in there too.


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#3 2005-04-11 17:40:46

Aletheuo
Member
Registered: 2004-03-26
Posts: 59

Re: php and ldap functions not working

Darn I thought that was it, but I already do have openldap installed, current version 2.2.24-1.


Arch Linux (Duke)
JabberID:  cgill27@jabber.org
IRC: Aletheuo
Registered Linux User #354975

Offline

#4 2005-04-11 17:58:30

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: php and ldap functions not working

hmm..have you done a phpinfo(); and seen if the ldap stuff is coming up?


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#5 2005-04-11 18:11:21

Aletheuo
Member
Registered: 2004-03-26
Posts: 59

Re: php and ldap functions not working

Yea, here's the configure command section of the phpinfo output:
(shows --with-ldap=shared)
This is also the standard Arch php package.

'./configure' '--with-apxs2' '--prefix=/usr' '--sysconfdir=/etc' '--with-layout=PHP' '--with-ttf' '--enable-mailparse' '--with-config-file-scan-dir=/etc' '--enable-bcmath=shared' '--enable-calendar=shared' '--enable-ftp=shared' '--enable-gd-native-ttf' '--enable-magic-quotes' '--enable-posix=shared' '--enable-session' '--enable-shared' '--enable-shmop=shared' '--with-imap' '--with-imap-ssl' '--with-ncurses' '--with-readline' '--with-sqlite=shared' '--enable-sysvsem=shared' '--enable-sysvshm=shared' '--enable-track-vars' '--enable-trans-sid' '--enable-safe-mode' '--enable-sockets=shared' '--enable-xml' '--with-bz2=shared' '--with-curl' '--with-mime-magic' '--with-unixODBC=shared' '--with-mysqli=shared' '--enable-dba' '--without-db2' '--without-db3' '--with-inifile' '--with-flatfile' '--with-gdbm' '--with-freetype-dir=/usr' '--with-gd=shared' '--enable-exif' '--with-jpeg-dir=/usr' '--with-mysql=shared,/usr' '--with-ldap=shared' '--with-mysql-sock=/tmp/mysql.sock' '--with-openssl' '--with-gettext' '--with-pear=/usr/share/pear' '--with-dom' '--with-dom-xslt' '--with-xsl' '--with-pgsql=shared' '--with-pgsql-sock=/tmp/pgsql.sock' '--with-png-dir=/usr' '--with-regex=php' '--with-zlib' '--with-fam=shared' '--enable-mbstring=all' '--enable-mbregex'


Arch Linux (Duke)
JabberID:  cgill27@jabber.org
IRC: Aletheuo
Registered Linux User #354975

Offline

#6 2005-04-11 18:23:43

Aletheuo
Member
Registered: 2004-03-26
Posts: 59

Re: php and ldap functions not working

I think I got it now, "extensions=ldap.so" was commented out in my /etc/php.ini.
I un-commented it and rebooting now but that should fix it, thanks for your help!

Craig


Arch Linux (Duke)
JabberID:  cgill27@jabber.org
IRC: Aletheuo
Registered Linux User #354975

Offline

#7 2005-04-11 18:31:27

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: php and ldap functions not working

heh..that is why I asked for phpinfo instead of build flags.
Good to see you *hopefully* got it working now.


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

Board footer

Powered by FluxBB