You are not logged in.

#1 2010-08-27 02:41:23

binskipy2u
Banned
Registered: 2009-09-14
Posts: 212

ive read threads on this how do you upgrade flash on 64bit? <SOLVED>

i seen all the different names for the flashplugin, standalone, bin32 etc etc etc..
ive tried yaourt, pacman, packages not found or dependencies cant be satisfied..
before anyone asks.. i read the page where you can just download it, tried pacman -U xxxxx
dependencies couldnt be resolved..

I have flash on here via the wrapper.. learned how to do it on here, something with debian-nswraper something like that..
so why whne i pacman -Syyu/Syu or yaourt -Syu none of those packages update..
even though on the home page, i see there's updated flash packages for 64bit/multilib??

can someone please help me.. ive tried everythign ive stated above.. how can i update these nspluginwrapper/debian/flash/whatever packages???
thanks in advance..

Last edited by binskipy2u (2010-08-27 02:53:11)


"Sometimes you comfort the afflicted, other times you AFFLICT the COMFORTABLE"

Offline

#2 2010-08-27 02:43:17

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,071

Re: ive read threads on this how do you upgrade flash on 64bit? <SOLVED>

install nspluginwrapper-flash from AUR. if you have read 5 threads, that should have been pretty clear smile

This installs the latest available flash ...but it also means that flash will be 32-bit as Adobe has dropped support for 64 bit flash (for now?). for you, it means that a bunch of lib32* packages will also be installed on your system

Last edited by Inxsible (2010-08-27 02:46:38)


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#3 2010-08-27 02:43:40

binskipy2u
Banned
Registered: 2009-09-14
Posts: 212

Re: ive read threads on this how do you upgrade flash on 64bit? <SOLVED>

sorry i'm not perfect..


"Sometimes you comfort the afflicted, other times you AFFLICT the COMFORTABLE"

Offline

#4 2010-08-27 02:45:56

binskipy2u
Banned
Registered: 2009-09-14
Posts: 212

Re: ive read threads on this how do you upgrade flash on 64bit? <SOLVED>

Edit nspluginwrapper.install ? [Y/n] ("A" to abort)
==> ---------------------------------------------------
==> n

==> Continue building nspluginwrapper-debian ? [Y/n]
==> ------------------------------------------------
==>
==> Building and installing package
==> Install or build missing dependencies for nspluginwrapper-debian:
error: 'lib32-libxmu': could not find or read package

==> WARNING: Dependencies have been installed before the failure
==> Restart building nspluginwrapper-debian ? [y/N]


II nomatter what i do.. from what you've just told me.. it says the above message.. doesnt it pull in dependencies or do i have to figure'em out? i'm lost.. just want to update whats on my system already.. since there are updates available


"Sometimes you comfort the afflicted, other times you AFFLICT the COMFORTABLE"

Offline

#5 2010-08-27 02:47:32

binskipy2u
Banned
Registered: 2009-09-14
Posts: 212

Re: ive read threads on this how do you upgrade flash on 64bit? <SOLVED>

it s not in pacman..
pacman -S lib32-libxmu
error: 'lib32-libxmu': could not find or read package

its not in yaourt
yaourt -S lib32-libxmu
error: 'lib32-libxmu': could not find or read package

where do i go from here?


"Sometimes you comfort the afflicted, other times you AFFLICT the COMFORTABLE"

Offline

#6 2010-08-27 02:47:35

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: ive read threads on this how do you upgrade flash on 64bit? <SOLVED>

Add the new [multilib] repo and try again.

Offline

#7 2010-08-27 02:52:29

binskipy2u
Banned
Registered: 2009-09-14
Posts: 212

Re: ive read threads on this how do you upgrade flash on 64bit? <SOLVED>

THANK YOU.. ive never heard of a multilib repo..
i did that, and it upgraded ALL the 32bit stuff and nsplugin,flash etc..
thank you VERY much...


"Sometimes you comfort the afflicted, other times you AFFLICT the COMFORTABLE"

Offline

#8 2010-08-27 23:13:45

alfonsodg
Member
Registered: 2010-08-26
Posts: 15

Re: ive read threads on this how do you upgrade flash on 64bit? <SOLVED>

Well, after install from AUR the nspluginwrapper-flash i have the next problem


nspluginwrapper -v -a -i
Auto-install plugins from /usr/lib/mozilla/plugins
Looking for plugins in /usr/lib/mozilla/plugins
/usr/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory
/usr/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory
/usr/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory
/usr/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory
/usr/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory
/usr/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory
/usr/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory
/usr/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory
/usr/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory
/usr/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory
Auto-install plugins from /usr/lib/firefox/plugins
Looking for plugins in /usr/lib/firefox/plugins
/usr/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory
/usr/lib/nspluginwrapper/i386/linux/npviewer.bin: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory
Auto-install plugins from /home/alfonsodg/.mozilla/plugins
Looking for plugins in /home/alfonsodg/.mozilla/plugins


The lib32-libpng is installed, what else i need?

Offline

#9 2010-08-27 23:29:59

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: ive read threads on this how do you upgrade flash on 64bit? <SOLVED>

@alfonsodg remove that crap, all the things you have from aur. delete the file from /home/alfonsodg/.mozilla/plugins  and install flashplugin from multilib repo.

http://www.archlinux.org/news/508/


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#10 2010-08-28 00:00:21

alfonsodg
Member
Registered: 2010-08-26
Posts: 15

Re: ive read threads on this how do you upgrade flash on 64bit? <SOLVED>

@wonder: Shame on me! Fillany works.... too much lib32 packages fro AUR, thanks! Working

Offline

#11 2010-08-28 00:55:33

72linus
Member
From: gordonsville,va
Registered: 2009-03-14
Posts: 144
Website

Re: ive read threads on this how do you upgrade flash on 64bit? <SOLVED>

hello guys
I'm getting this when trying to install nspluginwrapper-flash

[root@nfluxos64 ~]# packer -S nspluginwrapper-flash

Aur Targets    (2): nspluginwrapper-debian nspluginwrapper-flash
Pacman Targets (1): gcc-libs-multilib

Proceed with installation? [Y/n] 
resolving dependencies...
warning: dependency cycle detected:
warning: lib32-gcc-libs will be installed before its gcc-libs-multilib dependency
looking for inter-conflicts...
:: gcc-libs-multilib and gcc-libs are in conflict. Remove gcc-libs? [y/N] 
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: gcc-libs-multilib and gcc-libs are in conflict
Installation failed.

I have lib32* installed, so maybe uninstall lib32-gcc-libs?
I tried that and still get

[root@nfluxos64 ~]# packer -S nspluginwrapper-flash

Aur Targets    (2): nspluginwrapper-debian nspluginwrapper-flash
Pacman Targets (3): gcc-libs-multilib lib32-gtk2 lib32-pcre

Proceed with installation? [Y/n] 
resolving dependencies...
warning: dependency cycle detected:
warning: lib32-gcc-libs will be installed before its gcc-libs-multilib dependency
looking for inter-conflicts...
:: gcc-libs-multilib and gcc-libs are in conflict. Remove gcc-libs? [y/N] 
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: gcc-libs-multilib and gcc-libs are in conflict
Installation failed.

what do I do?

Offline

#12 2010-08-28 05:38:27

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: ive read threads on this how do you upgrade flash on 64bit? <SOLVED>

@72linus read again this thread especially the previous post. You are installing shitty builds from AUR. We are not interested about them.

you should install flashplugin which depends on nspluginwrapper and you should first pacman -Syu


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#13 2010-08-28 12:28:30

72linus
Member
From: gordonsville,va
Registered: 2009-03-14
Posts: 144
Website

Re: ive read threads on this how do you upgrade flash on 64bit? <SOLVED>

OK
so I did

[root@nfluxos64 ~]# pacman -S flashplugin
resolving dependencies...
looking for inter-conflicts...

Targets (2): nspluginwrapper-1.3.0-3  flashplugin-10.1.82.76-3

Total Download Size:    0.00 MB
Total Installed Size:   14.22 MB

Proceed with installation? [Y/n] 
checking package integrity...
(2/2) checking for file conflicts                  [######################] 100%
(1/2) installing nspluginwrapper                   [######################] 100%
warning: directory permissions differ on usr/lib/mozilla/
filesystem: 700  package: 755
(2/2) installing flashplugin                       [######################] 100%
warning: directory permissions differ on usr/lib/mozilla/
filesystem: 700  package: 755
nspluginwrapper: no appropriate viewer found for /usr/lib/nspluginwrapper/i386/plugins/libflashplayer.so
To use the flash player in firefox, you must set
  dom.ipc.plugins.enabled.libflashplayer.so
to true in about:config.
[root@nfluxos64 ~]# pacman -S flashplugin
warning: flashplugin-10.1.82.76-3 is up to date -- reinstalling
resolving dependencies...
looking for inter-conflicts...

Targets (1): flashplugin-10.1.82.76-3

Total Download Size:    5.73 MB
Total Installed Size:   13.76 MB

Proceed with installation? [Y/n] 
:: Retrieving packages from multilib...
 flashplugin-10.1.8...     5.7M  183.3K/s 00:00:32 [######################] 100%
checking package integrity...
(1/1) checking for file conflicts                  [######################] 100%
(1/1) upgrading flashplugin                        [######################] 100%
warning: directory permissions differ on usr/lib/mozilla/
filesystem: 700  package: 755
nspluginwrapper: no appropriate viewer found for /usr/lib/nspluginwrapper/i386/plugins/libflashplayer.so
error: command failed to execute correctly

now what?
I opened up firefox on about:config
and  dom.ipc.plugins.enabled.libflashplayer.so is set to true but flash still not working?
now what?

EDIT:
I had to uninstall lib32-nvidia-utils as it wouldn't upgrade lib32 etc because it wanted to replace libgl with nvidia-utils
so now it all works great
Thanks

Last edited by 72linus (2010-08-28 16:08:09)

Offline

#14 2010-08-28 18:33:52

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: ive read threads on this how do you upgrade flash on 64bit? <SOLVED>

warning: directory permissions differ on usr/lib/mozilla/
filesystem: 700  package: 755

# chmod 755 /usr/lib/mozilla


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

Board footer

Powered by FluxBB