You are not logged in.

#1 2005-04-14 21:43:00

haoh_maro
Member
Registered: 2005-02-15
Posts: 9

Please help me with httpd problem

Actually, yesterday the httpd was running well, suddenly its broke up and I'd face of this weird problems :

1) When I type /etc/rc.d/httpd start -> it's take a minute to stop and just to tell FAILED. Also its use all my memory and cause my arch slow and hang before I cancel the process(also hard to kill the process).

2) I just try to open my localhost at browser but suddenly it's close the browser right after I hit the enter button. It's happen when I put my hostname but if I put the IP address, it's just telling that the apache is not running.

3) I'm using KDE with 2.6.10 kernel --> devfs.

4) I've do nothing to httpd.conf and all conf except uncomment module lib for php.

$ cat /var/log/httpd/error_log

[Thu Apr 14 11:10:12 2005] [warn] child process 16367 still did not exit, sending a SIGTERM
[Thu Apr 14 11:10:12 2005] [warn] child process 16368 still did not exit, sending a SIGTERM
[Thu Apr 14 11:10:12 2005] [warn] child process 16369 still did not exit, sending a SIGTERM
[Thu Apr 14 11:10:12 2005] [warn] child process 16370 still did not exit, sending a SIGTERM
[Thu Apr 14 11:10:12 2005] [warn] child process 16371 still did not exit, sending a SIGTERM
[Thu Apr 14 11:10:12 2005] [warn] child process 16374 still did not exit, sending a SIGTERM
[Thu Apr 14 11:10:12 2005] [warn] child process 16389 still did not exit, sending a SIGTERM
[Thu Apr 14 11:10:12 2005] [notice] caught SIGTERM, shutting down
[Thu Apr 14 11:17:02 2005] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Apr 14 11:17:02 2005] [notice] Digest: generating secret for digest authentication ...
[Thu Apr 14 11:17:02 2005] [notice] Digest: done
[Thu Apr 14 11:17:05 2005] [notice] Apache configured -- resuming normal operations
[Thu Apr 14 11:21:13 2005] [notice] caught SIGTERM, shutting down
[Thu Apr 14 11:36:18 2005] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Apr 14 11:36:19 2005] [notice] Digest: generating secret for digest authentication ...
[Thu Apr 14 11:36:19 2005] [notice] Digest: done
[Thu Apr 14 11:36:22 2005] [notice] Apache configured -- resuming normal operations
[Thu Apr 14 15:57:35 2005] [notice] caught SIGTERM, shutting down
[Thu Apr 14 15:57:39 2005] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Apr 14 15:57:39 2005] [notice] Digest: generating secret for digest authentication ...
[Thu Apr 14 15:57:39 2005] [notice] Digest: done
[Thu Apr 14 15:57:39 2005] [notice] Apache configured -- resuming normal operations

$ cat /var/log/error_log

Apr 15 04:52:06 haniey devfsd[1031]: action_compat: error unlinking: "vcs1"     No such file or directory
Apr 15 04:52:06 haniey devfsd[1031]: action_compat: error unlinking: "vcsa1"    No such file or directory
Apr 15 04:53:32 haniey Out of Memory: Killed process 3738 (httpd).
Apr 15 04:53:33 haniey Out of Memory: Killed process 3419 (gconfd-2).
Apr 15 04:53:33 haniey Out of Memory: Killed process 3685 (rc.shutdown).
Apr 15 04:53:33 haniey devfsd[1031]: action_compat: error unlinking: "vcs1"     No such file or directory
Apr 15 04:53:33 haniey devfsd[1031]: action_compat: error unlinking: "vcsa1"    No such file or directory
Apr 15 04:55:51 haniey Out of Memory: Killed process 2171 (httpd).
Apr 15 04:55:52 haniey devfsd[1031]: action_compat: error unlinking: "vcsa1"    No such file or directory
Apr 15 04:57:48 haniey Out of Memory: Killed process 2367 (hostname).
Apr 15 05:03:15 haniey Out of Memory: Killed process 2458 (gkrellm).
Apr 15 05:04:39 haniey Out of Memory: Killed process 2522 (hostname).

$ tail -l /var/log/daemon.log

Apr 15 04:57:49 haniey udev[2386]: configured rule in '/etc/udev/rules.d/udev.rules' at line 33 applied, 'vcsa7' becomes 'vcc/a%n'
Apr 15 04:57:49 haniey udev[2386]: creating device node '/dev/vcc/a7'
Apr 15 04:57:50 haniey udev[2432]: creating device node '/dev/nvidiactl'
Apr 15 04:57:51 haniey udev[2440]: creating device node '/dev/nvidia0'
Apr 15 05:03:40 haniey udev[2491]: removing device node '/dev/vcsa7'
Apr 15 05:03:40 haniey udev[2490]: removing device node '/dev/vcs7'
Apr 15 05:04:40 haniey udev[2541]: configured rule in '/etc/udev/rules.d/udev.rules' at line 33 applied, 'vcsa7' becomes 'vcc/a%n'
Apr 15 05:04:40 haniey udev[2540]: configured rule in '/etc/udev/rules.d/udev.rules' at line 31 applied, 'vcs7' becomes 'vcc/%n'
Apr 15 05:04:40 haniey udev[2540]: creating device node '/dev/vcc/7'
Apr 15 05:04:40 haniey udev[2541]: creating device node '/dev/vcc/a7'

Offline

#2 2005-04-14 21:59:29

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: Please help me with httpd problem

hmm..try pacman -Syu. It might be that your version of php and apache are not compatible.
Do you have Ignore set for either apache or php in /etc/pacman.conf ?

Also, try running

/etc/rc.d/httpd stop
apachectl -t
apachectl start

see if that produces any errors..


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#3 2005-04-14 22:08:26

haoh_maro
Member
Registered: 2005-02-15
Posts: 9

Re: Please help me with httpd problem

Thanks for quick response. I gonna update my system first and for the

/etc/rc.d/httpd stop
apachectl -t
apachectl start 

it's also produce a same problem, use up all my memory. Thanks a lot cactus.

Offline

#4 2005-04-14 22:10:49

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: Please help me with httpd problem

hmm...
You are using the standard packages from the Arch repos for apache and php5, right?


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#5 2005-04-14 22:13:06

haoh_maro
Member
Registered: 2005-02-15
Posts: 9

Re: Please help me with httpd problem

yes...

why, it's still need to tweak those files. I'm just a beginner.

Offline

#6 2005-04-14 22:19:54

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: Please help me with httpd problem

very strange. You might try the following as root:

pacman -Sy php apache --force

then say yes when it asks you if you want to upgrade anyway.
see if that helps at all.

and do this..

pacman -Qs php apache

it will report the version of the packages you are using. might be useful for troubleshooting if you are using an older mirror or something..


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#7 2005-04-14 22:23:03

haoh_maro
Member
Registered: 2005-02-15
Posts: 9

Re: Please help me with httpd problem

I'm doing pacman -Syu right now, maybe after this if it's still not settle, I'll report to you as soon as I can. Thanks.

Offline

#8 2005-04-16 03:56:21

haoh_maro
Member
Registered: 2005-02-15
Posts: 9

Re: Please help me with httpd problem

It's solve now, I dont know why this is happen. It's just some problem happen to my hosts file, there's something unknown code in there, after I delete that code and configure it back, it's working now. Thanks bro cactus.

Offline

#9 2005-04-16 09:11:46

RedShift
Member
From: Belgium
Registered: 2004-07-16
Posts: 230

Re: Please help me with httpd problem

I'm seeing out of memory in one of your logs, how much system memory do you have and do you have enough swap space set up?


:?

Offline

Board footer

Powered by FluxBB