You are not logged in.

#1 2010-09-11 22:06:28

regitator
Member
Registered: 2010-08-10
Posts: 26

[SOLVED->use cairo-xcb]Symbol lookup errors with cairo and awesome

Hi  guys,
the last few days i've been getting these errors at start:

awesome: symbol lookup error: awesome: undefined symbol: cairo_xcb_surface_create

on xinit. It gets started with "exec ck-launch-session awesome"
I've narrowed the problem down to awesome itself, even with default rc.lua. Anyone else also getting these?
http://mirror.selfnet.de/archlinux/$repo/os/x86_64 has been my first mirror. The mirror itself seems ok.
Smells like packaging issue, right? Testing is enabled, so cairo is on 1.10.0-2 and awesome on 3.4.6-1.

Last edited by regitator (2010-09-11 22:25:26)

Offline

#2 2010-09-11 22:11:56

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [SOLVED->use cairo-xcb]Symbol lookup errors with cairo and awesome

read the testing forum

https://bbs.archlinux.org/viewtopic.php?id=104713

Last edited by wonder (2010-09-11 22:19:49)


Give what you have. To someone, it may be better than you dare to think.

Offline

#3 2010-09-11 22:20:48

regitator
Member
Registered: 2010-08-10
Posts: 26

Re: [SOLVED->use cairo-xcb]Symbol lookup errors with cairo and awesome

Thx. I searched the whole forum just yesterday and this thread wasn't there yet.

Offline

#4 2010-09-30 04:52:40

susbarbatus
Member
From: China
Registered: 2010-09-30
Posts: 8

Re: [SOLVED->use cairo-xcb]Symbol lookup errors with cairo and awesome

Hello regitator. I'm now being troubled by the same problem and I just wish to know how did you solve it? Thx.


小香猪杀手@cc98.org

Offline

#5 2010-09-30 05:06:50

Allan
Member
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,941
Website

Re: [SOLVED->use cairo-xcb]Symbol lookup errors with cairo and awesome

He clicked on the link given in the first reply and then read the information there....

Offline

#6 2010-09-30 05:45:32

susbarbatus
Member
From: China
Registered: 2010-09-30
Posts: 8

Re: [SOLVED->use cairo-xcb]Symbol lookup errors with cairo and awesome

I'm sorry I was so careless scaning and asked a meaningless question.

Last edited by susbarbatus (2010-09-30 05:47:49)


小香猪杀手@cc98.org

Offline

Board footer

Powered by FluxBB