You are not logged in.

#1 2009-11-16 12:48:15

blq
Member
Registered: 2009-10-26
Posts: 10

KWin compositing only in XRender mode / unable to use OpenGL mode.

Hi,

somehow I am unable to activate kwin4 compositing in OpenGL mode. If I try to I get the following message:

"Failed to activate desktop effects using the given configuration options. Settings will be reverted to their previous values.

Check your X configuration. You may also consider changing advanced options, especially changing the compositing type."

I have a NVidia GF GTX+ 9800 connected to 2 monitors in twinview.

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "DamageEvents" "True"
    Option         "RenderAccel" "True"
    Option         "AllowGLXWithComposite" "True"
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "CRT-0: nvidia-auto-select +0+0, CRT-1: nvidia-auto-select +1600+0"
    Option         "AddARGBGLXVisuals" "True"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

I've turned xdamage and xcomposite on.

Section "Extensions"
    Option         "Composite" "True"
    Option         "DAMAGE" "True"
    Option         "RENDER" "True"
EndSection

I made sure I am not in failsafe mode.

glxinfo says:

direct rendering: Yes

glxgears:

75516 frames in 5.0 seconds = 15103.146 FPS
85523 frames in 5.0 seconds = 17104.479 FPS
77216 frames in 5.0 seconds = 15443.117 FPS

Xorg.0.log says:

(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
    compiled for 4.0.2, module version = 1.0.0
    Module class: X.Org Server Extension
(II) NVIDIA GLX Module  190.42  Tue Oct 20 21:19:30 PDT 2009
(II) Loading extension GLX

(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
    compiled for 1.7.1, module version = 1.0.0
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
    compiled for 1.7.1, module version = 1.1.0
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2

(**) NVIDIA(0): Option "RenderAccel" "True"
(**) NVIDIA(0): Option "TwinView" "1"
(**) NVIDIA(0): Option "MetaModes" "CRT-0: nvidia-auto-select +0+0, CRT-1: nvidia-auto-select +1600+0"
(**) NVIDIA(0): Option "TwinViewXineramaInfoOrder" "CRT-0"
(**) NVIDIA(0): Option "AllowGLXWithComposite" "True"
(**) NVIDIA(0): Option "AddARGBGLXVisuals" "True"
(**) NVIDIA(0): Option "DamageEvents" "True"
(**) Nov 16 14:44:15 NVIDIA(0): Enabling RENDER acceleration
(II) Nov 16 14:44:15 NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) Nov 16 14:44:15 NVIDIA(0):     enabled.

(II) Nov 16 14:44:16 NVIDIA(0): Initialized OpenGL Acceleration
(==) NVIDIA(0): Disabling shared memory pixmaps
(II) Nov 16 14:44:16 NVIDIA(0): Initialized X Rendering Acceleration

(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing extension GLX

I think I've the latest drivers and software installed.
nvidia 190.42-1
xorg-server 1.7.1.901-2
kdebase-workspace 4.3.3-1


xorg.conf: http://longint.de/~blq/xorg.conf
.xsession-errors: http://longint.de/~blq/xsession-errors
Xorg.0.log: http://longint.de/~blq/Xorg.0.log
glxinfo: http://longint.de/~blq/glxinfo.output

What else could I check? Any suggestions?

Thanks in advance.

Last edited by blq (2009-11-16 14:14:46)

Offline

#2 2009-11-16 18:26:48

Ranguvar
Member
From: Our collective subconscious
Registered: 2008-08-12
Posts: 2,515
Website

Re: KWin compositing only in XRender mode / unable to use OpenGL mode.

Please try with Compiz instead of KWin.  I asked another user with a similar issue to do this and it helped them, because Compiz gave a better error message that helped them diagnose the issue.  And if Compiz works fine, it's a KWin bug smile

http://bbs.archlinux.org/viewtopic.php?id=83945

Offline

#3 2009-11-16 20:26:18

mutlu_inek
Member
From: all over the place
Registered: 2006-11-18
Posts: 676
Website

Re: KWin compositing only in XRender mode / unable to use OpenGL mode.

Offline

#4 2009-11-16 20:47:12

blq
Member
Registered: 2009-10-26
Posts: 10

Re: KWin compositing only in XRender mode / unable to use OpenGL mode.

mutlu_inek wrote:

I've allready tried that... and actually I do have a 24/32bit configuration smile Thank's anyway!

Offline

#5 2009-11-16 21:49:51

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: KWin compositing only in XRender mode / unable to use OpenGL mode.

Try a minimal xorg.conf. Read the nvidia wiki.

Offline

#6 2009-11-16 21:58:00

Ranguvar
Member
From: Our collective subconscious
Registered: 2008-08-12
Posts: 2,515
Website

Re: KWin compositing only in XRender mode / unable to use OpenGL mode.

And try what I suggested.  Run Compiz and see if it gives you error messages.

Offline

#7 2009-11-16 22:00:33

Gen2ly
Member
From: Sevierville, TN
Registered: 2009-03-06
Posts: 1,529
Website

Re: KWin compositing only in XRender mode / unable to use OpenGL mode.

Opengl does work for the desktop effects built into Kwin/KDE but it is currently buggy.  It does work for me but there are odd screen drawings in places.  I believe they are trying to get this fixed by 4.4.

Last edited by Gen2ly (2009-11-16 22:00:52)


Setting Up a Scripting Environment | Proud donor to wikipedia - link

Offline

#8 2009-11-16 22:02:22

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: KWin compositing only in XRender mode / unable to use OpenGL mode.

Gen2ly wrote:

Opengl does work for the desktop effects built into Kwin/KDE but it is currently buggy.  It does work for me but there are odd screen drawings in places.  I believe they are trying to get this fixed by 4.4.

Νο such prob here with latest Nvidia drivers.

Offline

#9 2009-11-17 03:33:42

mutlu_inek
Member
From: all over the place
Registered: 2006-11-18
Posts: 676
Website

Re: KWin compositing only in XRender mode / unable to use OpenGL mode.

Did you try changing the OpenGL mode in the "advanced" tab in systemsettings?

Offline

#10 2009-11-17 05:29:33

dalingrin
Member
Registered: 2009-03-18
Posts: 125

Re: KWin compositing only in XRender mode / unable to use OpenGL mode.

Nvidia, Xinerama and Kwin compositing does not currently work. With nVidia you will need to run twinview without Xinerama if you want KWin compositing.


EDIT: Nevermind, I see you have Xinerama turned off.

Last edited by dalingrin (2009-11-17 05:30:23)

Offline

#11 2009-11-17 13:06:42

blq
Member
Registered: 2009-10-26
Posts: 10

Re: KWin compositing only in XRender mode / unable to use OpenGL mode.

Ranguvar wrote:

Please try with Compiz instead of KWin.  I asked another user with a similar issue to do this and it helped them, because Compiz gave a better error message that helped them diagnose the issue.  And if Compiz works fine, it's a KWin bug smile

http://bbs.archlinux.org/viewtopic.php?id=83945

Ok, I weren't able to find a specific compiz log, so I started it via console the output was:

[14:03:43][blq@myhost ~]$ fusion-icon
* Detected Session: kde
* Searching for installed applications...
* NVIDIA on Xorg detected, exporting: __GL_YIELD=NOTHING
* Using the GTK Interface
* Starting Compiz
... executing: compiz --replace --sm-disable --ignore-desktop-hints ccp --loose-binding --indirect-rendering
fuse: failed to access mountpoint compiz: No such file or directory
compiz (cube) - Warn: Failed to load slide: freedesktop

Somehow I weren't able to get any window-decorations to work. (Emerald)







flamelab wrote:

Try a minimal xorg.conf. Read the nvidia wiki.

I allready tried that. I only added what was absolutely necessary to get the monitors working  ....  same problem........
I've read the NVidia wiki several times and very carefully. I went through every single step.. there is nothing more available that could solve my problem.



Thankyou very much for the responses!

Last edited by blq (2009-11-17 13:09:09)

Offline

#12 2009-11-19 01:40:03

danym
Member
From: Saint-Hippolyte, Qc
Registered: 2007-05-14
Posts: 72
Website

Re: KWin compositing only in XRender mode / unable to use OpenGL mode.

I also have the same problem since few days.  I know that opengl effect were working few days ago, but didn't notice when it's stop working.  I tried removing kde (by pacman -Rd kde), reinstalling kde, removing kde again to intall kdemod.  I reinstalled xorg-server (1.7.1.901-2) and Nvidia drivers and opengl works (for games) but not for desktop effects.
I tried compiz but i cannot have decoration (have this message:

 compiz (core) - Warn: No GLXFBConfig for depth 32

I've checked on Google about it and configured /etc/X11/xorg.conf correctly adding AddARGBGLXVisuals stuff...)

The only thing i haven't done is reinstalling Arch Linux....   :-(


sin² x + cos² x = 1

Offline

#13 2009-11-19 13:08:23

blq
Member
Registered: 2009-10-26
Posts: 10

Re: KWin compositing only in XRender mode / unable to use OpenGL mode.

Hi danym, where do you get that message? I couldn't find a compiz logfile anywhere ...

Offline

#14 2009-11-19 13:51:24

Gen2ly
Member
From: Sevierville, TN
Registered: 2009-03-06
Posts: 1,529
Website

Re: KWin compositing only in XRender mode / unable to use OpenGL mode.

flamelab wrote:
Gen2ly wrote:

Opengl does work for the desktop effects built into Kwin/KDE but it is currently buggy.  It does work for me but there are odd screen drawings in places.  I believe they are trying to get this fixed by 4.4.

Νο such prob here with latest Nvidia drivers.

I tried:

kquitapp plasma-desktop
plasma-desktop -graphicssystem opengl

And these are the odd draws I'm getting:

vMnQwYQ

Plus I noticed that this bjonks kwin (Desktop effects) now).  Last time I tried this was 4.3.1 or 4.3.2 and it didn't do that then.  Using nvidia-drivers too.


Setting Up a Scripting Environment | Proud donor to wikipedia - link

Offline

#15 2009-11-19 14:06:52

blq
Member
Registered: 2009-10-26
Posts: 10

Re: KWin compositing only in XRender mode / unable to use OpenGL mode.

Gen2ly wrote:

I tried:

kquitapp plasma-desktop
plasma-desktop -graphicssystem opengl

I tried that too, but it still seems to use XRender ... hmm

Ah, and yes I'm getting the same damaged icons by doing this.

Last edited by blq (2009-11-19 14:11:21)

Offline

#16 2009-11-19 14:51:15

danym
Member
From: Saint-Hippolyte, Qc
Registered: 2007-05-14
Posts: 72
Website

Re: KWin compositing only in XRender mode / unable to use OpenGL mode.

blq wrote:

Hi danym, where do you get that message? I couldn't find a compiz logfile anywhere ...

I started compiz by fusion-icon in terminal.  That's how i've the logs...


sin² x + cos² x = 1

Offline

#17 2009-11-19 14:55:20

blq
Member
Registered: 2009-10-26
Posts: 10

Re: KWin compositing only in XRender mode / unable to use OpenGL mode.

like I said above .. I don't get that error ..

but this should fix your problem (if u are using a nvidia card):

nvidia-xconfig --add-argb-glx-visuals -d 24

Last edited by blq (2009-11-19 14:55:49)

Offline

#18 2009-11-19 20:16:29

danym
Member
From: Saint-Hippolyte, Qc
Registered: 2007-05-14
Posts: 72
Website

Re: KWin compositing only in XRender mode / unable to use OpenGL mode.

To blq: Already tried...  Doesn't work  :-(
I'm pretty sure that something's wrong elsewhere...  but where?


sin² x + cos² x = 1

Offline

#19 2009-11-20 02:30:26

danym
Member
From: Saint-Hippolyte, Qc
Registered: 2007-05-14
Posts: 72
Website

Re: KWin compositing only in XRender mode / unable to use OpenGL mode.

Got opengl desktop effects working.
Since i decided to remove kde and install kdemod, i've downloaded chakra live CD (alpha 4) and booted it.
After that, i realised that desktop effect are working in live CD with nvidia drivers.
I've decided to compare my /etc directory with chakra's /etc directory and found some irregularities in mine!

I'll try to investigate to find what was exactly to problem...


sin² x + cos² x = 1

Offline

#20 2009-11-20 11:45:55

blq
Member
Registered: 2009-10-26
Posts: 10

Re: KWin compositing only in XRender mode / unable to use OpenGL mode.

Ok, that sounds interesting, would you please post the xorg.conf and the xorg log of the livecd?

Update:
---
I've installed kdemod now. Compositing still isnt working in OpenGL mode. Same behavior.

Last edited by blq (2009-11-20 13:35:01)

Offline

#21 2009-11-20 14:09:26

danym
Member
From: Saint-Hippolyte, Qc
Registered: 2007-05-14
Posts: 72
Website

Re: KWin compositing only in XRender mode / unable to use OpenGL mode.

I didn't change my xorg.conf file but here it is. 
Also, here are the files i've changed
--> /etc/X11/xinit/xinitrc
--> /etc/profile.d/xorg.sh

I've also remove some *.pacsave file and adjust some *.pacorig file, but there were nothing about kde or xorg.

Last edited by danym (2009-11-20 14:09:51)


sin² x + cos² x = 1

Offline

#22 2009-11-23 09:35:13

blq
Member
Registered: 2009-10-26
Posts: 10

Re: KWin compositing only in XRender mode / unable to use OpenGL mode.

Ranguvar wrote:

And try what I suggested.  Run Compiz and see if it gives you error messages.

I gave it another try and found out that compiz fusion runs fine if I start it via sudo, somehow it isnt able to replace the window decorator else.
I m not sure if compiz fusion is really using open gl, is there a way to prove it isnt running at XRender?

danym wrote:

I didn't change my xorg.conf file but here it is. 
Also, here are the files i've changed
--> /etc/X11/xinit/xinitrc
--> /etc/profile.d/xorg.sh

I've also remove some *.pacsave file and adjust some *.pacorig file, but there were nothing about kde or xorg.

I tried the exact same configuration without success hmm

Last edited by blq (2009-11-23 09:37:46)

Offline

#23 2009-11-24 01:34:05

danym
Member
From: Saint-Hippolyte, Qc
Registered: 2007-05-14
Posts: 72
Website

Re: KWin compositing only in XRender mode / unable to use OpenGL mode.

Have you tried running kde as root and using OpenGl effect?


sin² x + cos² x = 1

Offline

#24 2010-10-20 10:37:43

blazzter
Member
Registered: 2009-03-25
Posts: 16

Re: KWin compositing only in XRender mode / unable to use OpenGL mode.

try remove .kde4 folder (or rename just for try if you don't want to lose your settings), that helped me

Offline

Board footer

Powered by FluxBB