You are not logged in.

#1 2010-10-08 22:04:47

gromlok
Member
Registered: 2010-04-19
Posts: 154

TOR in ArchLinux: Torbutton

Hello:
I installed TOR following the Wiki of ArchLinux. I downloaded the Torbutton for Firefox, but when I active it, Firefox does not load any page! Its like the Internet is gone.run it.
I putted tor and privoxy as deamons, to run it.

Any suggestion please?

Thank you.


.

Offline

#2 2010-10-08 22:57:06

Army
Member
Registered: 2007-12-07
Posts: 1,784

Re: TOR in ArchLinux: Torbutton

Does it work with another browser? If not, you might have made a mistake in the configuration.

Offline

#3 2010-10-16 04:06:25

gromlok
Member
Registered: 2010-04-19
Posts: 154

Re: TOR in ArchLinux: Torbutton

Hello:
Sorry for the delay, but I had a lot of troubles setting up my wireless card!

I checked something in TOR, and privoxy is not starting, even after I re-installed it.

sudo /etc/rc.d/privoxy restart
:: Stopping Privoxy                                                      [FAIL] 
:: Starting Privoxy                                                      [FAIL] 

I only did the changes of the wiki in the /etc/privoxy/config

Any suggestion?

Thank you.

PD: I changed the order in the DEAMON array in rc.conf, this is "tor privoxy" or "privoxy tor", with the same results. Don't know if relevant.

Last edited by gromlok (2010-10-16 04:07:41)


.

Offline

#4 2010-10-16 04:16:48

gromlok
Member
Registered: 2010-04-19
Posts: 154

Re: TOR in ArchLinux: Torbutton

Sorry, I changed the config file of privoxy

listen-address  my ip

to the original setting, and now it connect. But the torbutton is not working.

I tried installing another browser, abaco, but did not find a torbutton application for that hmm

What could I do?

Thank you


.

Offline

#5 2010-10-16 09:11:26

Army
Member
Registered: 2007-12-07
Posts: 1,784

Re: TOR in ArchLinux: Torbutton

You don't need a torbutton application for a browser to work with tor!!! Tor simply needs a proxy setting, which most browsers support (I even guess every browser supports that).

What exactly did you change in privoxy's config? Could you provide a link to the wiki article you used? And could you show your config? In my experience privoxy only doesn't start if there's something wrong with the config, could be syntax errors or whatever, but this thing is really supposed to work!

Offline

#6 2010-10-16 16:23:01

gromlok
Member
Registered: 2010-04-19
Posts: 154

Re: TOR in ArchLinux: Torbutton

Hello:

I used this wiki for installing torbutton and Tor, and this for Tor in general.

In the last wiki, in the section of "Binding Privoxy to local network", I putted my IP. But privoxy did not connect. After that I leave it in the original form -127.0.0.1:8118- and now privoxy and tor connects, BUT when I activate the Torbutton, nothing happens. The browser does not load the page.

That was the only change that I did, and the ones suggested in the wiki. Nothing more. I will try to put the proxy settings directly in Firefox, to see what happens. Never the less, waiting for you reply.

Thank you.


.

Offline

#7 2010-10-16 16:28:38

gromlok
Member
Registered: 2010-04-19
Posts: 154

Re: TOR in ArchLinux: Torbutton

Well, putting the settings in the Firefox settings works! So, I guess that the problem is the torbutton. I re-installed and is not working hmm

EDIT: it only worked for a few minutes -putting manually the proxy settings-. Now does not work! I don't know why.

Last edited by gromlok (2010-10-16 17:06:15)


.

Offline

#8 2010-10-21 01:25:23

gromlok
Member
Registered: 2010-04-19
Posts: 154

Re: TOR in ArchLinux: Torbutton

Hello:
I'm getting something like this, for every page -using Torbutton, swtichproxy, or putting manually the info:

 This is Privoxy 3.0.16 on localhost.localdomain (127.0.0.1), port 8118, enabled
Forwarding failure

Privoxy was unable to socks4a-forward your request http://www.ixquick.com/ through localhost: SOCKS request rejected or failed.

Just try again to see if this is a temporary problem, or check your forwarding settings and make sure that all forwarding servers are working correctly and listening where they are supposed to be listening. 

And I have this settings:

The following options were given in the config file:

confdir /etc/privoxy
logdir /var/log/privoxy
actionsfile match-all.action
actionsfile default.action
actionsfile user.action
filterfile default.filter
logfile logfile
listen-address 127.0.0.1:8118
toggle 1
enable-remote-toggle 0
enable-remote-http-toggle 0
enable-edit-actions 0
enforce-blocks 0
buffer-limit 4096
forwarded-connect-retries 0
accept-intercepted-requests 0
allow-cgi-request-crunching 0
split-large-forms 0
keep-alive-timeout 5
socket-timeout 300
handle-as-empty-doc-returns-ok 1
forward-socks4a / 127.0.0.1:9050 .       ------> I changed 127.0.0.1 for localhost with the same results!

Any idea please?
thank you.


.

Offline

#9 2010-11-01 06:56:47

iopo
Member
Registered: 2009-10-26
Posts: 31

Re: TOR in ArchLinux: Torbutton

Hello,

I have installed following the privoxy wiki, and worked perfect for me. But, just to mention, I didn't changed my /etc/hosts, I have:

127.0.0.1        localhost.localdomain    localhost myownhostname

Then I tried it with midori, setting the proxy (Edit > Preferences > Network) to Hostname: 127.0.0.1 Port: 8118

Maybe your problem is in the /etc/hosts file, as mine is different from the wiki example but works perfectly fine.

Offline

#10 2010-11-04 01:03:49

gromlok
Member
Registered: 2010-04-19
Posts: 154

Re: TOR in ArchLinux: Torbutton

Hello:
I tried using the default configuration and the one with my HOSTNAME, and it didn't work. In the /var/log/privoxy/ in logfile there is nothing, so I don't see any error message, if any.
I don't know what to do! I'm using more Windows now because there is working TOR!
If anyone could help me.

I was thinking that maybe another program could interfere with this tor/privoxy, maybe CONKY, because when I activate TOR, the IP that conky shows is the same, this is, the one that originally had.

Waiting for your help!


.

Offline

Board footer

Powered by FluxBB