You are not logged in.

#1 2010-10-30 23:53:11

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,326

aireplay-ng: mon0 is on channel -1, but the AP uses channel 1

This is a really annoying bug, and all the packages that include the patches seem really sloppy.  It feels really silly to build and maintain a custom kernel just to fix this problem.  Has anyone encountered and fixed this bug (in a clean way)?


Touch my kernel

Offline

#2 2010-10-31 00:11:49

jt512
Member
Registered: 2009-02-19
Posts: 256

Re: aireplay-ng: mon0 is on channel -1, but the AP uses channel 1

I filed a bug report about it, and the package maintainer suggesting filing the bug upstream, which I've never gotten around to doing.

Offline

#3 2010-10-31 09:09:10

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,326

Re: aireplay-ng: mon0 is on channel -1, but the AP uses channel 1

Hmm, I see.  Well, I swapped my Broadcom 4312 Mini-PCI card out for an Atheros AR5006EG and am using the madwifi drivers.  They don't have this behavior, so ... fixed.  I'm really intersted in seeing this fixed for all cards though smile


Touch my kernel

Offline

#4 2010-11-04 14:04:47

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,326

Re: aireplay-ng: mon0 is on channel -1, but the AP uses channel 1

That Atheros idea crashed into the ground after I was getting hardware lockups after the swap ... back to Broadcom.

I researched the situation a bit and found that I needed to obtain, patch, and install the compat-wireless kernel module updates.  I dug around on the AUR for something but wasn't satisfied with what I saw, so I created my own.  If this would help any of you guys, here's the link:  http://aur.archlinux.org/packages.php?ID=42624


Touch my kernel

Offline

Board footer

Powered by FluxBB