You are not logged in.

#1 2005-05-21 19:05:07

tropical_disease
Member
From: Boston
Registered: 2005-02-21
Posts: 21

strange problem with idesk icons display on fluxbox [SOLVED]

I'm using idesk to display icons on fluxbox-devel. Only trouble is that when I do "startx", the background to the icons is grainy and grey, almost like the default x background. This effect is much worse when the icons are set to be transparent. Plus the icons don't execute any commands when I left click on them.
I'm using idesktool as well, so when I right click on any of the icons, the gui configuration tool for idesktool opens up. If I click on the option to edit .ideskrc, then click ok without actually editing anything, the icons go back to looking how they should, and they execute the associated programs correctly.
I've tried adding "idesk &" to .xinitrc and .fluxbox/apps, but nothing I've tried so far works.
Anyway, I'm a bit stuck here so gimme any help you can, it's much appreciated. Hopefully someone else has had the same problem and solved it.
Cheers

Offline

#2 2005-05-21 22:55:12

wickedlester
Member
Registered: 2004-07-22
Posts: 133

Re: strange problem with idesk icons display on fluxbox [SOLVED]

put this line in your .xinitrc to start idesk
(sleep 2; idesk &) &
that keeps it from starting before your wallpaper is displayed.

Offline

#3 2005-05-22 01:05:07

tropical_disease
Member
From: Boston
Registered: 2005-02-21
Posts: 21

Re: strange problem with idesk icons display on fluxbox [SOLVED]

Thanks a million!
This has been bugging me for a while.
Cheers!
Tropical

Offline

#4 2005-05-22 02:38:15

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,431
Website

Re: strange problem with idesk icons display on fluxbox [SOLVED]

that didn't work for me - it depends on the speed of your system you see.

I added fbsetbg -l then the idesk command to my fluxbox startup file - i have no sleeps at all now

Offline

#5 2005-05-22 03:13:10

wickedlester
Member
Registered: 2004-07-22
Posts: 133

Re: strange problem with idesk icons display on fluxbox [SOLVED]

dibblethewrecker, how fast is your system? I have a pretty decent system and it works great for me. although I have it in my .xinitrc file(not sure if it matters.) Also, which version of iDesk are you using. I am using 0.7.2
also not sure if that makes a difference.

Offline

#6 2005-05-22 22:04:58

tropical_disease
Member
From: Boston
Registered: 2005-02-21
Posts: 21

Re: strange problem with idesk icons display on fluxbox [SOLVED]

Dibble,
could you elaborate a bit on where you put those commands? the init file, apps or .xinitrc? - exact comands would also be appreciated. I know I'm demanding and I take more than I give, sorry smile

while the sleep command works for me most of time, I've recently discovered it doesn't work always. It seems I have most problems when I first boot into X. If I exit then reboot X, everything's fine. Kinda confusing.

Thanks

Offline

#7 2005-05-22 22:41:43

wickedlester
Member
Registered: 2004-07-22
Posts: 133

Re: strange problem with idesk icons display on fluxbox [SOLVED]

tropical_disease, have you tried changing the sleep time from 2 to a higher number? maybe you need more time before you have idesk started.

Offline

#8 2005-05-23 02:10:08

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,431
Website

Re: strange problem with idesk icons display on fluxbox [SOLVED]

tropical_disease - same prob for me

put em in your ~/.fluxbox/apps file, sorry!

[startup] {fbsetbg -l}
[startup] {idesk &}

Offline

#9 2005-05-23 22:20:11

tropical_disease
Member
From: Boston
Registered: 2005-02-21
Posts: 21

Re: strange problem with idesk icons display on fluxbox [SOLVED]

Hey, Dibblethewrecker - I'm afraid your remedy didn't work for me, don't know why, it must be something to do with how my backgrounds are already set I suppose  :?

wickedlester - Eventually after messing about with the sleep time, I've found that 5 seconds is enough to make sure my icons look and work normally when I do startx. It's not ideal, but it's much better than what I had originally.

Cheers for your help guys, I'm pretty happy already, but feel free to offer any more alternative solutions which may work more optimally.

Offline

#10 2005-05-24 06:29:59

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,431
Website

Re: strange problem with idesk icons display on fluxbox [SOLVED]

i lied....

[startup] {fbsetbg -l}
[startup] {sleep 5 && idesk &}

:opps:

Offline

Board footer

Powered by FluxBB