You are not logged in.

#1 2011-02-28 16:11:12

SpleenThief
Member
Registered: 2011-02-28
Posts: 16

No USB Hotplugging Under Linux

Recently I've been having trouble with hotplugging USB devices. If I boot up with them plugged in, they're recognized and function perfectly. However, from the (lack of) output in my logs and lsusb, it appears that my system isn't even recognizing that a device has been plugged in. I know that this isn't a hardware problem, because it worked fine for a long time, and still works perfectly in windows. I think it stopped working around a month ago, however I can't be sure.

I've tried reinstalling my kernel with # pacman -S kernel26, I've reinstalled xorg, udev. I haven't disabled hotplugging in xorg explicitly, however the wiki isn't clear on the exact config file that I should check.

The devices that I've tested are:
-USB stick
-Logitech Unifying Receiver (wireless mouse)
-LG Xenon (my phone: under windows at detects that it's connected to a computer and automatically puts itself into USB Mass Storage Mode, which lets me transfer files back and forth. Under linux it acts like it's plugged into the wall, and only charges)

I'm running Openbox and have done a great deal of configuration, so I would really not like to do a fresh install. Any help is appreciated, thanks.

EDIT: I just tried an Ubuntu live cd. Hotplugging works fine.

Last edited by SpleenThief (2011-02-28 16:23:06)

Offline

#2 2011-02-28 16:53:51

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,059

Re: No USB Hotplugging Under Linux


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#3 2011-02-28 17:01:41

SpleenThief
Member
Registered: 2011-02-28
Posts: 16

Re: No USB Hotplugging Under Linux

Possibly, but I doubt it. My cpu usage does not increase at all.

Offline

#4 2011-02-28 17:46:17

toad
Member
From: if only I knew
Registered: 2008-12-22
Posts: 1,775
Website

Re: No USB Hotplugging Under Linux

daemon array in rc.conf and dmesg output directly after having plugged a device in would be useful


never trust a toad...
::Grateful ArchDonor::
::Grateful Wikipedia Donor::

Offline

#5 2011-03-01 00:37:10

SpleenThief
Member
Registered: 2011-02-28
Posts: 16

Re: No USB Hotplugging Under Linux

DAEMONS=(syslog-ng dbus hal !network laptop-mode wicd sshd slim @samba @netfs @xinetd @alsa @autofs @crond @cups)

I've tried disabling autofs but it didn't change my problem.

Output from dmesg | tail after plugging in device:
wlan0: RX AssocResp from c0:c1:c0:02:55:b8 (capab=0x411 status=0 aid=1)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
padlock: VIA PadLock not detected.
Intel AES-NI instructions are not detected.
wlan0: no IPv6 routers present
ehci_hcd 0000:00:12.2: BAR 0: set to [mem 0xf2308600-0xf23086ff] (PCI address [0xf2308600-0xf23086ff])
ehci_hcd 0000:00:12.2: restoring config space at offset 0x1 (was 0x2b00000, writing 0x2b00017)
ehci_hcd 0000:00:12.2: PME# disabled
ehci_hcd 0000:00:12.2: PME# enabled

Output before plugging in device:
ADDRCONF(NETDEV_UP): wlan0: link is not ready
wlan0: authenticate with c0:c1:c0:02:55:b8 (try 1)
wlan0: authenticated
wlan0: associate with c0:c1:c0:02:55:b8 (try 1)
wlan0: RX AssocResp from c0:c1:c0:02:55:b8 (capab=0x411 status=0 aid=1)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
padlock: VIA PadLock not detected.
Intel AES-NI instructions are not detected.
wlan0: no IPv6 routers present

EDIT: https://bbs.archlinux.org/viewtopic.php?id=114077

So the problem is with ehci_hcd.

EDIT: My problem was having USB autosuspend disabled in laptop-mode-tools. I fixed this by changing "CONTROL_USB_AUTOSUSPEND" in /etc/laptop-mode/conf.d/usb-autosuspend.conf to 1 and having a long "AUTOSUSPEND_TIMEOUT".

Last edited by SpleenThief (2011-03-02 03:33:06)

Offline

Board footer

Powered by FluxBB