You are not logged in.

#1 2011-03-16 21:08:20

Vrekk
Member
Registered: 2009-07-29
Posts: 27

[SOLVED] Transparent Squid Proxy

I'm trying to set up a squid proxy server on my Archlinux gateway server at my house using shorewal, but I keep getting an error when  I try to visit a web page.

Error

The requested URL could not be retrieved

While trying to process the request:

GET / HTTP/1.1
Host: [url=http://www.google.com]www.google.com[/url]
Connection: keep-alive
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Accept: application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
Accept-Encoding: gzip,deflate,sdch
Accept-Language: en-US,de;q=0.8
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.3
Cookie: rememberme=true; PREF=ID=aa1d836f8d4bb6ee:U=45838810dcca7cc1:FF=0:TM=1299631268:LM=1300071550:GM=1:IG=4:S=DwPWkiNfWG2Yr0pb; HSID=AYtItQa8qRWl_hHCi; SID=DQAAAFUBAADoohV8wXBvDFPQeQOIQ-jPoB-OQIROJKWBogZSG10IcgVbF-uGmKcNro9ESbe6-Fr5pTyNG9cFU7FKoNYK97JseRC7-6pmpjVZXnr1DlE8C5gP7VkxgnvzZZXdKnjcDnCQk5aKsm8WyJHcdNOjpr4GgmLbVXBxH12aGG-Ni7Ej_jxlCEhtsf647BQyQ8qL2f7MVvK8ixaE1Kp83BGqRGRF60b-0CG3zFQwS5nqUFKKwp2bJ6ZgjziK0BLfPNEpwXkSDhFzLb8xMABcV7LsHOjzNfP_53vmmwfZ0GxYfCbTM8Dly-jtqpoD4xMFe8eNEw2pGTtVZz-8Bkp8UJW_7Wo2BRRg9kpzm4TAtgCyds5a3ENJJeeQfqOURUhxrxs4fZCpUg_MwwE5tIwHHtuKCnjOO52HK69jVc3HU-uZTkSmtk4xGEwvHGkxED4pX0Yn3fOUrTXx11PN2O2v0_El4FBZ; NID=45=1fxILE45sNdmYQmve0YzyfEkZDpATxfktku-Rr1DSZFW7KF8oN-Q9FvveE8bh9jufE3hpx3xd_K_AHMb46nUTYsT-pO1nDW8_JFFhp39jgg3gwYk9GJSMsx75qh8vKIe


The following error was encountered:

Invalid Request
Some aspect of the HTTP Request is invalid. Possible problems:

Missing or unknown request method
Missing URL
Missing HTTP Identifier (HTTP/1.0)
Request is too large
Content-Length missing for POST or PUT requests
Illegal character in hostname; underscores are not allowed
Your cache administrator is brett@vrekk.us. 
Generated Wed, 16 Mar 2011 20:44:12 GMT by localhost.localdomain (squid/2.7.STABLE9)

/etc/shorewall/rules

COMMENT Squid
REDIRECT    loc    3128    tcp    www
ACCEPT    fw    net    tcp  www
COMMENT End Squid
DROP    net    fw    all
DROP    net    loc    all 

When I try to connect with the REDIRECT rule on I get the message above, BUT if I add the locational of the proxy server to the Network Proxy Preferences in gnome squid works as it should. Any help would be appreciated :-)

Last edited by Vrekk (2011-03-25 21:35:03)

Offline

#2 2011-03-25 15:34:09

gregf
Member
Registered: 2007-09-04
Posts: 6

Re: [SOLVED] Transparent Squid Proxy

I have nearly the same setup only difference I noticed in mine was I used $FW per the instructions found here.

So in the end it ends up looking like this.

/etc/shoarewall/rules

COMMENT Squid
REDIRECT    loc 3128    tcp www
ACCEPT      $FW net tcp www
COMMENT End Squid

$FW comes from my policy file.

/etc/shorewall/policy

$FW             all             ACCEPT

Offline

#3 2011-03-25 21:34:31

Vrekk
Member
Registered: 2009-07-29
Posts: 27

Re: [SOLVED] Transparent Squid Proxy

Thanks! It was all because of the fact that every guide I saw was for an older squid, and I didn't know about the transparent line in my squid config!

Thanks a bunch for the link, its running the way it should now :-)

Offline

Board footer

Powered by FluxBB