You are not logged in.

#1 2011-03-18 01:18:27

archthomas.butz
Member
Registered: 2011-03-15
Posts: 37

Firefox can't load XPCOM ?! [SOLVED]

I'm writing this using Crux 2.7's Firefox 3.6.10. The one I installed can't load XPCOM - whatever that is.
pacman couldn't find anything called XPCOM. There's no rush, I can use the system for the time being.

BTW, Crux accepted a lot of Slackware stuff, so why not pass that on to ARCH..

Tom.

Last edited by archthomas.butz (2011-03-24 01:05:05)

Offline

#2 2011-03-18 02:56:13

Russano
Member
Registered: 2011-03-18
Posts: 2

Re: Firefox can't load XPCOM ?! [SOLVED]

This thread, though a little dated, seems to cover your problem. It suggests that the issue is with a missing .so file, and reinstalling xulrunner should resolve the error.

Also this thread, which is a bit newer, confirms that solution.

Those threads go into a little more detail.

Offline

#3 2011-03-19 07:22:43

archthomas.butz
Member
Registered: 2011-03-15
Posts: 37

Re: Firefox can't load XPCOM ?! [SOLVED]

Did pacman -Sy, then pacman -S xulrunner - no effect: same error.

Maybe I'll try again in a few weeks time, in the meantime the
Crux-version will do me.

Tom.

Offline

#4 2011-03-19 07:44:07

lives2evil
Member
From: GMT+7
Registered: 2010-03-21
Posts: 244

Re: Firefox can't load XPCOM ?! [SOLVED]

How about try a different mirror?


tsujeruplive, tnarongisi... ... ... ... ɥsılƃuǝ sı sıɥʇ

Offline

#5 2011-03-19 21:29:23

archthomas.butz
Member
Registered: 2011-03-15
Posts: 37

Re: Firefox can't load XPCOM ?! [SOLVED]

No change - tried Vietnam and Kazachstan only hoping that theye were a bit
behind.  Does anyone know of a good mirror for the 'sick' 'xulrunner'?

Tom.

Offline

#6 2011-03-19 21:37:22

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: Firefox can't load XPCOM ?! [SOLVED]

really. do not do pacman -Sy package. do pacman -Syu. it happens because you didn't update libevent to 2.x


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#7 2011-03-23 03:01:10

archthomas.butz
Member
Registered: 2011-03-15
Posts: 37

Re: Firefox can't load XPCOM ?! [SOLVED]

Good man! I did what you said (updated libevent) and firefox worked.

Thanx,

Tom.

Offline

Board footer

Powered by FluxBB