You are not logged in.

#1 2010-06-15 19:48:57

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,326

QGtkStyle was unable to detect the current GTK+ theme.

Watching the stdout from qtconfig, when I select "GTK+" from the themes, I see:

[max@killterm3 ~]$ qtconfig
QGtkStyle was unable to detect the current GTK+ theme.

Why?  The theme is also incorrectly recognized.

This is pacman -Q:
http://codepad.org/EAspWGal

I'm also using the Aurora GTK+ theme.


Touch my kernel

Offline

#2 2010-06-15 20:07:46

txus
Member
Registered: 2008-01-23
Posts: 75

Re: QGtkStyle was unable to detect the current GTK+ theme.

Happened to me too. Turned out there were some missing environmental variables to be set.

Putting

export GTK2_RC_FILES="$HOME/.gtkrc-2.0"

in my .xinit solved it.

Hope it helps!

Last edited by txus (2010-06-15 20:08:02)

Offline

#3 2010-06-15 21:49:13

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,326

Re: QGtkStyle was unable to detect the current GTK+ theme.

hmm, I put this in .bashrc and logged out and back in but it didn't do anything.  Then, I noticed that I didn't have a .gtkrc-2.0 file, so I installed gtk-theme-switch2 and made one, but I still get the same error as above.


Touch my kernel

Offline

#4 2010-06-15 22:10:54

txus
Member
Registered: 2008-01-23
Posts: 75

Re: QGtkStyle was unable to detect the current GTK+ theme.

Strange... I did just the same, but with lxappearance, and it worked. Assuming you did log out+log in after you created the gtkrc file, I don't know how to help you further, sorry sad

Offline

#5 2010-06-17 13:27:40

slumslayer
Member
From: Belgium
Registered: 2008-09-14
Posts: 66

Re: QGtkStyle was unable to detect the current GTK+ theme.

You need to add

gtk-theme-name="yourtheme"

in gtkrc

Last edited by slumslayer (2010-06-17 13:28:51)

Offline

#6 2010-10-14 18:35:19

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,326

Re: QGtkStyle was unable to detect the current GTK+ theme.

Bringing this thread up from the dead because I'm seeing these problems on a new machine tongue  I tried creating a .gtkrc-2.0 file without luck.  Still am seeing the error.


Touch my kernel

Offline

#7 2010-10-14 19:58:20

Watermel0n
Member
Registered: 2010-03-10
Posts: 60

Re: QGtkStyle was unable to detect the current GTK+ theme.

did you also try: export GTK2_RC_FILES="$HOME/.gtkrc-2.0"? This always fixed it for me.

Offline

#8 2010-10-14 22:59:39

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,326

Re: QGtkStyle was unable to detect the current GTK+ theme.

Watermel0n wrote:

did you also try: export GTK2_RC_FILES="$HOME/.gtkrc-2.0"? This always fixed it for me.

Sure did, and it didn't help hmm


Touch my kernel

Offline

#9 2010-11-30 22:52:24

sisco311
Member
From: Romania
Registered: 2008-05-23
Posts: 111

Re: QGtkStyle was unable to detect the current GTK+ theme.

I got the same error message because my root partition was almost full...


don't drink unwashed fruit juice.
i never make predictions, especially about the future.

Offline

#10 2010-12-30 21:08:04

ugaciaka
Member
From: Italy
Registered: 2008-07-06
Posts: 140
Website

Re: QGtkStyle was unable to detect the current GTK+ theme.

I same problem here ... qt 4.71 have a bug?


I have never bought on ebay, the macbook I do not like, I do not need facebook or myspace or secondlife
I am not a nerd or lamer or troll or geek or hacker or cracker
and I have never voted to elect berlusconi

Offline

#11 2011-01-01 08:12:41

ugaciaka
Member
From: Italy
Registered: 2008-07-06
Posts: 140
Website

Re: QGtkStyle was unable to detect the current GTK+ theme.

LOL. If I install glabels the problem disappear. Glabels, or another dependecies, correct qgtkstyle ...


I have never bought on ebay, the macbook I do not like, I do not need facebook or myspace or secondlife
I am not a nerd or lamer or troll or geek or hacker or cracker
and I have never voted to elect berlusconi

Offline

#12 2011-01-01 15:21:27

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: QGtkStyle was unable to detect the current GTK+ theme.

Does the problem return if you uninstall Glabels?

Offline

#13 2011-01-01 16:24:07

hurleyef
Member
Registered: 2010-06-22
Posts: 71

Re: QGtkStyle was unable to detect the current GTK+ theme.

I reinstalled arch yesterday (switched to x64) and came out with the same issue.

Following from ugaciaka's comment about glabels I installed libgnomeui (which is a dependency of glabels) and that fixed the issue after a relog.  I then pacman -Rd'ed libgnomeui to see if one of it's several dependencies fixed it and the problem didn't return.  So I reinstalled libgnomeui and pacman -Rnsc'ed it to restore the system to it's pre-libgnomeui state and the problem has still not returned.

I do, however, get a new error from qtconfig:
(<unknown>:15835): Gtk-WARNING **: Unable to locate theme engine in module_pah: "mist",
As I said, theming of qt apps works fine though.  Better than before the reinstall, actually, as virtualbox is now themed, whereas it always wanted to do it's own thing before.

edit:
Installing gtk-engines solved the "Unable to locate theme engine in module_pah: "mist"" error, as per this thread.

Last edited by hurleyef (2011-01-01 16:41:47)

Offline

#14 2011-02-04 09:19:36

skull-y
Member
From: Germany/Saxony-Anhalt /Halle
Registered: 2009-01-25
Posts: 28

Re: QGtkStyle was unable to detect the current GTK+ theme.

pacman -S libgnomeui

That solves the problem with the style of qt-apps. Its the dependecie of glabels.

Offline

#15 2011-03-29 00:01:47

vi3dr0
Member
From: Poland
Registered: 2009-03-22
Posts: 208

Re: QGtkStyle was unable to detect the current GTK+ theme.

Hi,

Is there any other option? libgnomeui brings 16 other packages as dependencies, that's just sick.


Thinkpad T61p : T7700 | 4GB RAM | nVidia FX 570M | Intel 4965
Arch64 @ Openbox

Offline

#16 2011-05-23 03:44:55

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,326

Re: QGtkStyle was unable to detect the current GTK+ theme.

Old thread, same topic = bump.

Anyone figure out what this is?  I'm installing libgnomeui atm, but like vi3dr0 said, that's a lot of dependencies :s


Touch my kernel

Offline

#17 2011-05-23 10:08:16

kaira
Member
Registered: 2010-09-30
Posts: 10

Re: QGtkStyle was unable to detect the current GTK+ theme.

For me exporting

export GTK2_RC_FILES="$HOME/.gtkrc-2.0"

always is sufficient, the thing is, you must export it before your DE is started, so .bashrc will never work. In my case i added it to .xinitrc like this

export GTK2_RC_FILES="$HOME/.gtkrc-2.0"
openbox-session

.
I hope this will help, and forgive me my poor english.

Offline

#18 2011-05-25 02:30:29

Diaz
Member
From: Lisbon, Portugal
Registered: 2008-04-16
Posts: 361
Website

Re: QGtkStyle was unable to detect the current GTK+ theme.

Or put it in /etc/profile.d, basically the same wink.


And i found this is a really weird thing.
I'm on xfce and i expect the xfce settings daemon to take care of those stuff. But if that file doesn't exist Qt applications stay with the default Qt theme.
So i create that gtkrc2 file and export it. Then i launch a Qt application and it is themed as i expect. Problem solved... Or so you would think.
So, in my expectation i think that the DE settings daemon should take care of those stuff and it really does, because if i go to the appearence settings and change the theme all Qt applications get it.
Now we get to the weird conclusion that Qt applications don't really get the theme from the gtkrc2 file, they just require it for nothing.
At least if i simply export the file with this line: gtk-theme-name = "hello world" it simply works.

Well i call this weird and stupid.


edit: this happens because i don't have gconf installed nor want it just for this. I hate things that pollute my $HOME

Last edited by Diaz (2011-06-07 11:09:39)


Owner of Asus 1215B :: User of Xfce :: Vasco Dias @blog

Offline

#19 2011-06-02 14:12:13

dejavu
Member
Registered: 2008-05-26
Posts: 103

Re: QGtkStyle was unable to detect the current GTK+ theme.

For me worked it also with this steps on a Gnome 3.0 install:

- installed libgnomeui (with all its dependencies)
- started a QT4 program (VLC)
- uninstalled libgnomeui (with all its dependencies)

Offline

#20 2011-06-07 04:53:11

FIlIPy65
Member
From: Brazil, Paraiba, Joao Pessoa
Registered: 2011-05-01
Posts: 14

Re: QGtkStyle was unable to detect the current GTK+ theme.

Just install "gconf", is so less dependencies, and worked to me. Since, gconf is used to tell what is your theme to QT: http://bugreports.qt.nokia.com/browse/QTBUG-5545

Offline

#21 2011-06-12 10:58:24

cyrusza
Member
From: Italy
Registered: 2011-05-18
Posts: 29
Website

Re: QGtkStyle was unable to detect the current GTK+ theme.

Installing gconf alone doesn't work if you don't have gnome. In that case you need to set theme name with this command:

gconftool-2 --set --type string /desktop/gnome/interface/gtk_theme your-theme-name

Change "your-theme-name" with your theme name big_smile

Last edited by cyrusza (2011-06-12 10:58:53)

Offline

#22 2011-07-21 22:33:11

mtfk
Member
Registered: 2011-04-14
Posts: 3

Re: QGtkStyle was unable to detect the current GTK+ theme.

I had the same error:

QGtkStyle was unable to detect the current GTK+ theme.

During printer driver instalation. And the thing was that root account didn't have all necessery files in home direcotry.
I just login in gnome as roor user (to create all files for gtk) and then all works.

Offline

#23 2011-08-09 23:03:20

cgarcia
Member
Registered: 2010-08-09
Posts: 37

Re: QGtkStyle was unable to detect the current GTK+ theme.

Curiously, I fixed this by selecting "Cleanlooks" as GUI style in qtconfig. Any other choice gives the error. I use XFCE. No need to touch any file (I haven't gnome packages, neither .gtkrc-2.0)

Offline

#24 2011-08-10 02:40:46

dipesh.nomad
Member
Registered: 2011-01-24
Posts: 14

Re: QGtkStyle was unable to detect the current GTK+ theme.

skull-y wrote:
pacman -S libgnomeui

That solves the problem with the style of qt-apps. Its the dependecie of glabels.

This works.

Offline

#25 2011-08-23 01:03:21

foolosophy
Member
Registered: 2009-04-17
Posts: 48

Re: QGtkStyle was unable to detect the current GTK+ theme.

dipesh.nomad wrote:
skull-y wrote:
pacman -S libgnomeui

That solves the problem with the style of qt-apps. Its the dependecie of glabels.

This works.


Thank you!

Offline

Board footer

Powered by FluxBB