You are not logged in.

#1 2005-05-18 00:11:58

rgalgon
Member
From: RIT
Registered: 2005-01-09
Posts: 11
Website

ipw2200 Monitor Mode Implemented

Just an announcement that the ipw2200 Intel PRO/Wireless 2200BG Driver found in Centrino systems now supports Monitor Mode :-). This means kismet, etc. now works with that driver. Neither extra nor testing is up to this version yet but its easy to modify the PKGBUILD in ABS and I'm sure that it will be moved into testing and then extra very soon any way as they seem to keep a good eye on that package. :-) Enjoy everyone.

Offline

#2 2005-05-31 14:29:43

bardo
Member
From: Milano, Italia
Registered: 2004-12-06
Posts: 90
Website

Re: ipw2200 Monitor Mode Implemented

Yay! big_smile
If you have the current version of the package, however, you can use monitor mode with kismet. In /etc/kismet.conf just set the driver to ipw2100, it will work wink
Oh, yes, and don't forget a

iwconfig eth1 mode monitor

otherwise kismet won't start properly...

Have fun!


dreaming in digital / living in realtime / thinking in binary / talking in ip / welcome to our world...

Offline

#3 2005-06-05 03:16:33

m3thodic
Member
Registered: 2004-08-24
Posts: 21

Re: ipw2200 Monitor Mode Implemented

anyone get this working? im running ipw2200 1.0.4 with the 2.3 firmware and when i try to set my wireless to monitor mode i get this:

[root@deathstar ipw2200]# iwconfig eth0 mode monitor
Error for wireless request "Set Mode" (8B06) :
    SET failed on device eth0 ; Invalid argument.

anyone get this to work?

Offline

#4 2005-06-05 11:36:14

bardo
Member
From: Milano, Italia
Registered: 2004-12-06
Posts: 90
Website

Re: ipw2200 Monitor Mode Implemented

First: is eth0 your wireless device? It seems somewhat strange to me, though it depends on the order you modprobe your modules.
Second: do you use the precompiled arch package or do you build it yourself? I do it by myself because of discrepancies with the latest kernel release and the arch headers version. I just follow make && make install and everything goes ok.

I saw something about monitor mode support being disabled by default in the docs, although I didn't have to manually switch it on. Try to look at the README and other files.


dreaming in digital / living in realtime / thinking in binary / talking in ip / welcome to our world...

Offline

#5 2005-06-05 18:49:32

m3thodic
Member
Registered: 2004-08-24
Posts: 21

Re: ipw2200 Monitor Mode Implemented

Yes eth0 is my wireless device.... and yes I am using the default module from pacman.... i will try to build it out of abs and see if that works better, thanks for the tip.

Offline

Board footer

Powered by FluxBB