You are not logged in.

#1 2011-04-14 19:07:48

Corubba
Member
From: Germany
Registered: 2010-11-14
Posts: 80

Atheros AR922x dont like 802.11n since todays Kernel-Update

Hey Guys,

Inside of my Desktop works an D-Lan PCI WLAN card with the Atheros AR922s chipset, supported by the ath9k Kernel Module. The last half year als works fine, until today morning after i upgraded my kernel to version 2.6.38.2-1, and after the reboot my WLAN sucks. I checked with my Laptop, all fine, so the Source was not the router or my internet connection. So i tested around with the 802.11 standards and different Channels, and i could figure out that when i use some combination of 802.11n with b or/and g it goes to low speed (send normal but recieve only around 100kb/s) but iwconfig and the connection-info of the NetworkManager-Applet shows normal 300MB/s.

I also updated my laptop which uses an Intel Wifi adapter, no problems.

Any ideas? smile maybe some kind of module bug?


greetz corubba

EDIT: oh i forgot, the signal strength is always 75+, mostly above 90. WPA2-Encrypted.

Last edited by Corubba (2011-04-14 19:15:22)

Offline

#2 2011-04-14 19:31:51

king.flasher.dave
Member
From: Berlin
Registered: 2008-11-25
Posts: 140
Website

Re: Atheros AR922x dont like 802.11n since todays Kernel-Update

Confirmed, have the same issue with a AR928X since kernel2.6.38 (bug report?)
Connection speed is extremely choppy. Right now there's noone but me in this network and surfing becomes paaaaaainful.

@Corubba: Did you find a solution through working out your routers settings?
Will try the same now... but that might break WLAN support for an older adapter in my network... grml.. -_-


Speak when you are angry and you will make the best speech you'll ever regret.

Offline

#3 2011-04-14 19:32:58

milomouse
Member
Registered: 2009-03-24
Posts: 940
Website

Re: Atheros AR922x dont like 802.11n since todays Kernel-Update

I can confirm this problem since 2.6.38 with AR9287 with ath9k, after upgrading from 2.6.36. sad  Same scenario, but no ideas so far although I haven't done a thorough search yet, just suffering with slow internet since then.. I may actually downgrade.

Offline

#4 2011-04-14 22:10:03

Corubba
Member
From: Germany
Registered: 2010-11-14
Posts: 80

Re: Atheros AR922x dont like 802.11n since todays Kernel-Update

@king.flasher.dave: i set my router to use 802.11b+g at channel 10 (2,457GHz) with full power. Seems to work but only with 54MB/s, no 300 support.

Offline

#5 2011-04-14 23:25:17

king.flasher.dave
Member
From: Berlin
Registered: 2008-11-25
Posts: 140
Website

Re: Atheros AR922x dont like 802.11n since todays Kernel-Update

@Corubba: ugh... that sucks then... only one non n-compatible card in the network... the other guys will be... "pleased" :>


Speak when you are angry and you will make the best speech you'll ever regret.

Offline

#6 2011-04-15 00:32:55

milomouse
Member
Registered: 2009-03-24
Posts: 940
Website

Re: Atheros AR922x dont like 802.11n since todays Kernel-Update

@anyone:  https://bugzilla.kernel.org/show_bug.cgi?id=31452#c19

I created the /etc/modprobe.d/ath9.conf file with

options ath9k nohwcrypt=1

and rebooted my computer (or alternatively rmmod and modprobe?) and so far so good, but only time will tell.  Can anyone else try this?

Edit:  Some odd hours later with this change and it's still going great.  I suggest trying this.

Last edited by milomouse (2011-04-15 03:43:48)

Offline

#7 2011-04-15 09:55:57

king.flasher.dave
Member
From: Berlin
Registered: 2008-11-25
Posts: 140
Website

Re: Atheros AR922x dont like 802.11n since todays Kernel-Update

@milomouse: thanks! Can confirm this to work (right now)! Seems to fix the speed issues. Hope they'll fix that bug soon in kernel :>


Speak when you are angry and you will make the best speech you'll ever regret.

Offline

#8 2011-04-15 13:09:42

Corubba
Member
From: Germany
Registered: 2010-11-14
Posts: 80

Re: Atheros AR922x dont like 802.11n since todays Kernel-Update

also working for me. thx milomouse

Offline

#9 2011-04-27 08:43:27

kvn
Member
Registered: 2010-08-13
Posts: 12

Re: Atheros AR922x dont like 802.11n since todays Kernel-Update

Thank you so much for that fix @milomouse. I actually tried so hard to believe it was my router at first, then my computer placement, then decided to google the chipset name + arch linux, which lead me here. All my transfers were capped at 50 kB/s and I was going mad. Now back to normal!

Offline

#10 2011-05-03 22:15:12

king.flasher.dave
Member
From: Berlin
Registered: 2008-11-25
Posts: 140
Website

Re: Atheros AR922x dont like 802.11n since todays Kernel-Update

@kvn: It's not a fix, but a workaround. Disabling the hwcrypt settings is not a solution. You should revert that setting when the fix has been applied to kernel. Don't forget about it!


Speak when you are angry and you will make the best speech you'll ever regret.

Offline

#11 2011-05-09 11:37:23

kvn
Member
Registered: 2010-08-13
Posts: 12

Re: Atheros AR922x dont like 802.11n since todays Kernel-Update

Will do, thanks for the correction.

Offline

Board footer

Powered by FluxBB