You are not logged in.

#1 2011-05-03 22:47:57

TRiBLy
Member
Registered: 2010-02-22
Posts: 5

Wakfu - game wont start on x64

Heyho dudes, i got a little problem with the game Wakfu on a x64 machine.

When i try to start the UpLauncher i get always lib errors, like "libcrypto.so.0.9.8 not found" and "libssl.so.0.9.8 not found". And i just don't know how to fix them. I tried linking the libs libcrypto.so to libcrypto.so.0.9.8 and for some libs it worked, but then at, i think, libssl it didnt work anymore.

Did anyone, or can anyone of you play this game on a x64 machine?

Last edited by TRiBLy (2011-05-05 18:30:37)

Offline

#2 2011-05-03 22:51:21

chris-kun
Member
From: SF Bay Area
Registered: 2010-09-07
Posts: 235
Website

Re: Wakfu - game wont start on x64

send me a beta key and I can try big_smile tongue


[home page] -- [code / configs]

"Once you go Arch, you must remain there for life or else Allan will track you down and break you." -- Bregol

Offline

#3 2011-05-03 22:54:31

TRiBLy
Member
Registered: 2010-02-22
Posts: 5

Re: Wakfu - game wont start on x64

Reading isnt everyones strength: "Play Wakfu Open Beta etc.etc." wink

Offline

#4 2011-05-03 23:13:30

chris-kun
Member
From: SF Bay Area
Registered: 2010-09-07
Posts: 235
Website

Re: Wakfu - game wont start on x64

open beta hasn't arrived yet for north america =/


[home page] -- [code / configs]

"Once you go Arch, you must remain there for life or else Allan will track you down and break you." -- Bregol

Offline

#5 2011-05-04 15:37:41

jelly
Trusted User (TU)
From: /dev/null
Registered: 2008-06-10
Posts: 711

Re: Wakfu - game wont start on x64

is this a binary, if so then you're unfortuate but we use openssl1.0.0.d and the creators use an old version.

Offline

#6 2011-05-04 21:25:40

TryA
Member
Registered: 2010-01-01
Posts: 23

Re: Wakfu - game wont start on x64

Someone in the AUR provides the old libraries for multilib systems in binary form (not ideal, but it does the work) : [link]

EDIT: Phewww, OpenSSL AUR packages are kind of a mess... Needs a serious clean-up...

Last edited by TryA (2011-05-04 21:34:53)

Offline

#7 2011-05-05 09:40:26

TRiBLy
Member
Registered: 2010-02-22
Posts: 5

Re: Wakfu - game wont start on x64

Well I installed the binaries from the AUR, and now i get this error:

./UpLauncher: /usr/lib32/libpng12.so.0: version `PNG12_0' not found (required by ./UpLauncher)
./UpLauncher: /usr/lib32/libcrypto.so.0.9.8: no version information available (required by ./UpLauncher)
./UpLauncher: /usr/lib32/libssl.so.0.9.8: no version information available (required by ./UpLauncher)

Last edited by TRiBLy (2011-05-05 09:55:38)

Offline

#8 2011-05-05 11:07:05

TryA
Member
Registered: 2010-01-01
Posts: 23

Re: Wakfu - game wont start on x64

Oh... You need lib32-libpng12 too... But before starting the program again, do a ldd ./UpLauncher to see which libraries may be missing.

Offline

#9 2011-05-05 13:09:40

TRiBLy
Member
Registered: 2010-02-22
Posts: 5

Re: Wakfu - game wont start on x64

Didn't knew about the "ldd" command, thx.

I've installed the lib32-libpng12 which you posted, and now i can run the UpLaunch! big_smile

Thank you very much smile

€DIT:

Ok, i can start the UpLaunch, and update the game, but when I hit play, i see the splashscreen...and that's it. No error, nothing, just the splashscreen...

€DIT2:

Since it's in the AUR now, I build it from there, but still have the same error.

Last edited by TRiBLy (2011-05-05 19:28:10)

Offline

#10 2011-05-24 16:48:11

splashy
Member
Registered: 2010-08-21
Posts: 128

Re: Wakfu - game wont start on x64

Install lib32-openssl098 and it would start! A new aur package one remplacing the old one and deprecated lib32-opensssl-compatibility.

Offline

#11 2011-07-03 21:19:18

xiliyi
Member
Registered: 2011-05-14
Posts: 41

Re: Wakfu - game wont start on x64

This didn't solve my problem. I installed the package wakfu from AUR. The updater runs just fine, but when trying to launch the game, I get this message:

/opt/wakfu/UpLauncher: /usr/lib32/libcrypto.so.0.9.8: no version information available (required by /opt/wakfu/UpLauncher)
/opt/wakfu/UpLauncher: /usr/lib32/libssl.so.0.9.8: no version information available (required by /opt/wakfu/UpLauncher)
testing JVM in /opt/wakfu/jre ...

The package comments and this thread (http://forum.wakfu.com/en/105-technical … ash-screen) didn't help me, either. Does anyone know how to solve this?

edit: I'm running arch 64 on a Thinkpad X201 (3323) with xmonad as window manager. I have openjdk 6 installed.

Last edited by xiliyi (2011-07-03 21:21:20)

Offline

#12 2011-07-11 07:26:12

SprawlingRabbit
Member
Registered: 2011-07-10
Posts: 1

Re: Wakfu - game wont start on x64

Don't know if you already found the tip.

rm /opt/wakfu/userPreferences.properties should do

I'm on arch 64. The game won't start if you already configured it to be full screen for instance, so you have to re-do it each time by suppressing the conf.
And I also had to install "_lib32-libxxf86vm" and "jogl" first even if it's supposed to be included in the package...

Offline

#13 2011-07-11 19:25:05

xiliyi
Member
Registered: 2011-05-14
Posts: 41

Re: Wakfu - game wont start on x64

SprawlingRabbit wrote:

Don't know if you already found the tip.

rm /opt/wakfu/userPreferences.properties should do

I'm on arch 64. The game won't start if you already configured it to be full screen for instance, so you have to re-do it each time by suppressing the conf.
And I also had to install "_lib32-libxxf86vm" and "jogl" first even if it's supposed to be included in the package...

Thanks. The two packages you mentioned (without the "_"), I already had them installed. Uninstalling does not help, either.
I don't have the /opt/wakfu/userPreferences.properties file. You sure it should be there?
error.log spits out a lot of errors, all concerning java. I have Java installed, though.

Offline

#14 2011-08-12 11:54:53

M4he
Member
Registered: 2011-08-11
Posts: 75

Re: Wakfu - game wont start on x64

After fiddling a lot with 32libs I finally got the launcher working and the game installed/updated on my x64 setup.

When I try to start the game now I always get

javax.media.opengl.GLException: Unable to select one of the provided GLCapabilities

EDIT: SOLVED!!!

First I had to remove lib32-mesa (lib32-libgl) with all dependencies
Then install lib32-nvidia-utils and lib32-libxxf86vm and it works!

To get sound working I needed:
lib32-libcanberra
lib32-libcanberra-pulse
lib32-alsa-plugins

Everything works now! Yay!

Last edited by M4he (2011-08-12 12:53:56)


Arch - makes me feel right at /home

Offline

#15 2012-03-17 19:08:37

arch_rise
Member
From: Colorado Springs
Registered: 2011-12-24
Posts: 2

Re: Wakfu - game wont start on x64

For anyone using Sandybridge graphics on a 64 bit system, you may have to download lib32-intel-dri to get it to work.  That's what did it for me.

Offline

#16 2012-04-08 16:21:48

chris-kun
Member
From: SF Bay Area
Registered: 2010-09-07
Posts: 235
Website

Re: Wakfu - game wont start on x64

Just installed it, I get to the splash screen, hit play, then it crashes. No console output save for /bin/sh ./Wakfu -Len -Cna. Any ideas?


[home page] -- [code / configs]

"Once you go Arch, you must remain there for life or else Allan will track you down and break you." -- Bregol

Offline

#17 2012-04-10 15:25:18

darquandier
Member
Registered: 2011-09-26
Posts: 10

Re: Wakfu - game wont start on x64

Thanks !

Offline

#18 2012-04-15 16:42:46

NSB-fr
Member
Registered: 2010-01-23
Posts: 45

Re: Wakfu - game wont start on x64

Hi there,

I came here because the AUR package mention this thread.

With gvfs installed on my config (openbox standalone) I get some strange behavior. For example thunar is slow on first launch. Also for some reason udisk automounting works half of time. I am not trying to solve those problems (at least not now) and this is just to describe the context.

So I am wondering why gvfs is listed as a dependency for this AUR package. I studied the PKGBUILD and the install script (wakfu_unix.sh) with no luck. I even removed gvfs and its dependencies and the game still work with no problems (played more than hour). Google is not of any help either. I certainly have missed something but can't figure what.

Any help appreciated.


Carpe Diem

Offline

Board footer

Powered by FluxBB