You are not logged in.

#1 2011-05-05 18:45:00

vendion
Member
From: Tennessee, USA
Registered: 2010-03-10
Posts: 201
Website

nm-applet permission problem

I am trying to use nm-applet under Awesome on my netbook, before I was just using cnetworkmanager but after the last update to NetworkManager cnetworkmanager is now broken.  Wired connections work fine but when I try to connect to a wireless AP I see this error in xterm:

** (nm-applet:5116): WARNING**: Failed to add/activate connection: (32) Insufficient privileges

I have version 0.8.999 of nm-applet and network manager installed, what kind of privileges does it need that knetworkmanager (also have KDE installed on the side) and cnetworkmanager doesn't?

Offline

#2 2011-05-05 21:21:34

lordnikon
Member
Registered: 2011-02-26
Posts: 3

Re: nm-applet permission problem

Got exactly the same problem...
is there any way to update only the packages which are marked like <stable> or sth like that?

Got kernel-crashes and different problems with networkmanager but it finally came up to the one error descripted above... would be very happy with any help smile

btw: didnt chance anything except the update, so the same user is executing nm-applet...

Offline

#3 2011-05-06 16:55:26

sunaku
Member
From: /dev/tty
Registered: 2010-09-29
Posts: 140
Website

Re: nm-applet permission problem

I'm having the exact same issue.

** (nm-applet:2895): WARNING **: Failed to add/activate connection: (32) Insufficient privileges.

This thread suggests to downgrade the networkmanager package, but I'm not able to downgrade successfully (per the example in pacman manpage):

# sudo pacman -S 'networkmanager<0.8.999-1'
error: target not found: networkmanager<0.8.999-1

Offline

#4 2011-05-07 21:53:58

lordnikon
Member
Registered: 2011-02-26
Posts: 3

Re: nm-applet permission problem

I tried to downgrade by using the pkg-cache but it seems to be more difficult because of different versions on which it depends (networkmanager alswell as its applet)...
by reinstalling at least by saved connections (gnome-keyring) were fixed...

i think its a "easy" permission-problem by saving a new Auto-Connection for the unknown ESSID.... should be fixed with a patch soon i hope smile

Offline

#5 2011-05-07 22:12:44

sunaku
Member
From: /dev/tty
Registered: 2010-09-29
Posts: 140
Website

Re: nm-applet permission problem

This bug report comment pointed out the exact versions of the NetworkManager packages that work properly:

networkmanager-0.8.3-0.20110113-x86_64.pkg.tar.xz
network-manager-applet-0.8.2-4-x86_64.pkg.tar.xz
networkmanager-vpnc-0.8.2-1-x86_64.pkg.tar.xz


I downloaded these packages from http://schlunix.org/archlinux/extra/os/x86_64/, installed them, ran `sudo /etc/rc.d/networkmanager restart`, and restarted my desktop environment, and now the wireless works again! cool

Offline

#6 2011-05-08 00:47:41

jlindgren
Member
Registered: 2011-02-27
Posts: 240

Re: nm-applet permission problem

Having the exact same problem.  Has anyone filed a bug on this?

Offline

#7 2011-05-08 21:56:14

Chrilleee
Member
Registered: 2011-04-27
Posts: 33

Re: nm-applet permission problem

I'm having this problem too.

jlindgren wrote:

Having the exact same problem.  Has anyone filed a bug on this?

Seems like it: https://bugzilla.gnome.org/show_bug.cgi?id=649422

Offline

#8 2011-06-12 17:09:11

jlindgren
Member
Registered: 2011-02-27
Posts: 240

Re: nm-applet permission problem

Well, I have finally figured out a solution to this (other than downgrading).  Tried to document it under:
https://wiki.archlinux.org/index.php/Ne … ermissions

Offline

#9 2011-06-15 21:02:50

sunaku
Member
From: /dev/tty
Registered: 2010-09-29
Posts: 140
Website

Re: nm-applet permission problem

jlindgren wrote:

Well, I have finally figured out a solution to this (other than downgrading).  Tried to document it under:
https://wiki.archlinux.org/index.php/Ne … ermissions

Although the above instructions fixed the

** (nm-applet:2895): WARNING **: Failed to add/activate connection: (32) Insufficient privileges.

error, they uncovered a new error:

** (nm-applet:2346): WARNING **: <WARN>  activate_connection_cb(): Connection activation failed: No user settings service available

My user account is a member of the "network" group:

> groups
lp wheel games network video audio optical storage scanner power users

What am I doing wrong?

Offline

#10 2011-06-15 21:37:55

jelly
Administrator
From: /dev/null
Registered: 2008-06-10
Posts: 714

Re: nm-applet permission problem

Networkmanager needs more stuff to work on not Gnome/KDE window managers. Make sure you run:

/usr/lib/notification-daemon-1.0/notification-daemon &
/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1&

Offline

#11 2011-06-15 23:17:36

sunaku
Member
From: /dev/tty
Registered: 2010-09-29
Posts: 140
Website

Re: nm-applet permission problem

jelly wrote:

Networkmanager needs more stuff to work on not Gnome/KDE window managers. Make sure you run:

/usr/lib/notification-daemon-1.0/notification-daemon &
/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1&

Thanks, I did not have /usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 running.

But now there is yet another error:

** (nm-applet:856): WARNING **: Failed to add/activate connection: (32) Not authorized to control networking.

Why does that occur?  I'm already a member of the "network" group: 

> groups
lp wheel games network video audio optical storage scanner power users

Thanks for your consideration.

Offline

#12 2011-07-31 16:09:32

statc
Member
Registered: 2011-04-14
Posts: 29

Re: nm-applet permission problem

Sorry for hijacking the thread... Could someone help me, please? I have the same "Insufficient privileges" problem as described in the first post. After logging in I *do have* the executable from polkit-gnome (/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1) running, but in "ps aux" I can see it belongs to "gdm" user, not me. Thus, the questions:

- For users who use GDM and don't have the "Insufficient privileges" problem: do you have on or two polkit-gnome-auth-agents running?
- If I should make the auth agent start on behalf of me instead of GDM, how do I do it?
- If I should run an auth agent in additional to the existing one that is run by GDM, what is the proper way of doing it? Can I just add "/path/polkit-gnome-authentication-agent-1" to autostart?

Additional info: if I run the auth agent manually from terminal after logging in, the "insufficient privileges" problem does not occur.

Offline

Board footer

Powered by FluxBB