You are not logged in.

#1 2011-05-17 08:39:49

Registered: 2007-07-27
Posts: 127

ssh: connection refused on netbook installation

I have a very odd ssh problem and so far there has been no solution or hint at where I should even start to debug.

If I try and ssh into my netbook I get the error mentioned:

ssh -v
OpenSSH_5.8p2, OpenSSL 1.0.0d 8 Feb 2011                                                                                                                                                    
debug1: Reading configuration data /etc/ssh/ssh_config                                                                                                                                      
debug1: Connecting to [] port 22.                                                                                                                                    
debug1: connect to address port 22: Connection refused                                                                                                                          

BUT - if I connect from the netbook to any other PC via ssh first, then all of a sudden ssh works and I can ssh into the netbook.
It is almost like ssh is "sleeping" and need a function call to get enabled.

Restarting sshd does not work, I need to connect to a machine outside for ssh to function on the netbook. Frustrating to say the least.

Here is the relevant configs, I have tried various methods mentioned on the forums and nothing seems to work:

/etc/ssh/sshd_config - the relevant entries that I have changed and tried without luck:

#Port 22                                                                                                                                                                                    
#AddressFamily any                                                                                                                                                                          
#ListenAddress ::                                                                                                                                                                           
ChallengeResponseAuthentication no                                                                                                                                                          
UsePAM yes                                                                                                                                                                 
Subsystem       sftp    /usr/lib/ssh/sftp-server                                                                                                                                            


# /etc/hosts.allow                                                                                                                                                                          
sshd: ALL                                                                                                                                                                                   
# End of file 


# /etc/hosts.deny                                                                                                                                                                           
#ALL: ALL                                                                                                                                                                                   
# End of file  


DAEMONS=(syslog-ng dbus gpm wicd network avahi-daemon sshd slim laptop-mode @netfs @crond @samba @ntpd @cups)

I'm using a wireless connection with WICD, if that helps any.


Board footer

Powered by FluxBB