You are not logged in.

#1 2011-06-29 03:34:40

jholbrook
Member
Registered: 2010-07-08
Posts: 18

Laptop kills my wireless router

I've recently purchased a new Lenovo Thinkpad T420s.

I have a Buffalo WHR-HP-G300N running the latest version of DD-WRT.

The wireless router has been working fine for over a year. I've had other laptops attach. The kids ipods, iphones, etc all work great with it.

I can successfully connect to the router without any problems. If I do minimal activities (like ping google.ca) then the router works fine. As soon as I try to visit any web pages the router completely hangs. I actually have to unplug and plug it back in.

Here's the last bunch of lines on /var/log/everything.log

Jun 28 20:22:00 jhlaptop NetworkManager[763]: <info>   gateway 172.30.0.1
Jun 28 20:22:00 jhlaptop NetworkManager[763]: <info>   nameserver '172.30.0.1'
Jun 28 20:22:00 jhlaptop NetworkManager[763]: <info>   domain name 'localdomain'
Jun 28 20:22:00 jhlaptop NetworkManager[763]: <info> Activation (wlan0) Stage 5 of 5 (IP Configure Commit) scheduled...
Jun 28 20:22:00 jhlaptop NetworkManager[763]: <info> Activation (wlan0) Stage 4 of 5 (IP4 Configure Get) complete.
Jun 28 20:22:00 jhlaptop NetworkManager[763]: <info> Activation (wlan0) Stage 5 of 5 (IP Configure Commit) started...
Jun 28 20:22:01 jhlaptop NetworkManager[763]: <info> (wlan0): device state change: ip-config -> activated (reason 'none') [70 100 0]
Jun 28 20:22:01 jhlaptop NetworkManager[763]: <info> Policy set 'mynet 1' (wlan0) as default for IPv4 routing and DNS.
Jun 28 20:22:01 jhlaptop NetworkManager[763]: <info> Activation (wlan0) successful, device activated.
Jun 28 20:22:01 jhlaptop NetworkManager[763]: <info> Activation (wlan0) Stage 5 of 5 (IP Configure Commit) complete.
Jun 28 20:22:01 jhlaptop dbus[738]: [system] Activating service name='org.freedesktop.nm_dispatcher' (using servicehelper)
Jun 28 20:22:01 jhlaptop dbus[738]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
Jun 28 20:22:20 jhlaptop kernel: [  807.315592] iwlagn 0000:03:00.0: iwlagn_tx_agg_start on ra = 00:23:a4:13:67:44 tid = 0
Jun 28 20:22:26 jhlaptop kernel: [  813.474483] iwlagn 0000:03:00.0: Stopping AGG while state not ON or starting
Jun 28 20:22:26 jhlaptop kernel: [  813.547619] cfg80211: Calling CRDA to update world regulatory domain
Jun 28 20:22:26 jhlaptop NetworkManager[763]: <info> (wlan0): supplicant interface state: completed -> disconnected
Jun 28 20:22:26 jhlaptop NetworkManager[763]: <info> (wlan0): supplicant interface state: disconnected -> scanning
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> (wlan0): device state change: activated -> disconnected (reason 'supplicant-timeout') [100 30 11]
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> (wlan0): deactivating device (reason: 11).
Jun 28 20:22:42 jhlaptop dhcpcd[1670]: received SIGTERM, stopping
Jun 28 20:22:42 jhlaptop dhcpcd[1670]: wlan0: removing interface
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> (wlan0): canceled DHCP transaction, DHCP client pid 1670
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <warn> (pid 1670) unhandled DHCP event for interface wlan0
Jun 28 20:22:42 jhlaptop dbus[738]: [system] Activating service name='org.freedesktop.nm_dispatcher' (using servicehelper)
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> (wlan0): supplicant interface state: scanning -> disconnected
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <warn> Couldn't disconnect supplicant interface: This interface is not connected.
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> Activation (wlan0) starting connection 'mynet 1'
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> (wlan0): device state change: disconnected -> prepare (reason 'none') [30 40 0]
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> (wlan0): device state change: prepare -> config (reason 'none') [40 50 0]
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> Activation (wlan0/wireless): access point 'mynet 1' has security, but secrets are required.
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> (wlan0): device state change: config -> need-auth (reason 'none') [50 60 0]
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> (wlan0): device state change: need-auth -> prepare (reason 'none') [60 40 0]
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> (wlan0): device state change: prepare -> config (reason 'none') [40 50 0]
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> Activation (wlan0/wireless): connection 'mynet 1' has security, and secrets exist.  No new secrets needed.
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> Config: added 'ssid' value 'mynet'
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> Config: added 'scan_ssid' value '1'
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> Config: added 'key_mgmt' value 'WPA-PSK'
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> Config: added 'psk' value '<omitted>'
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> Config: set interface ap_scan to 1
Jun 28 20:22:42 jhlaptop dbus[738]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
Jun 28 20:22:42 jhlaptop NetworkManager[763]: <info> (wlan0): supplicant interface state: disconnected -> scanning
Jun 28 20:23:06 jhlaptop NetworkManager[763]: <info> (wlan0): device state change: config -> disconnected (reason 'user-requested') [50 30 39]
Jun 28 20:23:06 jhlaptop NetworkManager[763]: <info> (wlan0): deactivating device (reason: 39).
Jun 28 20:23:06 jhlaptop NetworkManager[763]: <warn> Couldn't disconnect supplicant interface: This interface is not connected.
Jun 28 20:23:07 jhlaptop NetworkManager[763]: <info> (wlan0): supplicant interface state: scanning -> inactive

Details on hardware:

iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:
iwlagn: Copyright(c) 2003-2010 Intel Corporation
iwlagn 0000:03:00.0: Detected Intel(R) Centrino(R) Ultimate-N 6300 AGN, REV=0x74

# cat /etc/rc.conf | egrep -v "(^#.*|^$)"

LOCALE="en_US.UTF-8"
DAEMON_LOCALE="no"
HARDWARECLOCK="localtime"
TIMEZONE="America/Vancouver"
KEYMAP="us"
CONSOLEFONT=
CONSOLEMAP=
USECOLOR="yes"
VERBOSE="3"
MODULES=(tp_smapi hdaps)
UDEV_TIMEOUT=30
USEDMRAID="no"
USEBTRFS="no"
USELVM="no"
HOSTNAME="jhlaptop"
NETWORK_PERSIST="no"
DAEMONS=(hwclock syslog-ng dbus networkmanager @alsa acpid netfs crond slim)

# pacman -Ss wireless | grep installed

core/wireless_tools 29-4 [installed]
core/wpa_supplicant 0.7.3-3 (base) [installed]

My /etc/wpa_supplicant.conf is the original file renamed.

Does anybody have any idea why this is doing this? Any solutions? If you need any other files to troubleshoot this let me know.

Last edited by jholbrook (2011-06-29 05:06:21)

Offline

#2 2011-06-29 04:07:01

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,079

Re: Laptop kills my wireless router

please use BBCode code tags to paste outputs or files


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#3 2011-06-30 02:44:51

jholbrook
Member
Registered: 2010-07-08
Posts: 18

Re: Laptop kills my wireless router

Okay. I've tried every setting. Searched all over the forums. Chatted with the guys in IRC on the DD-WRT channel. Googled until my eyes started to bleed. No luck.

I played with every setting under the sun. Still no luck. Finally I turned the wireless to G mode only. Now it seems to be working fine. Not getting the speed I should with my laptop but at least I can connect.

Any ideas?

Offline

#4 2011-06-30 02:54:50

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,079

Re: Laptop kills my wireless router

you might want to try wicd instead of networkmanager and see if that helps.


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#5 2011-07-01 00:34:14

jholbrook
Member
Registered: 2010-07-08
Posts: 18

Re: Laptop kills my wireless router

Tried wicd. Still have exactly the same problem. NG mixed mode dies. G mode only is fine. Pain in the butt.

I definitely think there's a problem with the drivers/firmware for this wireless NIC.

Offline

#6 2011-07-01 00:50:32

bangkok_manouel
Member
From: indicates a starting point
Registered: 2005-02-07
Posts: 1,554

Re: Laptop kills my wireless router

can you reproduce it with older kernels?


All design goals must be phrased in such a way that it is hard to use them as slogans to justify stupidity.

Offline

#7 2011-07-01 09:25:11

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 3,610

Re: Laptop kills my wireless router

I'd say: "I have a Buffalo WHR-HP-G300N running the latest version of DD-WRT." and "NG mixed mode dies. G mode only is fine." is the problem.

DD-WRT is not without bugs, N mode or NG mixed mode support is probably flaky and I'd say this has nothing to do with your news laptop or arch. A workaround might be to force the router to work in G mode only.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#8 2011-07-05 01:20:17

jholbrook
Member
Registered: 2010-07-08
Posts: 18

Re: Laptop kills my wireless router

Well, I forgot to mention one other point. The laptop dual boots Windows 7. I can connect just fine from Windows 7 to the wireless router and surf the web to my hearts content. For me (and I could be wrong) that really points to an issue with the Linux drivers/firmware.

Offline

#9 2011-07-05 22:12:46

benhamill
Member
Registered: 2011-07-05
Posts: 4

Re: Laptop kills my wireless router

I am having this same problem. I have a Buffalo WZR-HP-G300NH. My Xbox, non-Linux machines, etc. can all connect to the router fine until I sudo netcfg home. Then I have to unplug and replug my router for anything else to connect. And as soon as iwlagn gets involved, the router flips out again. Logs:

Jul  5 17:02:49 localhost dhcpcd[6892]: sending signal 1 to pid 6688
Jul  5 17:02:49 localhost dhcpcd[6892]: waiting for pid 6688 to exit
Jul  5 17:02:49 localhost dhcpcd[6688]: received SIGHUP, releasing
Jul  5 17:02:49 localhost dhcpcd[6688]: wlan0: removing interface
Jul  5 17:03:49 localhost kernel: [14720.923768] ADDRCONF(NETDEV_UP): wlan0: link is not ready
Jul  5 17:03:51 localhost kernel: [14723.514450] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Jul  5 17:03:54 localhost dhcpcd[7025]: version 5.2.12 starting
Jul  5 17:03:54 localhost dhcpcd[7025]: wlan0: rebinding lease of 192.168.11.64
Jul  5 17:03:54 localhost dhcpcd[7025]: wlan0: acknowledged 192.168.11.64 from 192.168.11.1
Jul  5 17:03:54 localhost dhcpcd[7025]: wlan0: checking for 192.168.11.64
Jul  5 17:03:59 localhost dhcpcd[7025]: wlan0: leased 192.168.11.64 for 86400 seconds
Jul  5 17:03:59 localhost dhcpcd[7025]: forked to background, child pid 7048
Jul  5 17:04:13 localhost kernel: [14744.906413] iwlagn 0000:03:00.0: iwlagn_tx_agg_start on ra = 00:24:a5:d8:60:9f tid = 0
Jul  5 17:06:41 localhost kernel: [14892.721959] iwlagn 0000:03:00.0: Stopping AGG while state not ON or starting
Jul  5 17:06:41 localhost dhcpcd[7048]: wlan0: carrier lost
Jul  5 17:06:41 localhost kernel: [14892.806507] cfg80211: Calling CRDA to update world regulatory domain
Jul  5 17:06:58 localhost dhcpcd[7316]: sending signal 1 to pid 7048
Jul  5 17:06:58 localhost dhcpcd[7316]: waiting for pid 7048 to exit
Jul  5 17:06:58 localhost dhcpcd[7048]: received SIGHUP, releasing
Jul  5 17:06:58 localhost dhcpcd[7048]: wlan0: removing interface

I'll report back after trying the set-to-G-only thing.


Ben

Last edited by benhamill (2011-07-05 22:25:10)

Offline

#10 2011-07-05 22:28:50

benhamill
Member
Registered: 2011-07-05
Posts: 4

Re: Laptop kills my wireless router

So far, at least, my connection seems stable with both my iPhone and my laptop connected to the router and the internet therethrough. I haven't yet tested my various other networked devices, but if problems crop up, I'll come find this thread again.


Ben

Offline

#11 2011-07-06 05:02:51

jholbrook
Member
Registered: 2010-07-08
Posts: 18

Re: Laptop kills my wireless router

Do you mean it's fine now that you've switched to G only?

Offline

#12 2011-07-09 06:42:36

dscaife
Member
Registered: 2007-10-25
Posts: 3

Re: Laptop kills my wireless router

I've been having the exact same issue with my Windows/Arch dual-booting laptop. The issue only occurs on Arch, and with this particular laptop, and only when it's using wireless (G or N). Different laptop to the original poster, different wireless device (Intel 5100), different router hardware - but it is running DD-WRT.

An interesting thing is, I've been using the laptop flawlessly with N up until a few weeks ago with no changes to the router, though I do recall software/kernel updates happening on the laptop shortly before problems began. Ultimately, the router's responsible for not killing itself like this, but it seems like there's a bit of suicide-synergy going on here.

Switching the router to G-only seems to be an effective workaround. While that's not ideal, at least I can stop pulling my hair out - thanks jholbrook.

Offline

#13 2011-07-18 12:23:22

thiagoboche
Member
Registered: 2011-07-18
Posts: 5

Re: Laptop kills my wireless router

I've been having this problem too.
The workaround that dscaife proposed worked for me too, but I'm not satisfied yet.
I'm still looking for a solution, if I find I tell you guys.

Thanks anyway!

Offline

#14 2011-07-19 04:20:04

jreptak
Member
From: New Jersey
Registered: 2011-07-19
Posts: 1
Website

Re: Laptop kills my wireless router

Same thing happens with me. Removing N functionality fixes it. Except I have Verizon FIOS router.

lspci:

04:00.0 Network controller: Intel Corporation WiFi Link 5100
08:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5784M Gigabit Ethernet PCIe (rev 10)

dmesg:

[  138.621365] wlan0: authenticate with 00:26:b8:27:8b:59 (try 1)
[  138.623915] wlan0: authenticated
[  138.631411] wlan0: associate with 00:26:b8:27:8b:59 (try 1)
[  138.637235] wlan0: RX AssocResp from 00:26:b8:27:8b:59 (capab=0x431 status=0 aid=1)
[  138.637239] wlan0: associated
[  138.645488] cfg80211: Calling CRDA for country: US
[  138.647976] cfg80211: Regulatory domain changed to country: US
[  138.647978] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  138.647981] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
[  138.647983] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
[  138.647985] cfg80211:     (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  138.647987] cfg80211:     (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  138.647990] cfg80211:     (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  138.647992] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
[  143.950017] wlan0: no IPv6 routers present
[  146.860026] iwlagn 0000:04:00.0: iwlagn_tx_agg_start on ra = 00:26:b8:27:8b:59 tid = 0
[  165.370719] iwlagn 0000:04:00.0: Stopping AGG while state not ON or starting
[  165.405265] cfg80211: Calling CRDA to update world regulatory domain
[  165.407679] cfg80211: World regulatory domain updated:
[  165.407682] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  165.407684] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  165.407686] cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  165.407688] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  165.407690] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  165.407693] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)

uname -a:

Linux Jetpak-Chakra 2.6.39-CHAKRA #1 SMP PREEMPT Sun Jul 10 10:40:31 UTC 2011 x86_64 Intel(R) Core(TM)2 Duo CPU P8700 @ 2.53GHz GenuineIntel GNU/Linux

I ran Arch about 2 months ago and this problem didn't exist. Also, I ran Fedora until today and also no problems. Tried Chakra today and started breaking my router every time I accessed the network. I don't remember the kernel versions of either, sorry.

Can anyone explain how this is happening? I'm fine with leaving just G on (No N devices anyway), just curious how this can be happening.

Thank you!

Offline

#15 2011-08-18 12:24:46

jac
Member
From: /home/jac
Registered: 2009-05-19
Posts: 431
Website

Re: Laptop kills my wireless router

Has anyone made progress on this other than switching the router to G-only?

The workaround works here too, but I have some N-enabled chips I would like to use. I have the same router as OP, and there have been no dd-wrt updates unfortunately.

Offline

#16 2011-08-22 00:42:04

grimaldo
Member
Registered: 2011-08-22
Posts: 1

Re: Laptop kills my wireless router

I am having the same problem with a different router and OS. Attaching to my Netgear WNDR3700 (DD-WRT firnware) via Gentoo OS (2.6.39 or 3.0.3 kernel) either an Intel WiFi Link 5100 or Intel Centrino Advanced-N 6200. Kills network at router. Other router (dLink DIR-655, stock firmware) stays up on same network, same client connected through this router works fine. The same laptop using Atheros 9k card works fine through either router.

Intel reports that the problem is a router firmware/kernel/driver issue. They fixed it by using OpenWRT firmware. (http://bugzilla.intellinuxwireless.org/ … gi?id=2297)

Offline

#17 2011-08-24 11:58:49

jac
Member
From: /home/jac
Registered: 2009-05-19
Posts: 431
Website

Re: Laptop kills my wireless router

Great grimaldo! I don't have time at the moment, but I'm going to look into using OpenWRT.

The bugzilla link also has a "patch" consisting of commenting only one line, but I think it is to the kernel, unfortunately. That may also be an option for correcting the issue until dd-wrt fixes its issues.

Offline

#18 2011-10-25 16:31:03

zachtib
Member
Registered: 2006-03-09
Posts: 20

Re: Laptop kills my wireless router

Is there any followup to this? I have a Cr-48 running Arch and both it and a friend's Thinkpad X200 have this issue on DD-WRT networks. Since a lot of my friends have DD-WRT routers, I can't just switch my router to something else, as I want to be able to use wifi when I'm at their houses as well.

Offline

Board footer

Powered by FluxBB