You are not logged in.

#1 2011-08-08 04:39:03

Carlinhos
Member
Registered: 2011-07-08
Posts: 41

[SOLVED] Wireless doesn't work after upgrade to Linux 3

Hi,
Networkmanager no longer lists wireless networks after upgrading to Linux 3, it's like the card is not recognized.
I have a Broadcom BCM4313 and I never needed a driver because it was included in the kernel.
Let me know if you need any more information.
Thanks

Edit: I fixed it by unloading all the modules in lsmod | grep brcm and reloading brcmsmac again. I also added "blacklist bcma" to /etc/modprobe.d/modprobe.conf and rebuilt my initramfs.

Last edited by Carlinhos (2011-08-08 05:33:30)

Offline

#2 2011-08-08 09:28:55

Awebb
Member
Registered: 2010-05-06
Posts: 5,877

Re: [SOLVED] Wireless doesn't work after upgrade to Linux 3

I hereby confirm your solution and salute your success finding it out in less than an hour.

Offline

#3 2011-08-08 09:55:06

capnion
Member
Registered: 2011-05-01
Posts: 10

Re: [SOLVED] Wireless doesn't work after upgrade to Linux 3

Thanks to your post now everything works just fine, but at login screen I receive this kind of messages:


Arch Linux 3.0-ARCH (myhost) (tty1)

myhost login: [  15.025853] ieee80211 phy0: wl_ops_config: change monitor mode: false (implement)
[   15.025956] ieee80211 phy0: wl_ops_config: change power-save mode: false (implement)
[   15.026710] ieee80211 phy0: wl_ops_bss_info_changed: qos enabled: false (implement)
...

Does anyone know what they mean and how can I get rid of them?

Last edited by capnion (2011-08-08 10:01:06)

Offline

#4 2011-08-08 10:02:12

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: [SOLVED] Wireless doesn't work after upgrade to Linux 3

capnion wrote:

Thanks to your post now everything works just fine, but at login screen I receive this kind of messages:


Arch Linux 3.0-ARCH (myhost) (tty1)

myhost login: [  15.025853] ieee80211 phy0: wl_ops_config: change monitor mode: false (implement)
[   15.025956] ieee80211 phy0: wl_ops_config: change power-save mode: false (implement)
[   15.026710] ieee80211 phy0: wl_ops_bss_info_changed: qos enabled: false (implement)
...

Does anyone know what they mean and how can I get rid of them?

When you upgraded you should have got

[2011-07-31 18:35] warning: /etc/rc.conf installed as /etc/rc.conf.pacnew
[2011-07-31 18:35] VERBOSE= in rc.conf no longer has any effect.
[2011-07-31 18:35] Please append 'quiet' to your kernel command line.

in your pacman output. Act accordingly.

Offline

#5 2011-08-08 10:07:25

capnion
Member
Registered: 2011-05-01
Posts: 10

Re: [SOLVED] Wireless doesn't work after upgrade to Linux 3

Thanks Karol but I already added this line to menu.lst:

# (0) Arch Linux
title  Arch Linux  [/boot/vmlinuz-linux]
root   (hd0,0)
kernel /vmlinuz-linux root=/dev/sda2 ro quiet
initrd /initramfs-linux.img

The messages disappear when bcma is not blackĺisted but then my wireless stops working.

Last edited by capnion (2011-08-08 10:10:43)

Offline

#6 2011-08-08 10:09:29

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: [SOLVED] Wireless doesn't work after upgrade to Linux 3

Try 'loglevel=3'.

Offline

#7 2011-08-08 10:12:45

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,111
Website

Re: [SOLVED] Wireless doesn't work after upgrade to Linux 3

capnion wrote:

Thanks to your post now everything works just fine, but at login screen I receive this kind of messages:


Arch Linux 3.0-ARCH (myhost) (tty1)

myhost login: [  15.025853] ieee80211 phy0: wl_ops_config: change monitor mode: false (implement)
[   15.025956] ieee80211 phy0: wl_ops_config: change power-save mode: false (implement)
[   15.026710] ieee80211 phy0: wl_ops_bss_info_changed: qos enabled: false (implement)
...

Does anyone know what they mean and how can I get rid of them?

These messages are miscategorized as loglevel 3. They should be ranked much lower in the foodchain, probably 9 or 10 (debug). It's worth reporting upstream.

Last edited by falconindy (2011-08-08 10:13:01)

Offline

#8 2011-08-08 10:21:25

capnion
Member
Registered: 2011-05-01
Posts: 10

Re: [SOLVED] Wireless doesn't work after upgrade to Linux 3

Many thanks Karol, your solution works just fine for me. I will use that until further developments.

Offline

#9 2011-08-08 10:23:51

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,151

Re: [SOLVED] Wireless doesn't work after upgrade to Linux 3

capnion wrote:

Many thanks Karol, your solution works just fine for me. I will use that until further developments.

capnion, please be so kind to also report this upstream as falconindy mentioned. Would help out a lot more people if they were in the same boat.

Thanks.


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#10 2011-08-08 11:39:56

capnion
Member
Registered: 2011-05-01
Posts: 10

Re: [SOLVED] Wireless doesn't work after upgrade to Linux 3

Ok I have reported the bug to the guys in AUR discussion about broadcom-wl, I cannot find anything more upstream than that. At bugs.archlinux.com they didn't seem to be very interested in it.

Offline

#11 2011-08-08 12:25:15

Awebb
Member
Registered: 2010-05-06
Posts: 5,877

Re: [SOLVED] Wireless doesn't work after upgrade to Linux 3

Since it is a normal kernel module, this is either relevant for the kernel.org team or broadcom.

Offline

#12 2011-08-08 23:30:46

gbc921
Member
From: Brazil
Registered: 2011-08-05
Posts: 64
Website

Re: [SOLVED] Wireless doesn't work after upgrade to Linux 3

Carlinhos wrote:

Hi,
Networkmanager no longer lists wireless networks after upgrading to Linux 3, it's like the card is not recognized.
I have a Broadcom BCM4313 and I never needed a driver because it was included in the kernel.
Let me know if you need any more information.
Thanks

Edit: I fixed it by unloading all the modules in lsmod | grep brcm and reloading brcmsmac again. I also added "blacklist bcma" to /etc/modprobe.d/modprobe.conf and rebuilt my initramfs.


Worked for me too, using a BCM43224 on Vostro 3500.
Just to be completely sure I've blacklisted brcmfmac too, on /etc/modprobe.d/blacklist.conf

Thanks!


- "Nothing is impossible, impossible just takes longer"
- My Arch Linux Mirror located in São Paulo, Brazil: http://archmirror.duckdns.org:9000/

Offline

Board footer

Powered by FluxBB