You are not logged in.

#51 2011-02-25 17:37:10

otsug
Member
From: Brasil
Registered: 2010-12-12
Posts: 31
Website

Re: Yapan - another notifier

forkboy wrote:

For what it's worth, I would love to just see a notification and the red ghost when updates are available, not an animation.  I do like the pacman chomping animation when it's syncing, as it's a lot less distracting and I only have it set for every hour.

You already can do that, you can change the update gif to a png or svg, like this http://www.clker.com/cliparts/f/8/6/3/1 … svg.hi.png, and set to 60 minutes in settings...

Offline

#52 2011-02-27 00:14:15

forkboy
Member
From: Blackpool, England
Registered: 2005-09-03
Posts: 74

Re: Yapan - another notifier

Can you make it so that it doesn't notify for updates of packages that are listed in IgnorePkg in /etc/pacman.conf?

Offline

#53 2011-02-27 00:32:13

otsug
Member
From: Brasil
Registered: 2010-12-12
Posts: 31
Website

Re: Yapan - another notifier

forkboy wrote:

Can you make it so that it doesn't notify for updates of packages that are listed in IgnorePkg in /etc/pacman.conf?

Oo, probably this is a pacman problem, I only call the pacman, so I don't have that kind of control, I don't know if this behavior is the pacman design, I think is better to ask to the pacman developers...

Offline

#54 2011-03-21 15:47:23

chr0nik
Member
From: Michigan, USA
Registered: 2011-03-13
Posts: 31

Re: Yapan - another notifier

This command should launch Xfce's Terminal, but it doesn't - at least not from within Yapan. It does work if I just try it from a command line.

dbus-launch terminal --hold --command='bash -c "%1; echo && echo --- Finished ---"'

In lieu of that, I'm just using xterm for now with this command:

dbus-launch xterm -hold -e bash -c "%1; echo && echo --- Finished ---"

This is a slick little tool you've built. My only question is why does it have to use dbus-launch to invoke a terminal? That seems to be creating a new session message bus each time I use Yapan to run an update. The only way to terminate the extra instances of dbus-daemon is to explicitly kill them. And yes, dbus starts at boot, I have a session bus running before Yapan even starts and I have a DBUS_SESSION_BUS_ADDRESS environment variable set.

Last edited by chr0nik (2011-03-21 16:59:22)

Offline

#55 2011-03-21 16:50:36

keenerd
Trusted User (TU)
Registered: 2007-02-22
Posts: 647
Website

Re: Yapan - another notifier

Please don't use "sudo pacman -Sy".  It is dangerous and can easily lead to all sorts of trouble.  Much safer is to use the following:

# Setup
mkdir -p /tmp/localsync
ln -s /var/lib/pacman/local /tmp/localsync &> /dev/null
# Call this regularly
fakeroot pacman -Syy --dbpath /tmp/localsync/ &> /dev/null
pacman -Qqu --dbpath /tmp/localsync/ | wc -l

Does not need root and does not risk serious breakage.

Last edited by keenerd (2011-03-21 16:51:45)

Offline

#56 2011-03-23 19:56:03

otsug
Member
From: Brasil
Registered: 2010-12-12
Posts: 31
Website

Re: Yapan - another notifier

keenerd wrote:

Please don't use "sudo pacman -Sy".  It is dangerous and can easily lead to all sorts of trouble.  Much safer is to use the following:

# Setup
mkdir -p /tmp/localsync
ln -s /var/lib/pacman/local /tmp/localsync &> /dev/null
# Call this regularly
fakeroot pacman -Syy --dbpath /tmp/localsync/ &> /dev/null
pacman -Qqu --dbpath /tmp/localsync/ | wc -l

Does not need root and does not risk serious breakage.

Wow, that is nice, I only have time to test this in the end of week, but if works without the need of sudo, I will include this by default for sure in the new version. Thank you.

Offline

#57 2011-03-24 09:52:31

forkboy
Member
From: Blackpool, England
Registered: 2005-09-03
Posts: 74

Re: Yapan - another notifier

keenerd wrote:

Please don't use "sudo pacman -Sy".  It is dangerous and can easily lead to all sorts of trouble.

Can you explain why?

Offline

#58 2011-03-24 12:16:54

keenerd
Trusted User (TU)
Registered: 2007-02-22
Posts: 647
Website

Re: Yapan - another notifier

Why -Sy is bad: https://bbs.archlinux.org/viewtopic.php … 58#p802658

If you want to get a warning about -Sy ing on a stale system, check out Pacmatic.

Offline

#59 2011-03-27 18:34:33

otsug
Member
From: Brasil
Registered: 2010-12-12
Posts: 31
Website

Re: Yapan - another notifier

chr0nik wrote:

This command should launch Xfce's Terminal, but it doesn't - at least not from within Yapan. It does work if I just try it from a command line.

dbus-launch terminal --hold --command='bash -c "%1; echo && echo --- Finished ---"'

In lieu of that, I'm just using xterm for now with this command:

dbus-launch xterm -hold -e bash -c "%1; echo && echo --- Finished ---"

This is a slick little tool you've built. My only question is why does it have to use dbus-launch to invoke a terminal? That seems to be creating a new session message bus each time I use Yapan to run an update. The only way to terminate the extra instances of dbus-daemon is to explicitly kill them. And yes, dbus starts at boot, I have a session bus running before Yapan even starts and I have a DBUS_SESSION_BUS_ADDRESS environment variable set.

Sorry, I only see your post today... I don't use XFCE so I don't know why the terminal does not work for you, I use dbus-launch in KDE because when I call konsole direct the command open in a new tab instead of new window, if this not occurs to you, you can delete the dbus-launch, in KDE 4.6.1 with konsole 2.6.1 apparently the dbus-launch is not necessary anymore. Thank you.

Edit: The problem persists if there is already a konsole open, and I call for konsole in yapan the konsole does not open, but if I use dbus-launch works...


keenerd wrote:

Please don't use "sudo pacman -Sy".  It is dangerous and can easily lead to all sorts of trouble.  Much safer is to use the following:

# Setup
mkdir -p /tmp/localsync
ln -s /var/lib/pacman/local /tmp/localsync &> /dev/null
# Call this regularly
fakeroot pacman -Syy --dbpath /tmp/localsync/ &> /dev/null
pacman -Qqu --dbpath /tmp/localsync/ | wc -l

Does not need root and does not risk serious breakage.

Works, very nice, explain one thing, I am new to Linux, the command:

ln -s /var/lib/pacman/local /tmp/localsync &> /dev/null

create a symbolic link to pacman/local in localsync right? so this link is for update the database of pacman too? and you are using pacman -Syy because the explanation in this link: https://bbs.archlinux.org/viewtopic.php … 58#p802658 ?

and did you know a safe way to call pacman -Su without the sudo too? Something like:

konsole --nofork --noclose -e bash -c "su -c 'pacman -Su; echo && echo --- Finished ---'"

Last edited by otsug (2011-03-28 01:40:22)

Offline

#60 2011-04-23 12:57:57

Doorbreath
Member
Registered: 2010-06-08
Posts: 20

Re: Yapan - another notifier

otsug wrote:

Wow, that is nice, I only have time to test this in the end of week, but if works without the need of sudo, I will include this by default for sure in the new version. Thank you.

And when's that gonna be? tongue

Offline

#61 2011-04-23 13:17:45

otsug
Member
From: Brasil
Registered: 2010-12-12
Posts: 31
Website

Re: Yapan - another notifier

Doorbreath wrote:
otsug wrote:

Wow, that is nice, I only have time to test this in the end of week, but if works without the need of sudo, I will include this by default for sure in the new version. Thank you.

And when's that gonna be? tongue

Sorry I don't know, I just started in my first job and my exams at college started too, but you already can use the fakeroot with the current yapan... just change the commands in settings, because that I made yapan with many configurations.

Offline

#62 2011-04-23 20:46:57

akurei
Member
From: Bochum, NRW, Germany
Registered: 2009-05-25
Posts: 152
Website

Re: Yapan - another notifier

Awesome!

Offline

#63 2011-04-25 09:04:06

Cookie
Member
Registered: 2008-03-08
Posts: 119

Re: Yapan - another notifier

Brilliant! big_smile


Linux nabcake in training...
ArchLinux64

Offline

#64 2011-05-12 14:25:23

laurion
Member
Registered: 2011-05-12
Posts: 6

Re: Yapan - another notifier

If LXTerminal is your term of choice, you can use the following command in your update line:

lxterminal --command "bash -c '%1 && echo --- Finished --- && bash'"

Which will run an update and then drop you at a prompt if anything needs further followup.

Offline

#65 2011-06-02 12:43:17

awayand
Member
Registered: 2009-09-25
Posts: 396

Re: Yapan - another notifier

I agree with forkboy, is there a way to add IgnorePkg so that I don't get a notification for those packages? If this is not possible, then the tool is not really that useful as it will always stay in "new update available" state...

EDIT: I found a way. In my example, I am excluding the package gnucash. So here is what I did to suppress this package in the notifier. Edit in the tab "Package manager" the field "List packages to update" like this:

pacman -Qu|grep -v gnucash

Then when gnucash for example is the only "IgnorePkg", and also the only "outdated" package, the above command won't return anything, thus making yapan think everything is up to date.

EDIT: Correction: the above code has to be in a shell script actually. For some reason yapan doesn't like the pipe in the field directly. So if you put the above in for example ~/bin/update.sh, have your .bashrc export PATH=$PATH:~/bin and chmod +x ~/bin/update.sh, you can put "update.sh" directly into the field "List packages to update" and it will work...

Last edited by awayand (2011-06-06 01:38:10)

Offline

#66 2011-06-13 00:45:54

otsug
Member
From: Brasil
Registered: 2010-12-12
Posts: 31
Website

Re: Yapan - another notifier

Sorry for the delay I was without internet access..

@akurei, @Cookie, @laurion thanks.

@awayand good that you found a solution, I think if you call bash the pipe will work too.

The only different I made in yapan is the change in the default to not use sudo, when I have time I will launch this little modification, but like I said is just a modification in the default commands nothing more.

Offline

#67 2011-06-13 01:17:50

awayand
Member
Registered: 2009-09-25
Posts: 396

Re: Yapan - another notifier

@otsug: I noticed when I quit my session and then relaunch it, yapan complains that only one instance of yapan can run as if some lock file hadn't been cleaned up. If I restart my session a second time, then yapan starts up fine. I am using dwm and often just exit dwm using alt+shift+q.

Offline

#68 2011-06-13 01:20:53

otsug
Member
From: Brasil
Registered: 2010-12-12
Posts: 31
Website

Re: Yapan - another notifier

awayand wrote:

@otsug: I noticed when I quit my session and then relaunch it, yapan complains that only one instance of yapan can run as if some lock file hadn't been cleaned up. If I restart my session a second time, then yapan starts up fine. I am using dwm and often just exit dwm using alt+shift+q.

Hmm, did you tried to launch yapan a second time after the yapan message?

Offline

#69 2011-06-14 11:04:42

awayand
Member
Registered: 2009-09-25
Posts: 396

Re: Yapan - another notifier

Yes, if I launch a second time, the message disappears, but then launching a 3rd time it re-appears, then 4th time disappears, and so on....

Offline

#70 2011-07-30 18:38:06

aijeitpipol
Member
From: Colombia
Registered: 2011-02-25
Posts: 1
Website

Re: Yapan - another notifier

Awesome, awesome job man. smile Greetings.

Offline

#71 2011-08-08 04:17:00

otsug
Member
From: Brasil
Registered: 2010-12-12
Posts: 31
Website

Re: Yapan - another notifier

awayand wrote:

Yes, if I launch a second time, the message disappears, but then launching a 3rd time it re-appears, then 4th time disappears, and so on....

Hi awayand I think I resolved this issue in Yapan 0.4.1, please let me know if works, sorry for the big delay, I am very busy at work =/.

aijeitpipol wrote:

Awesome, awesome job man. smile Greetings.

big_smile thank you.

Offline

#72 2011-09-02 12:32:00

krax
Member
From: Tory;Mi
Registered: 2010-06-26
Posts: 62
Website

Re: Yapan - another notifier

hi I use openbox. and I have a problem. yapan does only synchronizes and show a notify to update . but if I click on the update button or update option on the menu. it only sync and show that massage again.
I uses the command call for openbox which is mentioned in wiki section of yapan site.
the full account of my problem is here
https://bbs.archlinux.org/viewtopic.php … 71#p985271

I hope a can get some help and make yapan to update my packages by just click on update button on notification.
thanks YAPAN

Last edited by krax (2011-09-02 12:33:40)

Offline

#73 2011-09-21 16:02:46

ancleessen4
Member
From: Luxembourg
Registered: 2009-11-22
Posts: 120
Website

Re: Yapan - another notifier

@krax
I had this problem with a recent yapan install.
If you have pacman -Syu set up for sudo use (nano /etc/sudoers) as per my case;

 neil ALL = NOPASSWD: /usr/bin/pacman -Syu

then change the update line in yapan to ;

sudo pacman -Syu

This works for me cool

Offline

#74 2011-10-07 17:18:09

krax
Member
From: Tory;Mi
Registered: 2010-06-26
Posts: 62
Website

Re: Yapan - another notifier

ancleessen4 wrote:

@krax
I had this problem with a recent yapan install.
If you have pacman -Syu set up for sudo use (nano /etc/sudoers) as per my case;

 neil ALL = NOPASSWD: /usr/bin/pacman -Syu

then change the update line in yapan to ;

sudo pacman -Syu

This works for me cool

Really THANKS

Offline

Board footer

Powered by FluxBB