You are not logged in.

#1 2011-09-13 22:21:07

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

[wicd] PEAP with TKIP/MSCHAPV2 - bad password [solved]

Hi guys,

I'm trying to connect to my university's network through wicd. But unfortunately it does not work. The wicd logs give me the following.

2011/09/13 14:59:09 :: Connecting to wireless network UoA-WiFi
2011/09/13 14:59:10 :: Putting interface down
2011/09/13 14:59:10 :: Releasing DHCP leases...
2011/09/13 14:59:10 :: Setting false IP...
2011/09/13 14:59:10 :: Stopping wpa_supplicant
2011/09/13 14:59:10 :: Flushing the routing table...
2011/09/13 14:59:10 :: Putting interface up...
2011/09/13 14:59:12 :: Attempting to authenticate...
2011/09/13 14:59:15 :: wpa_supplicant rescan forced...
2011/09/13 14:59:52 :: wpa_supplicant authentication may have failed.
2011/09/13 14:59:52 :: connect result is Failed
2011/09/13 14:59:52 :: exiting connection thread
2011/09/13 14:59:52 :: Sending connection attempt result bad_pass

The network is a WPA2 network with PEAP protection. I followed this guide from my university to successfully connect through networkmanager. However it does not work with wicd. The password is definitely correct, so the ID and the path to the root certificate with resides in my home directory.

Do you have any ideas what I can try?

Regards

Last edited by orschiro (2011-09-15 00:01:13)

Offline

#2 2011-09-13 23:42:36

the sad clown
Member
From: 192.168.0.X
Registered: 2011-03-20
Posts: 833

Re: [wicd] PEAP with TKIP/MSCHAPV2 - bad password [solved]

http://wicd.net/punbb/viewtopic.php?id=316

Perhaps this is your problem?


I laugh, yet the joke is on me

Offline

#3 2011-09-14 06:19:01

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: [wicd] PEAP with TKIP/MSCHAPV2 - bad password [solved]

Well not really as I can provide the certificate and it is definitely the right one because it works with networkmanager.

Regards

Offline

#4 2011-09-14 09:55:43

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 2,964

Re: [wicd] PEAP with TKIP/MSCHAPV2 - bad password [solved]

That "EC\" may be causing the problem, \ is an escape character and wicd does not store the settings, such as password and username, in quotes so when loading them it might be loading the wrong username (just a guess). On another note people (the guys that configured the network) should know better than to use "strange" characters in network names or when assigning usernames and passwords, this will sooner or later cause hard to trace problems.

If using "EC\" in front of your login does not work, some users report that they can login with just their UPI (NETID, eg ffih001)

Did you try this?


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#5 2011-09-14 11:05:47

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: [wicd] PEAP with TKIP/MSCHAPV2 - bad password [solved]

Hi R00KIE,

Yes it tried it. Actually I was the user who reported to just login without the EC\ as this worked sufficiently for networkmanager. But in wicd, equally if with or without EC\ it does not work. I always receive this bad password response. However as stated above, the password is definitely correct.

Regards

Offline

#6 2011-09-14 13:06:45

crondog
Member
Registered: 2011-04-21
Posts: 125

Re: [wicd] PEAP with TKIP/MSCHAPV2 - bad password [solved]

orschiro,

I was having the same issues as you with my uni's wifi. They have PEAP with TKIP/MSCHAPv2 also. Give this a try. Save it to /etc/wicd/encryption/templates/somename. It works for me smile

name = Uni
author = Me
version = 1
require identity *Identity password *Password
-----
ctrl_interface=/var/run/wpa_supplicant
network={
        ssid="$_ESSID"
        scan_ssid=$_SCAN
        proto=RSN
        key_mgmt=WPA-EAP
        pairwise=CCMP
        group=CCMP
        eap=PEAP
        identity="$_IDENTITY"
        password="$_PASSWORD"
        phase2="auth=MSCHAPV2"
}

Offline

#7 2011-09-14 13:12:01

the sad clown
Member
From: 192.168.0.X
Registered: 2011-03-20
Posts: 833

Re: [wicd] PEAP with TKIP/MSCHAPV2 - bad password [solved]

Also, instead of the password, perhaps a PSK would work better?


I laugh, yet the joke is on me

Offline

#8 2011-09-14 13:16:34

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 2,964

Re: [wicd] PEAP with TKIP/MSCHAPV2 - bad password [solved]

If you know how to connect manually using wpa_supplicant and dhcpcd/dhclient maybe you should try to do it manually. For me the hard part would be to supply wpa_supplicant with a proper configuration file, however I can get one valid configuration file when wicd is trying to connect and then use that.

You can try that too, if I'm not remembering incorrectly, when wicd is trying to connect you can do a 'ps uxa | grep wicd' and see which configuration file wicd has generated to supply to wpa_supplicant, you will need to copy that file as root.

Then use that configuration file directly with 'wpa_supplicant -c config_file -iwlan0' and check if you can authenticate with the network, if you can it means the username, password and certificate are correct and being accepted, then try to get an ip with dhcpcd or dhclient.

I have seen wicd report that the password was incorrect when in fact the problem was with (temporarily) not being able to get an ip address through dhcp. In your case you can try both dhcpcd and dhclient as it seems that for some cases dhcpcd fails to get an ip. Either way when you perform the steps manually you can check for warnings or errors that might help you find the cause of the problem and a solution.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#9 2011-09-15 00:00:55

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: [wicd] PEAP with TKIP/MSCHAPV2 - bad password [solved]

Thank you all for your extensive replies. I was able to solve the problem.

Instead of the template PEAP with TKIP/MSCHAPV2 I connected through PEAP with GTC. This requires only my username and password which works without any problem.

The connection gets established instantly.

Regards

Offline

#10 2013-02-20 15:51:26

fatfishy
Member
Registered: 2013-02-20
Posts: 1

Re: [wicd] PEAP with TKIP/MSCHAPV2 - bad password [solved]

Wow Thanks! I've been struggling to get PEAP with MSCHAP working for a long time now. What a nice quick fix to an annoying problem.

Offline

#11 2013-03-21 12:36:03

danilo
Member
From: Switzerland
Registered: 2010-12-10
Posts: 21
Website

Re: [wicd] PEAP with TKIP/MSCHAPV2 - bad password [solved]

Great! I had the same problem, today wicd stopped working for my PEAP/MSCHAP university network. It was either due to a password change or due to a package upgrade. Using PEAP/GTC works like a charm.


"Freedom is the freedom to say that two plus two make four. If that is granted, all else follows." - George Orwell

Offline

#12 2014-01-29 21:31:11

markwithk
Member
Registered: 2014-01-29
Posts: 5

Re: [wicd] PEAP with TKIP/MSCHAPV2 - bad password [solved]

PEAP with GTC works!  Thanks!

Offline

#13 2014-01-29 22:01:34

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,254

Re: [wicd] PEAP with TKIP/MSCHAPV2 - bad password [solved]

markwithk,
Welcome to Arch Linux.  I am glad it works.
But, not meaning to put you off in any way, you kind of broke a couple of our community norms.
Please be careful of old threads and of empty posts
Thanks.

Closing.

Last edited by ewaller (2014-01-29 22:01:58)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

Board footer

Powered by FluxBB