You are not logged in.

#1 2013-03-19 14:02:59

Registered: 2010-05-28
Posts: 14

(Solved) fstab not automounting cifs shares

The newest linux 3.8 update no longer supports ntlm, resulting in fstab no longer auto-mounting the cifs shares on my old buffalo tera-station. The workaround is to add "sec=ntlm" in fstab.


// /mountpoint cifs sec=ntlm,noauto,x-systemd.automount 0 0

Please note ntlm is NOT secure!

Last edited by brasas (2013-03-19 14:10:48)


#2 2013-03-20 18:42:52

From: Illinois, U.S.
Registered: 2010-07-16
Posts: 154

Re: (Solved) fstab not automounting cifs shares

Yesterday my Arch installs stopped being able to access samba shares that I have set up in fstab as well.   I fixed them my adding the "sec=ntlm" to fstab as you suggested.   I'm hoping there is a bug fix in the works.  I'm not familiar with that variable, how is it not secure?

Last edited by Beelzebud (2013-03-20 18:43:39)


#3 2013-03-20 18:58:14

From: Ancapistan
Registered: 2010-07-12
Posts: 2,756

Re: (Solved) fstab not automounting cifs shares

I have several cifs entries in my fstab:

//phoenix/share		/mnt/phoenix	cifs	noauto,uid=testing,gid=users,file_mode=0664,dir_mode=0775,iocharset=iso8859-15,credentials=/home/pcreds	0 0
//server/storage	/mnt/server	cifs	noauto,uid=testing,gid=users,file_mode=0664,dir_mode=0775,iocharset=iso8859-15,credentials=/home/screds	0 0
//vault/Operations/ 	/mnt/vault	cifs	noauto,uid=testing,gid=users,file_mode=0664,dir_mode=0775,iocharset=iso8859-15,credentials=/home/vcreds 0 0

"Phoenix" is the only one I'm having issues with (and your suggestion fixes the issue). It's XP and the only one that I know for sure is updated regularly. "Server' is W2k3 Storage Server and it probably hasn't been updated in a while. "Vault" is some Ubuntu LTS I think, no idea about its update status.

But whether the Constitution really be one thing, or another, this much is certain - that it has either authorized such a government as we have had, or has been powerless to prevent it. In either case, it is unfit to exist.
-Lysander Spooner


#4 2013-03-21 09:10:41

From: Stalowa Wola, Poland
Registered: 2009-12-22
Posts: 117

Re: (Solved) fstab not automounting cifs shares

Thank you very much. Your advice is a life saver.


Board footer

Powered by FluxBB