You are not logged in.

#1 2013-03-28 03:59:04

dontbugme
Banned
Registered: 2011-11-04
Posts: 166
Website

Sftp not working [SOLVED]

Hi, I've got an XBMC box in the living room I'm using as a HTPC. It's running Ubuntu (I'd love to change it to Arch, but it has hundreds of gigs of media stored on it, and I just re-installed not too long ago, so I'll keep it till it breaks.)

Anyway, I can't sftp into the darn thing from my Arch laptop. I also can't ftp or ssh into it. Neither from Nautilus, or gFTP. Not sure what else to do.

Anybody have experience with any of this?

Thanks!

Last edited by dontbugme (2013-03-28 11:24:37)

Offline

#2 2013-03-28 04:08:39

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,059

Re: Sftp not working [SOLVED]

it sounds like more of an Ubuntu problem than Arch problem. Can you ssh into it with any other distro or Windows?

is the sshd running on the box? is it behind a different router? If so, have the ports been forwarded correctly?


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#3 2013-03-28 04:53:11

dontbugme
Banned
Registered: 2011-11-04
Posts: 166
Website

Re: Sftp not working [SOLVED]

I don't know if it can be ssh'd into. This is what I did on the Ubuntu box:

First things first you should do the following:

    sudo apt-get install openssh-server ssh

This will install the server and the ssh daemon, you can start the server by doing:

    service ssh start

You also have the following at your disposal(don’t forget to sudo if you aren’t running as root):

    service ssh restart #restarts the server

    service ssh reload #reloads the configuration file for the server

    service ssh stop     #stops the server

    service ssh status  #gives you a short description of the status of the server

Now that you have some knowledge of how to start, restart, and stop the server we are going to take a look at configuration.

sudo vim /etc/ssh/sshd_config #or nano if your lazy or whatever you normally use gedit is perfectly valid here

The first thing you’ll want to do is set it up to bind to an address (NOTE: The default is to listen on all address’s so if you have your computer in dmz(w/e its called) where your internet ip is assigned to your computer you may want to change this).

So navigate to where it says ListenAddress this tells the server what ip to listen on, your going to want to change this to 127.0.0.1 (which is the loopback address ie it means it will run locally).

The default for this server is to allow ssh scp and sftp connections, you are pretty much done

And I have installed openssh on the Arch laptop, and enabled the service.

Offline

#4 2013-03-28 05:07:29

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Sftp not working [SOLVED]

This is sounding even less like an Arch problem, since you had to follow these instructions to even get the service going. 

I am going to guess that (if the service really is running) that it is a firewall issue.  But even after you posted the instructions you used, it is not really very much information about what is actually going on in your systems.

Offline

#5 2013-03-28 05:25:42

dontbugme
Banned
Registered: 2011-11-04
Posts: 166
Website

Re: Sftp not working [SOLVED]

Maybe it is. Maybe it isn't. At this point I have no idea whether it's Arch or Ubuntu.

What I do know is that I can control XBMC over the local network using my Android phone. So I doubt it's a firewall issue, especially since I haven't installed any firewall.

Last edited by dontbugme (2013-03-28 06:06:19)

Offline

#6 2013-03-28 06:13:27

dontbugme
Banned
Registered: 2011-11-04
Posts: 166
Website

Re: Sftp not working [SOLVED]

Ok, now I know the problem is my Arch laptop.

I was able to sftp into the ubuntu box using my ubuntu username and password (not the xbmc ones) with an Android app on my phone called AndFTP. Once in, I was able to delete a folder on the host machine. This tells me that not only is sftp working, but permissions, etc, are all set up correctly.

But if I attempt a

ssh://username@192.168.1.106

on my laptop, it just gives the "No such file or directory" error.

As I already mentioned, I have openssh installed. Do I need a separate ssh package installed, like in Ubuntu? Doesn't seem to be one in the repos.

Offline

#7 2013-03-28 06:23:37

dontbugme
Banned
Registered: 2011-11-04
Posts: 166
Website

Re: Sftp not working [SOLVED]

I can also ssh in using ConnectBot on my phone.

Last edited by dontbugme (2013-03-28 11:21:46)

Offline

#8 2013-03-28 07:27:51

dontbugme
Banned
Registered: 2011-11-04
Posts: 166
Website

Re: Sftp not working [SOLVED]

OK, progress! I can ssh into the box with "ssh username@192.168.1.106" (although it complains about rsa stuff).

Edit: Somehow I got it figured out! Thanks for all your help!

Last edited by dontbugme (2013-03-28 11:22:59)

Offline

#9 2013-03-28 14:47:38

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,059

Re: Sftp not working [SOLVED]

dontbugme wrote:

OK, progress! I can ssh into the box with "ssh username@192.168.1.106" (although it complains about rsa stuff).

Edit: Somehow I got it figured out! Thanks for all your help!

The polite way is to explain how you got it fixed so that it helps others in similar situations instead of just saying that "somehow you figured it out"


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#10 2014-02-01 00:06:22

twelvedogs
Member
Registered: 2014-01-28
Posts: 1

Re: Sftp not working [SOLVED]

i'd guess he's not sure how he fixed it.  i had a similar problem and fixed it by deleting my ssh known hosts file.  even though command line sftp and ssh to my server worked xbmc logs showed it was rejecting it for some kind of key problem.  figured it out by enabling logging in the xbmc menu and checking the xbmc log file. edit: sorry to necro the thread it just came up high on my searching so i figured my solution might be handy to the next person.

Last edited by twelvedogs (2014-02-01 00:11:51)

Offline

Board footer

Powered by FluxBB