You are not logged in.

#1 2013-10-12 06:46:45

marko2010
Member
Registered: 2010-04-17
Posts: 68

[SOLVED] Kill the Gnome screen curtain once and for all

Author edit: you can see the fix that finally worked in post https://bbs.archlinux.org/viewtopic.php … 4#p1351594

screen.lock.png
mad I was inadvertently locked out of my own computer for about 10 minutes until I happened to stumble on the "Ctl + L" trick to bring up the login in screen.  How can I remove or disable the gnome shell screen lock for good.

I already tried:

  • setting the "screen lock" to OFF under gnome setting > Privacy (gnome 3.10 appears to ignore this, or "screen lock" refers to something else)

  • the Disable Screen Shield extension - this has  not been updated to gnome 3.10

Last edited by marko2010 (2013-11-19 18:04:06)

Offline

#2 2013-10-12 07:23:12

LucetLux
Member
Registered: 2013-08-16
Posts: 165

Re: [SOLVED] Kill the Gnome screen curtain once and for all

There seems to be a bug with this currently.
You can read more here https://bbs.archlinux.org/viewtopic.php?pid=1336052

Offline

#3 2013-10-26 14:27:41

hellpe
Member
From: France
Registered: 2012-11-03
Posts: 20

Re: [SOLVED] Kill the Gnome screen curtain once and for all

I'm having the exact same problem than marko2010 ; the topic linked above is not a fix to this issue.
I'm actually fine with screen dimming, but I don't need/want that shield to be brought up every time I go back to my computer. Until now, I was using that Disable Screen Shield extension. Why the "Screen Lock" parameter in gnome-control-center isn't taken into account?

Last edited by hellpe (2013-10-26 17:33:16)

Offline

#4 2013-10-26 17:24:34

KingYes
Member
From: Israel
Registered: 2011-05-08
Posts: 120
Website

Re: [SOLVED] Kill the Gnome screen curtain once and for all

I have problem with this screen lock.. because all my gnome exts disable.. so I need press alt+f2 + "r" command for restart the shell sad


Web Developer.

Offline

#5 2013-10-26 17:53:01

defears
Member
Registered: 2010-07-26
Posts: 218

Re: [SOLVED] Kill the Gnome screen curtain once and for all

This works for me.

dconf-editor
/org/gnome/desktop/lockdown/disable-lock-screen

Offline

#6 2013-10-26 18:21:26

KingYes
Member
From: Israel
Registered: 2011-05-08
Posts: 120
Website

Re: [SOLVED] Kill the Gnome screen curtain once and for all

@defears, no work for me.


Web Developer.

Offline

#7 2013-10-27 15:20:33

Chazza
Wiki Maintainer
From: United Kingdom
Registered: 2013-06-02
Posts: 506

Re: [SOLVED] Kill the Gnome screen curtain once and for all

I found something interesting. It would appear that in Gnome 3.10 screen locking is provided by gdm. If you use a different display manager like, say, lightdm then screenlocking is disabled.

Offline

#8 2013-10-28 21:53:58

KingYes
Member
From: Israel
Registered: 2011-05-08
Posts: 120
Website

Re: [SOLVED] Kill the Gnome screen curtain once and for all

When I use with this command for debug:

$ journalctl _PID=$(pidof gnome-session) -f

I get this notice:

Oct 28 23:52:04 localhost gnome-session[358]: (gnome-settings-daemon:396): power-plugin-CRITICAL **: gsd_power_backlight_abs_to_percentage: assertion 'max > min' failed

What I can to do?


Web Developer.

Offline

#9 2013-10-31 01:32:18

marko2010
Member
Registered: 2010-04-17
Posts: 68

Re: [SOLVED] Kill the Gnome screen curtain once and for all

Another possible way to kill off the annoying screen curtain might be via use of an extension. When I brows extension.gnome.org I see a "Curtains Up" extension presumable available for version 3.10. Although it appears to install, it never shows up in my list of extensions, and it certainly does not work. Here is the URL in case anyone can get it to work on gnome shell 3.10:

https://extensions.gnome.org/extension/730/curtains-up/

Last edited by marko2010 (2013-10-31 01:34:18)

Offline

#10 2013-11-19 18:00:11

marko2010
Member
Registered: 2010-04-17
Posts: 68

Re: [SOLVED] Kill the Gnome screen curtain once and for all

I think I finally found a way to disable the inactivity curtain in gnome 3.10. Launch dconf-editor then drill down org > gnome > desktop> session. Find the key for idle-delay and change it's value to 0 .

Or  you can do it in once step by running the command:

gsettings set org.gnome.desktop.session idle-delay 0

Note you would think that going into the gnome control center and moving Privacy > Screen Lock to "OFF" would completely disable the screen curtain, but this never worked for me. The curtain would still come up after periods of inactivity, but would no longer ask for a password. Adding the fix above, completely gets rid of this pesky thing.

Offline

#11 2014-10-17 19:33:19

jakub
Member
Registered: 2013-09-14
Posts: 149

Re: [SOLVED] Kill the Gnome screen curtain once and for all

Ahh don't know why but it doesn't work for me. What's wore I event can't swipe curtain up so I can't log in hmm I'm looking for some solution and currently using lightdm.
https://bbs.archlinux.org/viewtopic.php … 1#p1466541

Offline

Board footer

Powered by FluxBB