You are not logged in.

#1 2014-04-15 14:39:45

labotsirc
Member
Registered: 2013-08-21
Posts: 94

[SOLVED] Gnome terminal not working after upgrade to gnome 3.12

Whenever i run gnome-terminal, now i get this error:

[cristobal@orion ~]$ gnome-terminal 
Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.gnome.Terminal exited with status 1

I have tried this https://bbs.archlinux.org/viewtopic.php?pid=1403166 but no luck.

any ideas?

Last edited by labotsirc (2014-04-15 17:54:51)

Offline

#2 2014-04-15 15:18:22

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 4,584
Website

Re: [SOLVED] Gnome terminal not working after upgrade to gnome 3.12

Use xterm or urxvt tongue

Offline

#3 2014-04-15 16:08:18

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,108

Re: [SOLVED] Gnome terminal not working after upgrade to gnome 3.12

Have you searched the forums? There are 2 solved threads on this already.

https://bbs.archlinux.org/viewtopic.php?id=180081
https://bbs.archlinux.org/viewtopic.php?id=180073


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#4 2014-04-15 17:33:22

fredbezies
Member
Registered: 2011-07-28
Posts: 333

Re: [SOLVED] Gnome terminal not working after upgrade to gnome 3.12

Just a missing /etc/locale.conf as far as I've read ?

Offline

#5 2014-04-15 17:36:50

meunierd
Member
Registered: 2013-02-10
Posts: 10

Re: [SOLVED] Gnome terminal not working after upgrade to gnome 3.12

I don't have the locale or aur vte issues and I'm still unable to launch gnome-terminal.

Offline

#6 2014-04-15 17:54:35

labotsirc
Member
Registered: 2013-08-21
Posts: 94

Re: [SOLVED] Gnome terminal not working after upgrade to gnome 3.12

Ok everything is working. Just to clarify I did the locale issue and the vte3 issue altogether before posting this thread. I guess i was missing a reboot at the moment i posted this, i have no other explanation.
thanks

Last edited by labotsirc (2014-04-15 17:56:25)

Offline

#7 2014-04-15 18:00:41

link63
Member
Registered: 2014-04-15
Posts: 1

Re: [SOLVED] Gnome terminal not working after upgrade to gnome 3.12

# localectl set-locale LANG="en_US.UTF-8"
plus rebooting solved it for me

Offline

#8 2014-04-15 18:25:07

meunierd
Member
Registered: 2013-02-10
Posts: 10

Re: [SOLVED] Gnome terminal not working after upgrade to gnome 3.12

This makes no difference for me.

Offline

#9 2014-04-16 03:07:34

lmello
Member
From: Brazil
Registered: 2012-11-06
Posts: 300

Re: [SOLVED] Gnome terminal not working after upgrade to gnome 3.12

meunierd wrote:

This makes no difference for me.

Try to regenerate locales first:
# locale-gen

And then:
# localectl set-locale LANG="en_US.UTF-8"

And reboot.

Last edited by lmello (2014-04-16 03:12:09)


Fundamental Axiom of the Universe (aka Murphy's Law): Whatever can go wrong, will go wrong.
First Digital Deduction: Nothing obeys Murphy's Law so well as computers.
Second Digital Deduction: Everything go wrong at least once.
Third Digital Deduction: Things go wrong even when there's absolutely no possibility of anything go wrong.

Offline

#10 2014-04-16 15:24:00

labotsirc
Member
Registered: 2013-08-21
Posts: 94

Re: [SOLVED] Gnome terminal not working after upgrade to gnome 3.12

meunierd wrote:

This makes no difference for me.

How is the output of your "localectl" command ?
mine looks like this after it worked:

[cristobal@orion ~]$ localectl 
   System Locale: LANG=en_US.utf8
       VC Keymap: us
      X11 Layout: us
       X11 Model: pc105+inet
     X11 Options: terminate:ctrl_alt_bksp

Before that, it had n/a fields for VC Keymap and X11 layout.

Offline

#11 2014-04-16 23:51:39

dranger003
Member
Registered: 2014-04-16
Posts: 4

Re: [SOLVED] Gnome terminal not working after upgrade to gnome 3.12

I have the same issue... and I'm pretty sure I tried everything tied to the locale (including many reboots).

$ locale
LANG=en_US.UTF-8
LC_CTYPE=en_US.UTF-8
LC_NUMERIC=en_US.UTF-8
LC_TIME=en_US.UTF-8
LC_COLLATE=en_US.UTF-8
LC_MONETARY=en_US.UTF-8
LC_MESSAGES=en_US.UTF-8
LC_PAPER=en_US.UTF-8
LC_NAME=en_US.UTF-8
LC_ADDRESS=en_US.UTF-8
LC_TELEPHONE=en_US.UTF-8
LC_MEASUREMENT=en_US.UTF-8
LC_IDENTIFICATION=en_US.UTF-8
LC_ALL=

$ locale -a
C
en_US
en_US.iso88591
en_US.utf8
POSIX

$ localectl
   System Locale: LANG=en_US.UTF-8
       VC Keymap: cf
      X11 Layout: us,ca
     X11 Variant: ,

Offline

#12 2014-04-16 23:59:57

dranger003
Member
Registered: 2014-04-16
Posts: 4

Re: [SOLVED] Gnome terminal not working after upgrade to gnome 3.12

Same even with this setup:

$ locale
LANG=en_US.UTF-8
LC_CTYPE=en_US.UTF-8
LC_NUMERIC=en_US.UTF-8
LC_TIME=en_US.UTF-8
LC_COLLATE=en_US.UTF-8
LC_MONETARY=en_US.UTF-8
LC_MESSAGES=en_US.UTF-8
LC_PAPER=en_US.UTF-8
LC_NAME=en_US.UTF-8
LC_ADDRESS=en_US.UTF-8
LC_TELEPHONE=en_US.UTF-8
LC_MEASUREMENT=en_US.UTF-8
LC_IDENTIFICATION=en_US.UTF-8
LC_ALL=

$ locale -a
C
en_US.utf8
POSIX

$ localectl
   System Locale: LANG=en_US.UTF-8
       VC Keymap: us
      X11 Layout: us

Offline

#13 2014-04-17 00:35:49

dranger003
Member
Registered: 2014-04-16
Posts: 4

Re: [SOLVED] Gnome terminal not working after upgrade to gnome 3.12

OK, I found something - it doesn't work logged in as root (I know, I know...). It definitely used to work even logged in as root.
Works logged as user.. any idea why it stopped working as root?

Offline

#14 2014-04-17 07:21:58

ico
Member
Registered: 2011-01-25
Posts: 23

Re: [SOLVED] Gnome terminal not working after upgrade to gnome 3.12

dranger003 wrote:

OK, I found something - it doesn't work logged in as root (I know, I know...). It definitely used to work even logged in as root.
Works logged as user.. any idea why it stopped working as root?

yup, you are right.

Works fine as a normal user, but not as root.

[gagan@cozmo3 ~]$ sudo gnome-terminal
[sudo] password for gagan: 
Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.gnome.Terminal exited with status 1
[gagan@cozmo3 ~]$ gksu gnome-terminal
Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.gnome.Terminal exited with status 1

We can always 'su' anyway.

Last edited by ico (2014-04-17 07:24:52)

Offline

#15 2014-05-05 21:56:00

phubai
Member
Registered: 2011-01-28
Posts: 6

Re: [SOLVED] Gnome terminal not working after upgrade to gnome 3.12

lmello wrote:
meunierd wrote:

This makes no difference for me.

Try to regenerate locales first:
# locale-gen

And then:
# localectl set-locale LANG="en_US.UTF-8"

And reboot.

In case there are others...this worked for me. Simply issuing the set-locale... did nothing by itself, but the locale-gen and then the localectl set-locale... put things back together. This worked even though it looked set correctly beforehand.

Thanks!!

Offline

#16 2014-05-17 20:26:48

alphabeat
Member
Registered: 2014-05-17
Posts: 2

Re: [SOLVED] Gnome terminal not working after upgrade to gnome 3.12

Hey guys,

I totally ran into the same problem. I'm using LANG="de_DE.UTF-8". is there a way to stay by the german local settings? or does it just run by en utf-8?

thanks

Offline

#17 2014-05-23 06:52:57

alphabeat
Member
Registered: 2014-05-17
Posts: 2

Re: [SOLVED] Gnome terminal not working after upgrade to gnome 3.12

After having more and more issues with locale C I found the solution. I just wasn't using the local-gen thing right. All you have to do is edit /etc/locale.gen and uncomment all charsets you need. Then just run locale-gen again and restart your machine. Voila you have a working charset and a working terminal. And besides that you can get mongodb running as it should smile

Offline

#18 2014-05-24 05:30:40

DESPAIR
Member
Registered: 2014-05-24
Posts: 1

Re: [SOLVED] Gnome terminal not working after upgrade to gnome 3.12

Today I got last update "GNOME Terminal 3.12.2".
And problem seems like fixed.

Offline

#19 2014-10-18 04:23:42

rajat
Member
Registered: 2013-10-10
Posts: 10

Re: [SOLVED] Gnome terminal not working after upgrade to gnome 3.12

Works for me after localectl set-locale LANG="en_US.UTF-8" and Reboot. Not sure why this happens. However I am glad this fixes the issue.


Linux is easy.. People are Difficult

Offline

#20 2014-12-08 05:09:31

mtbrooks33
Member
Registered: 2011-06-08
Posts: 52

Re: [SOLVED] Gnome terminal not working after upgrade to gnome 3.12

I'm running into this issue with Gnome 3.14 on a fresh build of Arch. When I create a new user through through the gnome ui, that new user is able to use gnome terminal but I get the same error when I try and run it. The new user and I are in all of the same groups (if that even matters). Any ideas? I've tried everything posted in this thread.

Offline

#21 2014-12-08 05:25:33

mtbrooks33
Member
Registered: 2011-06-08
Posts: 52

Re: [SOLVED] Gnome terminal not working after upgrade to gnome 3.12

I've just managed to fix it by editing my /etc/local.conf file.

LANG="en_US.UTF-8"
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="C"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL="en_US.UTF-8"

I noticed somewhere (I think on a thread linked in a post on this thread) that someone had:

en_US-UTF-8

instead of:

en_US.UTF-8

in their /etc/locale.conf file. Changing the hyphen to a period fixed the problem for me.

Last edited by mtbrooks33 (2014-12-08 05:28:11)

Offline

#22 2014-12-20 10:30:03

el mariachi
Member
Registered: 2007-11-30
Posts: 595

Re: [SOLVED] Gnome terminal not working after upgrade to gnome 3.12

I tried all of the above and gnome-terminal is still not launching. Latest version from the repos (3.14)

Offline

#23 2015-03-12 09:47:35

sbt1
Member
Registered: 2015-01-14
Posts: 24

Re: [SOLVED] Gnome terminal not working after upgrade to gnome 3.12

Hello,

suddenly I have this problem, too.

Resetting the locale and installing vte3 like mentioned in one of the linked threads above didn't help.

This problem occured just yesterday without having updated anything that could have something to do with this problem.

Any ideas whats wrong here or which information I could provide that helps?

EDIT: The error is:

Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.gnome.Terminal exited with status 8

EDIT2: Suddenly works again, never mind

Last edited by sbt1 (2015-03-17 21:42:22)

Offline

#24 2015-03-30 19:46:27

lvanderree
Member
Registered: 2015-03-30
Posts: 1

Re: [SOLVED] Gnome terminal not working after upgrade to gnome 3.12

I had this same issue as well, and also tried everything without any effects.

My local was at first not UTF-8, but ISO. I changed that to (both Dutch and English) ISO, but as said without any effect.
I once was able to start gnome-terminal while I had su(do-ed) to root and then it came to me that my user locale in gnome was different from my root locale.
So I changed my user settings in the gnome configuration panel from Dutch to English, restarted gnome as requested, and then tried to start gnome-terminal et voila! It was working. Then I changed my user configuration back to Dutch and now gnome-terminal would start again without any problems.

It looks to me like the first-time you start gnome-terminal, it should be done with the user-settings in English (or the same as your root locale?).

Maybe someone can confirm that the gnome-language-settings has something to do with the error messages, as described by others as well.

Last edited by lvanderree (2015-03-30 19:47:51)

Offline

#25 2015-03-31 02:22:29

w201
Member
Registered: 2012-10-04
Posts: 267

Re: [SOLVED] Gnome terminal not working after upgrade to gnome 3.12

Head_on_a_Stick wrote:

Use xterm or urxvt tongue

I second urxvt

Offline

Board footer

Powered by FluxBB