You are not logged in.

#26 2014-06-06 20:38:05

ebeyer
Member
Registered: 2013-06-20
Posts: 6

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

WonderWoofy wrote:
rusty725 wrote:

solved cause you can rollback at least that's why.

Yeah... that's not really a solution.  It is a temporary workaround, but certainly not a solution.

Maybe the forums could use a [WORKAROUND] tag.

Offline

#27 2014-06-07 00:52:15

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,414

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

People use that sometimes, and I don't think anyone has an issue with it.  In reality, you could actually put whatever you want in that title...

Offline

#28 2014-06-07 10:42:14

psycho
Member
Registered: 2013-04-26
Posts: 29

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

thiagowfx wrote:

Apparently the reason this issue isn't affecting me is because I'm using the Human cursor theme (available in the AUR). See the bug report, at least one more user says this is a workaround.

I am also using Human cursor theme and it still affects me. Most of the perl dependant packages i'm using are broken, such as rxvt, weechat, finch. Even `cpanp' throws segfaults. Could this be a perl related issue, and not only libxcursor ? Or does libxcursor breaks up perl and therefore these issues ?


~ > fortune
I never met a piece of chocolate I didn't like.

Offline

#29 2014-06-07 13:53:13

ProtoTech
Member
Registered: 2014-05-31
Posts: 25

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

psycho wrote:
thiagowfx wrote:

Apparently the reason this issue isn't affecting me is because I'm using the Human cursor theme (available in the AUR). See the bug report, at least one more user says this is a workaround.

I am also using Human cursor theme and it still affects me. Most of the perl dependant packages i'm using are broken, such as rxvt, weechat, finch. Even `cpanp' throws segfaults. Could this be a perl related issue, and not only libxcursor ? Or does libxcursor breaks up perl and therefore these issues ?

Same here. Downloaded the Human cursor theme, applied it, updated libxcursor, rebooted and no-go. Still having issues. Downgrading still works like a charm though.

Offline

#30 2014-06-07 14:42:11

thiagowfx
Member
Registered: 2013-07-09
Posts: 586

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

@psycho and @ProtoTech In this case I guess I'm very lucky, so I have no idea what aspect of my setup is making me avoid those crashes. I thought it was the icon theme because @amarradi from the bug tracker said it was a workaround for him too. I'm willing to do some tests to make my X programs crash (crazy =P), but I don't know where to look at.

Question: what WM / DE are you two using?

thiago@arch ~ $ pacman -Q libxcursor xcursor-human numix-themes-archblue numix-icon-theme-git numix-themes
libxcursor 1.1.14-2
xcursor-human 0.6-4
numix-themes-archblue 2.2.3-1
numix-icon-theme-git 0.r158.bcd1610-1
numix-themes 2.2.3-1

Offline

#31 2014-06-07 20:52:40

psycho
Member
Registered: 2013-04-26
Posts: 29

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

thiagowfx wrote:

Question: what WM / DE are you two using?

Using StumpWM atm. I tried downgrading - didn't work -, i copied `/usr/share/icons/Human' in `/usr/share/icons/default' - didn't work -, i modified the index.theme files both from ~/.icons and /usr/share/icons/default/ - didn't work -, i had set the mouse cursor theme in Xdefaults, no change. Tbh i have no idea what to try anymore.


~ > fortune
I never met a piece of chocolate I didn't like.

Offline

#32 2014-06-10 07:03:12

axper
Member
Registered: 2013-01-25
Posts: 115

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

For me only urxvt segfaults.

Downgraded libxcursor to 1.1.14-1, still the same. Is this a different bug?

Offline

#33 2014-06-10 09:04:46

jjacky
Member
Registered: 2011-11-09
Posts: 347
Website

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

axper wrote:

For me only urxvt segfaults.

Downgraded libxcursor to 1.1.14-1, still the same. Is this a different bug?

sounds like you didn't update/recompile urxvt w/ perl 5.20

Offline

#34 2014-06-10 09:15:50

axper
Member
Registered: 2013-01-25
Posts: 115

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

jjacky wrote:
axper wrote:

For me only urxvt segfaults.

Downgraded libxcursor to 1.1.14-1, still the same. Is this a different bug?

sounds like you didn't update/recompile urxvt w/ perl 5.20

Thanks, that was indeed the case. I updated to perl-5.20.0-2 and rxvt-unicode-9.20-2 and it worked.

Sorry for hijacking the thread.

Offline

#35 2014-06-10 15:28:23

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,828

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

Everyone experiencing this, please read https://bugs.archlinux.org/task/40658#comment124132

Offline

#36 2014-06-10 20:28:04

psycho
Member
Registered: 2013-04-26
Posts: 29

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

Scimmia wrote:

Everyone experiencing this, please read https://bugs.archlinux.org/task/40658#comment124132

None of the methods explained in the bugtracker work for me. This almost makes me want to reinstall, or even try some bsd distro.


~ > fortune
I never met a piece of chocolate I didn't like.

Offline

#37 2014-06-10 22:34:10

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,828

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

psycho wrote:
Scimmia wrote:

Everyone experiencing this, please read https://bugs.archlinux.org/task/40658#comment124132

None of the methods explained in the bugtracker work for me. This almost makes me want to reinstall, or even try some bsd distro.

Did you create a /usr/share/icons/default symlink? If so, downgrade libxcursor, remove that symlink, then upgrade.

Offline

#38 2014-06-11 13:15:19

psycho
Member
Registered: 2013-04-26
Posts: 29

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

Scimmia wrote:

Did you create a /usr/share/icons/default symlink? If so, downgrade libxcursor, remove that symlink, then upgrade.

I never had a symlink, i used lxappearance and that only customized things through ~/.icons. I upgraded, deleted the default folder, downgraded and deleted stuff, tried everything. For me, weechat and finch also segfault when i'm not running X, so i have a hunch that perl could be the culprit, as gdb says when trying to load:

rxvt-unicode (aka urxvt)

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff38376c7 in boot_List__Util () from /usr/lib/perl5/site_perl/auto/List/Util/Util.so

finch

Program received signal SIGSEGV, Segmentation fault.
0x00007fffe888cd43 in boot_Encode () from /usr/lib/perl5/site_perl/auto/Encode/Encode.so

and weechat

Program received signal SIGSEGV, Segmentation fault.
0x00007fffed28fd43 in boot_Encode () from /usr/lib/perl5/site_perl/auto/Encode/Encode.so

I also tried downgrading perl, but perl was upgraded after the libxcursor issue.


~ > fortune
I never met a piece of chocolate I didn't like.

Offline

#39 2014-06-11 14:48:49

Scimmia
Fellow
Registered: 2012-09-01
Posts: 9,828

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

Yes, you're running in to the perl 5.20 upgrade, which is totally different than this.

Read the news on the front page. Anything you installed outside of the main repos needs to be rebuilt.

Offline

#40 2014-06-11 16:00:47

psycho
Member
Registered: 2013-04-26
Posts: 29

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

Scimmia wrote:

Yes, you're running in to the perl 5.20 upgrade, which is totally different than this.

Read the news on the front page. Anything you installed outside of the main repos needs to be rebuilt.

I read the `perl 5.20 update' topic and did step 2 from this post and now everything works as it should.


~ > fortune
I never met a piece of chocolate I didn't like.

Offline

#41 2014-09-12 04:53:36

powerpoint45
Member
Registered: 2013-03-06
Posts: 24

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

!!!SOLVED!!!

I compressed the solution to solve this issue using the resources already posted in this forum

just in-case first downgrade to libxcursor-1.1.14-1 using

pacman -U libxcursor-1.1.14-1-x86_64.pkg.tar.xz

. Package can be found here: http://seblu.net/a/arm/packages/l/

then do the following:

sudo rm -R /usr/share/icons/default

next remove perl

sudo rm -rf /usr/lib/perl5

now re-install perl

sudo pacman -S perl

now upgrade libxcursor

sudo pacman -S libxcursor

Enjoy! this should fix the crashes!

Last edited by powerpoint45 (2014-09-12 04:55:45)


Developer of Lucid Launcher for Android

Offline

#42 2014-09-12 19:42:32

DacStugly
Member
Registered: 2014-04-11
Posts: 1

Re: [WORKAROUND] libxcursor 1.1.14-2 causes apps segfaults

I just figured this out. The above is the best solution and it works. Thx!

Offline

Board footer

Powered by FluxBB