You are not logged in.

#1 2018-10-21 12:00:20

tesla135
Member
Registered: 2013-06-27
Posts: 38

Httpd not starting on random boots

On random boots the httpd daemon it does not start.

I saved two logs.

httpd.service - Apache Web Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Sun 2018-10-21 09:15:38 EEST; 5h 19min ago
  Process: 508 ExecReload=/usr/bin/httpd -k graceful (code=exited, status=1/FAILURE)
  Process: 459 ExecStart=/usr/bin/httpd -k start -DFOREGROUND (code=killed, signal=TERM)
 Main PID: 459 (code=killed, signal=TERM)

Oct 21 09:15:38 hostname httpd[459]: AH00558: httpd: Could not reliably determine the server's fully >
Oct 21 09:15:38 hostname httpd[508]: AH00558: httpd: Could not reliably determine the server's fully >
Oct 21 09:15:38 hostname httpd[508]: (98)Address already in use: AH00073: make_sock: unable to listen>
Oct 21 09:15:38 hostname httpd[508]: (98)Address already in use: AH00072: make_sock: could not bind t>
Oct 21 09:15:38 hostname httpd[508]: no listening sockets available, shutting down
Oct 21 09:15:38 hostname httpd[508]: AH00015: Unable to open logs
Oct 21 09:15:38 hostname httpd[508]: httpd not running, trying to start
Oct 21 09:15:38 hostname systemd[1]: httpd.service: Control process exited, code=exited status=1
Oct 21 09:15:38 hostname systemd[1]: httpd.service: Failed with result 'exit-code'.
Oct 21 09:15:38 hostname systemd[1]: Reload failed for Apache Web Server.
httpd.service - Apache Web Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Sun 2018-08-05 07:29:09 EEST; 28min ago
  Process: 480 ExecReload=/usr/bin/httpd -k graceful (code=exited, status=1/FAILURE)
  Process: 441 ExecStart=/usr/bin/httpd -k start -DFOREGROUND (code=killed, signal=TERM)
 Main PID: 441 (code=killed, signal=TERM)

Aug 05 07:29:11 hostname httpd[480]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
Aug 05 07:29:11 hostname httpd[480]: (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
Aug 05 07:29:11 hostname httpd[480]: no listening sockets available, shutting down
Aug 05 07:29:11 hostname httpd[480]: AH00015: Unable to open logs
Aug 05 07:29:11 hostname httpd[480]: httpd not running, trying to start
Aug 05 07:29:04 hostname systemd[1]: Started Apache Web Server.
Aug 05 07:29:06 hostname systemd[1]: Reloading Apache Web Server.
Aug 05 07:29:09 hostname systemd[1]: httpd.service: Control process exited, code=exited status=1
Aug 05 07:29:09 hostname systemd[1]: httpd.service: Failed with result 'exit-code'.
Aug 05 07:29:09 hostname systemd[1]: Reload failed for Apache Web Server.

I started the daemon

// start

httpd.service - Apache Web Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
   Active: active (running) since Sun 2018-10-21 14:46:28 EEST; 6s ago
  Process: 508 ExecReload=/usr/bin/httpd -k graceful (code=exited, status=1/FAILURE)
 Main PID: 9077 (httpd)
    Tasks: 6 (limit: 4605)
   Memory: 21.8M
   CGroup: /system.slice/httpd.service
           ├─9077 /usr/bin/httpd -k start -DFOREGROUND
           ├─9078 /usr/bin/httpd -k start -DFOREGROUND
           ├─9079 /usr/bin/httpd -k start -DFOREGROUND
           ├─9080 /usr/bin/httpd -k start -DFOREGROUND
           ├─9081 /usr/bin/httpd -k start -DFOREGROUND
           └─9082 /usr/bin/httpd -k start -DFOREGROUND

Oct 21 14:46:28 hostname systemd[1]: Started Apache Web Server.
Oct 21 14:46:28 hostname httpd[9077]: AH00112: Warning: DocumentRoot [/etc/httpd/docs/dummy-host.exam>
Oct 21 14:46:28 hostname httpd[9077]: AH00112: Warning: DocumentRoot [/etc/httpd/docs/dummy-host2.exa>
Oct 21 14:46:28 hostname httpd[9077]: AH00558: httpd: Could not reliably determine the server's fully>

Then a relod

// reload

httpd.service - Apache Web Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
   Active: active (running) since Sun 2018-10-21 14:46:28 EEST; 30s ago
  Process: 9098 ExecReload=/usr/bin/httpd -k graceful (code=exited, status=0/SUCCESS)
 Main PID: 9077 (httpd)
    Tasks: 6 (limit: 4605)
   Memory: 22.8M
   CGroup: /system.slice/httpd.service
           ├─9077 /usr/bin/httpd -k start -DFOREGROUND
           ├─9099 /usr/bin/httpd -k start -DFOREGROUND
           ├─9100 /usr/bin/httpd -k start -DFOREGROUND
           ├─9101 /usr/bin/httpd -k start -DFOREGROUND
           ├─9102 /usr/bin/httpd -k start -DFOREGROUND
           └─9103 /usr/bin/httpd -k start -DFOREGROUND

Oct 21 14:46:28 hostname systemd[1]: Started Apache Web Server.
Oct 21 14:46:28 hostname httpd[9077]: AH00112: Warning: DocumentRoot [/etc/httpd/docs/dummy-host.exam>
Oct 21 14:46:28 hostname httpd[9077]: AH00112: Warning: DocumentRoot [/etc/httpd/docs/dummy-host2.exa>
Oct 21 14:46:28 hostname httpd[9077]: AH00558: httpd: Could not reliably determine the server's fully>
Oct 21 14:46:56 hostname systemd[1]: Reloading Apache Web Server.
Oct 21 14:46:56 hostname httpd[9098]: AH00112: Warning: DocumentRoot [/etc/httpd/docs/dummy-host.exam>
Oct 21 14:46:56 hostname httpd[9098]: AH00112: Warning: DocumentRoot [/etc/httpd/docs/dummy-host2.exa>
Oct 21 14:46:56 hostname httpd[9098]: AH00558: httpd: Could not reliably determine the server's fully>
Oct 21 14:46:56 hostname systemd[1]: Reloaded Apache Web Server.

/usr/lib/systemd/system/httpd.service


[Unit]
Description=Apache Web Server
After=network.target remote-fs.target nss-lookup.target

[Service]
Type=simple
ExecStart=/usr/bin/httpd -k start -DFOREGROUND
ExecStop=/usr/bin/httpd -k graceful-stop
ExecReload=/usr/bin/httpd -k graceful
PrivateTmp=true
LimitNOFILE=infinity
KillMode=mixed

[Install]
WantedBy=multi-user.target

Offline

#2 2018-10-21 12:08:00

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 3,013

Re: Httpd not starting on random boots

Set your hostname.

Also post the output of...

systemctl list-unit-files --state=enabled

No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Online

#3 2018-10-21 12:39:10

tesla135
Member
Registered: 2013-06-27
Posts: 38

Re: Httpd not starting on random boots

The hostname was set to "hostname" long time ago (after instalation in /etc/hostname) . big_smile

And in my /etc/hosts

127.0.0.1	localhost.localdomain	localhost
::1		localhost.localdomain	localhost
127.0.1.1	hostname

systemctl list-unit-files --state=enabled

 
UNIT FILE                 STATE  
autostart.service         enabled
autovt@.service           enabled
cronie.service            enabled
getty@.service            enabled
httpd.service             enabled
mariadb.service           enabled
mysqld.service            enabled
named.service             enabled
systemd-timesyncd.service enabled
remote-fs.target          enabled

Offline

#4 2018-10-21 13:06:24

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 3,013

Re: Httpd not starting on random boots

Try changing your hostname to something else, I think I remember reading somewhere that hostname is reserved and shouldn't be used.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Online

#5 2018-10-21 13:06:49

seth
Member
Registered: 2012-09-03
Posts: 8,981

Re: Httpd not starting on random boots

Offline

#6 2018-10-21 13:54:49

tesla135
Member
Registered: 2013-06-27
Posts: 38

Re: Httpd not starting on random boots

Ok, I set hostname to myhost and full hostname to myhost.myhost.net. I'll be back...if the problem appears again.

Offline

#7 2018-10-28 05:29:47

tesla135
Member
Registered: 2013-06-27
Posts: 38

Re: Httpd not starting on random boots

Well, it happened again

httpd.service - Apache Web Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Sun 2018-10-28 07:02:59 EET; 25min ago
  Process: 491 ExecReload=/usr/bin/httpd -k graceful (code=exited, status=1/FAILURE)
  Process: 467 ExecStart=/usr/bin/httpd -k start -DFOREGROUND (code=killed, signal=TERM)
 Main PID: 467 (code=killed, signal=TERM)

Oct 28 07:02:54 myhost systemd[1]: Started Apache Web Server.
Oct 28 07:02:57 myhost systemd[1]: Reloading Apache Web Server.
Oct 28 07:02:59 myhost httpd[491]: (98)Address already in use: AH00072: make_sock: could not bind to >
Oct 28 07:02:59 myhost httpd[491]: (98)Address already in use: AH00072: make_sock: could not bind to >
Oct 28 07:02:59 myhost httpd[491]: no listening sockets available, shutting down
Oct 28 07:02:59 myhost httpd[491]: AH00015: Unable to open logs
Oct 28 07:02:59 myhost systemd[1]: httpd.service: Control process exited, code=exited status=1
Oct 28 07:02:59 myhost httpd[491]: httpd not running, trying to start
Oct 28 07:02:59 myhost systemd[1]: httpd.service: Failed with result 'exit-code'.
Oct 28 07:02:59 myhost systemd[1]: Reload failed for Apache Web Server.

Offline

#8 2018-10-28 07:33:05

seth
Member
Registered: 2012-09-03
Posts: 8,981

Re: Httpd not starting on random boots

You might have noticed that the unreliable hostname error is gone.

Please post the servers complete log and your journal (it seems you copy & paste the systemctl status output from a VTE? It's cut off) for a better idea on what's going on.
Also see https://wiki.archlinux.org/index.php/Ap … to_address and in doubt share  your server config as well.

Offline

#9 2018-10-28 11:50:18

tesla135
Member
Registered: 2013-06-27
Posts: 38

Re: Httpd not starting on random boots

From journalctl

Oct 28 07:02:59 myhost httpd[491]: (98)Address already in use: AH00072: make_sock: could not bind     to address [::]:80
Oct 28 07:02:59 myhost httpd[491]: (98)Address already in use: AH00072: make_sock: could not bind     to address 0.0.0.0:80
Oct 28 07:02:59 myhost httpd[491]: no listening sockets available, shutting down
Oct 28 07:02:59 myhost httpd[491]: AH00015: Unable to open logs
Oct 28 07:02:59 myhost audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit    =httpd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
Oct 28 07:02:59 myhost systemd[1]: httpd.service: Control process exited, code=exited status=1
Oct 28 07:02:59 myhost httpd[491]: httpd not running, trying to start
Oct 28 07:02:59 myhost systemd[1]: httpd.service: Failed with result 'exit-code'.

netstat -lnp | grep -e :80 -e :443

tcp6       0      0 :::80                   :::*                    LISTEN      4467/httpd

But the last output I get it after I reloaded httpd.

P.S. in my httpd.conf I have only
Listen 80

and Listen 443 in extra/httpd-ssl.conf

Offline

#10 2018-10-28 13:36:36

seth
Member
Registered: 2012-09-03
Posts: 8,981

Re: Httpd not starting on random boots

Not "from" - https://bbs.archlinux.org/viewtopic.php?id=57855 - Context matters.
The server apparently restarts for some reason, so there must be a previous problem and it runs into itself. Also the apparently random behavior suggests a race condition.

Offline

#11 2018-11-11 06:15:28

tesla135
Member
Registered: 2013-06-27
Posts: 38

Re: Httpd not starting on random boots

Well, it happened again, now here is the full log:

httpd.service - Apache Web Server
Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Sun 2018-11-11 07:35:25 EET; 18min ago
Process: 482 ExecReload=/usr/bin/httpd -k graceful (code=exited, status=1/FAILURE)
Process: 448 ExecStart=/usr/bin/httpd -k start -DFOREGROUND (code=killed, signal=TERM)
Main PID: 448 (code=killed, signal=TERM) 
Nov 11 07:35:19 myhost systemd[1]: Started Apache Web Server.
Nov 11 07:35:21 myhost systemd[1]: Reloading Apache Web Server.
Nov 11 07:35:24 myhost httpd[482]: (98)Address already in use: AH00073: make_sock: unable to listen for connections on address [::]:80
Nov 11 07:35:24 myhost httpd[482]: (98)Address already in use: AH00072: make_sock: could not bind  to address 0.0.0.0:80
Nov 11 07:35:24 myhost httpd[482]: no listening sockets available, shutting down
Nov 11 07:35:24 myhost httpd[482]: AH00015: Unable to open logs
Nov 11 07:35:24 myhost httpd[482]: httpd not running, trying to start
Nov 11 07:35:24 myhost systemd[1]: httpd.service: Control process exited, code=exited status=1
Nov 11 07:35:25 myhost systemd[1]: httpd.service: Failed with result 'exit-code'.
Nov 11 07:35:25 myhost systemd[1]: Reload failed for Apache Web Server.

I noticed ( if you look at the date of previous logs)...that this happens only on Sunday.

P.S.

httpd -k start

(13)Permission denied: AH00072: make_sock: could not bind to address [::]:80
(13)Permission denied: AH00072: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
AH00015: Unable to open logs

Last edited by tesla135 (2018-11-11 06:18:36)

Offline

#12 2018-11-11 08:02:33

seth
Member
Registered: 2012-09-03
Posts: 8,981

Re: Httpd not starting on random boots

The last output is a mere permission issue, you need root privs to bind to ports < 1024

Again, the full journal around the incident (or the entire boot) would be interesting (you just posted the log of the failed re(?)start)
What happens on sundays? Does eg. the router/dhcp server reboot?
What is actually listening on port 80 when this happens? ("sudo netstat -tulpen")

Offline

#13 2018-11-11 10:06:43

tesla135
Member
Registered: 2013-06-27
Posts: 38

Re: Httpd not starting on random boots

seth wrote:

Again, the full journal around the incident (or the entire boot) would be interesting (you just posted the log of the failed re(?)start)

But I do not know where to find the full journal.


seth wrote:

What happens on sundays? Does eg. the router/dhcp server reboot?

httpd is not installed on a server, it's on my laptop...and I boot arch linux in the morning every day.

seth wrote:

What is actually listening on port 80 when this happens? ("sudo netstat -tulpen")

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       User       Inode      PID/Program name    
tcp        0      0 0.0.0.0:51413           0.0.0.0:*               LISTEN      1000       29701      1542/transmission-g 
tcp        0      0 192.168.1.22:53         0.0.0.0:*               LISTEN      40         22299      456/named           
tcp        0      0 192.168.1.2:53          0.0.0.0:*               LISTEN      40         21375      456/named           
tcp        0      0 127.0.0.1:53            0.0.0.0:*               LISTEN      40         19243      456/named           
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      0          23487      1072/sshd           
tcp6       0      0 :::3306                 :::*                    LISTEN      89         17345      553/mysqld          
tcp6       0      0 :::80                   :::*                    LISTEN      0          156241     6430/httpd          
tcp6       0      0 :::51413                :::*                    LISTEN      1000       29703      1542/transmission-g 
tcp6       0      0 :::53                   :::*                    LISTEN      40         19239      456/named           
tcp6       0      0 :::22                   :::*                    LISTEN      0          23489      1072/sshd           
udp        0      0 192.168.1.22:53         0.0.0.0:*                           40         22298      456/named           
udp        0      0 192.168.1.2:53          0.0.0.0:*                           40         21374      456/named           
udp        0      0 127.0.0.1:53            0.0.0.0:*                           40         19242      456/named           
udp        0      0 0.0.0.0:68              0.0.0.0:*                           0          23286      1049/dhcpcd         
udp        0      0 0.0.0.0:51413           0.0.0.0:*                           1000       29704      1542/transmission-g 
udp        0      0 0.0.0.0:53526           0.0.0.0:*                           1000       28802      1542/transmission-g 
udp6       0      0 :::53                   :::*                                40         19238      456/named           

The weird thing is that I setup an ip static to my laptop(192.168.1.2), and in the above output and in my wireless router dhcp client list it's viewed with
192.168.1.22


Later edit:

ip address show


1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp7s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether b8:2a:72:a8:ec:58 brd ff:ff:ff:ff:ff:ff
3: wlp6s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 90:48:9a:41:5a:6d brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global wlp6s0
       valid_lft forever preferred_lft forever
    inet 192.168.1.22/24 brd 192.168.1.255 scope global secondary noprefixroute wlp6s0
       valid_lft forever preferred_lft forever
    inet6 fe80::9248:9aff:fe41:5a6d/64 scope link 
       valid_lft forever preferred_lft forever

I used netctl:

Description='A simple WPA encrypted wireless connection' 
Interface=wlp6s0 
Connection=wireless 
Security=wpa 
 
IP=static
Address=('192.168.1.2/24')
Gateway=('192.168.1.1')
DNS=('192.168.1.1')
  

Last edited by tesla135 (2018-11-11 13:01:32)

Offline

#14 2018-11-11 13:40:21

seth
Member
Registered: 2012-09-03
Posts: 8,981

Re: Httpd not starting on random boots

"sudo journalctl -b", see https://wiki.archlinux.org/index.php/Systemd#Journal

I wasn't asking whether your http server reboots, but the dhcp one (there's usually one in comsumer routers, it's what hands out IP addresses)

In that netstat, port 80 is taken by httpd - do you deliberately run a DNS server on the notebook?
As for your IPs:

ip a
ip r

Offline

#15 2018-11-11 14:21:39

tesla135
Member
Registered: 2013-06-27
Posts: 38

Re: Httpd not starting on random boots

seth wrote:

Do you deliberately run a DNS server on the notebook?

Yes, for some development

Ok, here is some logs from boot to around the incident

https://pastebin.com/akeXMKRf

And ip a outputs exactly like ip address show

ip r

default via 192.168.1.1 dev wlp6s0 proto dhcp src 192.168.1.22 metric 303 
192.168.1.0/24 dev wlp6s0 proto dhcp scope link src 192.168.1.22 metric 303 

Offline

#16 2018-11-11 14:48:42

seth
Member
Registered: 2012-09-03
Posts: 8,981

Re: Httpd not starting on random boots

Please no paraphrases, but if there're only two interfaces (one being the loopback, though the journal suggests there's also a wire interface) this means your static IP setup doesn't work and your particular network setup routine becomes a critical aspect of this.

Also I notice that the httpd initially tries to start before the network is actually up, which is odd.

Nov 11 07:35:24 myhost httpd[482]: (98)Address already in use: AH00073: make_sock: unable to listen for connections on address [::]:80
Nov 11 07:36:09 myhost systemd[1]: Reached target Network.

Is the service maybe started independently?
What if you wait after "network-online.target" instead of "network.target"?

I don't see anything that'd take local port 80, though.

Akso for a wild guess i'd take out the bind daemon (next sunday ;-)

Offline

#17 2018-11-18 08:33:54

tesla135
Member
Registered: 2013-06-27
Posts: 38

Re: Httpd not starting on random boots

Well, I disabled yesterday the bind daemon:

sudo systemctl disable named

And it still happened this morning when I booted my system.

https://pastebin.com/96xYzmh7

About the network, I forgot about a custom script that I created long time ago.

/home/reconnect.sh

Nov 18 08:26:03 myhost CROND[589]: (root) CMD (/home/reconnect.sh)
Nov 18 08:26:03 myhost systemd[1]: Created slice system-netctl.slice.
Nov 18 08:26:03 myhost systemd[1]: Starting Networking for netctl profile arch-net...
Nov 18 08:26:03 myhost network[596]: Starting network profile 'arch-net'...
Nov 18 08:26:04 myhost kernel: IPv6: ADDRCONF(NETDEV_UP): wlp6s0: link is not ready
Nov 18 08:26:05 myhost kernel: wlp6s0: authenticate with 84:16:f9:9b:e5:56
Nov 18 08:26:05 myhost kernel: wlp6s0: send auth to 84:16:f9:9b:e5:56 (try 1/3)
Nov 18 08:26:05 myhost kernel: wlp6s0: authenticated
Nov 18 08:26:05 myhost kernel: wlp6s0: associate with 84:16:f9:9b:e5:56 (try 1/3)
Nov 18 08:26:05 myhost kernel: wlp6s0: RX AssocResp from 84:16:f9:9b:e5:56 (capab=0x431 status=0 aid=2)
Nov 18 08:26:05 myhost kernel: wlp6s0: associated
Nov 18 08:26:05 myhost kernel: IPv6: ADDRCONF(NETDEV_CHANGE): wlp6s0: link becomes ready
Nov 18 08:26:05 myhost systemd[1]: Started Networking for netctl profile arch-net.

Wich starts after httpd.

Nov 18 08:25:57 myhost httpd[482]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
Nov 18 08:25:57 myhost httpd[482]: (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
Nov 18 08:25:57 myhost httpd[482]: no listening sockets available, shutting down
Nov 18 08:25:57 myhost httpd[482]: AH00015: Unable to open logs
Nov 18 08:25:58 myhost httpd[482]: httpd not running, trying to start
Nov 18 08:25:58 myhost systemd[1]: httpd.service: Control process exited, code=exited status=1
Nov 18 08:25:58 myhost systemd[1]: httpd.service: Failed with result 'exit-code'.
Nov 18 08:25:58 myhost systemd[1]: Reload failed for Apache Web Server.

But, why it fails only sunday(on first boot)?

/home/reconnect.sh

#!/bin/bash

if [[ ! $( ifconfig |  grep 'wlp6s0') ]]; then
     netctl start arch-net
###     dhcpcd

elif [[ ! $( ifconfig | grep -E '192\.168\.[0-9]+\.[0-9]+' ) ]]; then
    netctl start arch-net
###    dhcpcd
fi



if [[ -z $(systemctl status sshd | grep "Active: active (running)") ]]; then
   systemctl restart sshd
fi 

The commented line with dhcpcd was the two ips problem. I commented yesterday, but the httpd problem remains.

LE: reconnect.sh starts with crontab

sudo crontab -e

*/1 * * * * /home/reconnect.sh

Last edited by tesla135 (2018-11-18 08:45:00)

Offline

#18 2018-11-25 06:59:18

tesla135
Member
Registered: 2013-06-27
Posts: 38

Re: Httpd not starting on random boots

Without /home/reconnect.sh

https://pastebin.com/NTdd57NR

I'll try next time without  bind and reconnect.sh.

Offline

#19 2018-12-02 08:15:11

tesla135
Member
Registered: 2013-06-27
Posts: 38

Re: Httpd not starting on random boots

Without  bind and reconnect.sh

https://pastebin.com/nL5y7r9E

Offline

Board footer

Powered by FluxBB