You are not logged in.

#1 2018-11-08 12:19:26

TheSaint
Member
From: my computer
Registered: 2007-08-19
Posts: 1,512

[Solved] wpa_supplicant@interface.service failed

Hello forum,

I tried to simplify my connections, I'm using just my smartphone as AP. So I decided to setup systemd-networkd, but I'd like to have the wpa_supplicant to connect automatically.
I'm trying to start the service

sudo systemctl -xe
Nov 08 20:05:38 AsusG75 systemd[1]: Dependency failed for WPA supplicant daemon (interface-specific version).
-- Subject: Unit wpa_supplicant@wpl3s0.service has failed
-- Defined-By: systemd
-- Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit wpa_supplicant@wpl3s0.service has failed.
-- 
-- The result is dependency.
Nov 08 20:05:38 AsusG75 systemd[1]: wpa_supplicant@wpl3s0.service: Job wpa_supplicant@wpl3s0.service/start failed with result 'dependency'.
Nov 08 20:05:38 AsusG75 systemd[1]: sys-subsystem-net-devices-wpl3s0.device: Job sys-subsystem-net-devices-wpl3s0.device/start failed with result 'timeout'.
Nov 08 20:05:43 AsusG75 sudo[9827]:   myself : TTY=pts/1 ; PWD=/home/myself ; USER=root ; COMMAND=/usr/bin/wpa_supplicant -B -c /etc/wpa_supplicant/wpa_supplicant-wlp3s0.conf -i wlp3s0

$ systemctl --type=service 
UNIT                                               LOAD   ACTIVE SUB     DESCRIPTION               
alsa-restore.service                               loaded active exited  Save/Restore Sound Card St>
avahi-daemon.service                               loaded active running Avahi mDNS/DNS-SD Stack   
bluetooth.service                                  loaded active running Bluetooth service         
dbus.service                                       loaded active running D-Bus System Message Bus  
getty@tty1.service                                 loaded active running Getty on tty1             
iptables.service                                   loaded active exited  Packet Filtering Framework
kmod-static-nodes.service                          loaded active exited  Create list of required st>
ldconfig.service                                   loaded active exited  Rebuild Dynamic Linker Cac>
lvm2-lvmetad.service                               loaded active running LVM2 metadata daemon      
lvm2-monitor.service                               loaded active exited  Monitoring of LVM2 mirrors>
ntpd.service                                       loaded active running Network Time Service      
polkit.service                                     loaded active running Authorization Manager     
rtkit-daemon.service                               loaded active running RealtimeKit Scheduling Pol>
sda-spindown.service                               loaded active exited  Set HDD spindown          
systemd-backlight@backlight:acpi_video0.service    loaded active exited  Load/Save Screen Backlight>
systemd-backlight@backlight:acpi_video1.service    loaded active exited  Load/Save Screen Backlight>
systemd-backlight@leds:asus::kbd_backlight.service loaded active exited  Load/Save Screen Backlight>
systemd-binfmt.service                             loaded active exited  Set Up Additional Binary F>
systemd-fsck@dev-disk-by\x2dlabel-Datasave.service loaded active exited  File System Check on /dev/>
systemd-fsck@dev-disk-by\x2dlabel-Home.service     loaded active exited  File System Check on /dev/>
systemd-hwdb-update.service                        loaded active exited  Rebuild Hardware Database 
systemd-journal-catalog-update.service             loaded active exited  Rebuild Journal Catalog   
systemd-journal-flush.service                      loaded active exited  Flush Journal to Persisten>
systemd-journald.service                           loaded active running Journal Service           
systemd-logind.service                             loaded active running Login Service             
systemd-modules-load.service                       loaded active exited  Load Kernel Modules       
systemd-networkd.service                           loaded active running Network Service           
systemd-random-seed.service                        loaded active exited  Load/Save Random Seed     
systemd-remount-fs.service                         loaded active exited  Remount Root and Kernel Fi>
systemd-resolved.service                           loaded active running Network Name Resolution   
systemd-sysctl.service                             loaded active exited  Apply Kernel Variables    
systemd-sysusers.service                           loaded active exited  Create System Users       
systemd-timesyncd.service                          loaded active running Network Time Synchronizati>
systemd-tmpfiles-setup-dev.service                 loaded active exited  Create Static Device Nodes>
systemd-tmpfiles-setup.service                     loaded active exited  Create Volatile Files and >
systemd-udev-trigger.service                       loaded active exited  udev Coldplug all Devices 
systemd-udevd.service                              loaded active running udev Kernel Device Manager
systemd-update-done.service                        loaded active exited  Update is Completed       
systemd-update-utmp.service                        loaded active exited  Update UTMP about System B>
systemd-user-sessions.service                      loaded active exited  Permit User Sessions      
udisks2.service                                    loaded active running Disk Manager              
upower.service                                     loaded active running Daemon for power management
user-runtime-dir@1001.service                      loaded active exited  User Runtime Directory /ru>
user@1001.service                                  loaded active running User Manager for UID 1001 

But if I start wpa_supplicant at the CLI, is getting right, so this is written after that connection wink

Last edited by TheSaint (2018-11-08 15:12:56)


do it good first, it will be faster than do it twice the saint wink

Offline

#2 2018-11-08 13:56:26

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 26,733
Website

Re: [Solved] wpa_supplicant@interface.service failed

wpl3s0 != wlp3s0


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#3 2018-11-08 15:12:31

TheSaint
Member
From: my computer
Registered: 2007-08-19
Posts: 1,512

Re: [Solved] wpa_supplicant@interface.service failed

Thank you ! You're an acute observer smile

A terrible oversight sad


do it good first, it will be faster than do it twice the saint wink

Offline

Board footer

Powered by FluxBB