You are not logged in.

#1 2022-01-07 04:02:33

Registered: 2022-01-07
Posts: 1

First Time Arch Installation Not Working, on an Asus Chromebook

Hello, I am trying to install Arch for the first time, but I am having issues. I am installing it on an Asus C200M chromebook, it has a Intel Bay Trail-M dual-core N2830 CPU, 2GB RAM, and about 16GB internal storage eMMC. I think the issue may be with how I partitioned it, but I'm not sure. I tried following the installation guide's example memory layouts, first for BIOS/GPT, and then BIOS/MBR, except I used 10GB for the root directory and the rest for the /home directory on separate partitions. When I tried with GPT, I set the first partition, /dev/mmcblk1p1, to type BIOS boot. I tried flagging it as bootable, but I didn't see anything change. When I tried with MBR, I first had SWAP as the first partition, root as the second, and /home as the third. I tried flagging the root partition as bootable, but again saw no change. I then changed it so the first partition was 30KiB of type "MBR partition scheme", the second partition as root, the third partition as /home, and the fourth partition as swap. I tried flagging the first partition as bootable but saw no change. Both times when I tried installing GRUB with MBR partition schemes, in the output I saw that it read the partition scheme as GPT and it couldn't find a bootable partition.


#2 2022-01-07 11:00:44

From: London
Registered: 2014-02-20
Posts: 6,217

Re: First Time Arch Installation Not Working, on an Asus Chromebook

Please post the actual commands you tried and verbatim output rather than vague (and very confusing) descriptions. See also

This will show us the disposition of your drive & partitions:

# parted --list

^ Run that from any live ISO. If you only have the Arch ISO see … ted_client for a way to share the output from there.

I have no experience with Chromebooks but I would recommend an MS-DOS ("MBR" type) partition table for non-UEFI systems and a GUID partition table for UEFI systems. I presume the Chromebook uses UEFI by default so I would prefer that.

And please try to break up your post a little more. Condensed blocks of text can be quite hard to follow. Well, they are for me anyway smile


#3 2022-01-07 11:46:02

Registered: 2016-11-21
Posts: 243

Re: First Time Arch Installation Not Working, on an Asus Chromebook

have you read this:

not a simple install it would seem, looks like you need to flash a custom firmware


Board footer

Powered by FluxBB