You are not logged in.

#1 2022-03-07 16:27:45

afader
Member
Registered: 2013-09-12
Posts: 162

[SOLVED] qt5-base broken

solved..rebuilt everything

❯ opensnitch-ui
Loading translations: /usr/lib/python3.10/site-packages/opensnitch/i18n locale: en_US
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
Cannot mix incompatible Qt library (5.15.2) with this library (5.15.3)
[1]    166367 IOT instruction (core dumped)  opensnitch-ui

opensnitch-git 1.5.0.r17.a2f237a-1
Arch Linux 5.15.26-hardened1-1-hardened-git-r1049098 #1 SMP PREEMPT Fri, 04 Mar 2022 02:53:28 +0000 x86_64 GNU/Linux
Gnome on wayland

See: https://github.com/evilsocket/opensnitch/issues/644
https://forum.artixlinux.org/index.php/ … 781.0.html
https://forum.manjaro.org/t/extra-qt5-e … 15-3/71426
https://discuss.getsol.us/d/7015-cannot … brary-5153

Last edited by afader (2022-03-07 17:30:43)

Offline

#2 2022-03-07 16:40:40

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,644

Re: [SOLVED] qt5-base broken

This nearly always means you have some Qt library installed from the AUR or elsewhere. Styles are a common cause. Whatever it is, it needs rebuit.

Last edited by Scimmia (2022-03-07 16:41:16)

Online

#3 2022-03-07 17:26:38

afader
Member
Registered: 2013-09-12
Posts: 162

Re: [SOLVED] qt5-base broken

I've tried various things like

yay -Si opensnitch-git | awk -F ": " -v filter="^Depends" \ '$0 ~ filter {gsub(/[>=<][^ ]*/,"",$2) ; gsub(/ +/,"\n",$2) ; print $2}' | yay -S --asdeps -

Rebuilding everything but can't seem to get this message to disappear

Offline

#4 2022-03-07 17:26:45

frabjous
Member
Registered: 2010-07-13
Posts: 367

Re: [SOLVED] qt5-base broken

For me, I had to reinstall qt5-styleplugins (after deleting it from my paru cache so it would rebuild from scratch). YMMV.

Last edited by frabjous (2022-03-07 17:26:58)

Offline

#5 2022-03-07 17:28:45

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,644

Re: [SOLVED] qt5-base broken

It has nothing to do with opensnitch. Look at all of your AUR packages.

Online

#6 2022-03-07 17:30:57

afader
Member
Registered: 2013-09-12
Posts: 162

Re: [SOLVED] qt5-base broken

OK, you're right, that fixed it, thanks!

Offline

#7 2022-03-08 12:29:23

RedArcher
Member
From: South Africa
Registered: 2009-09-03
Posts: 110

Re: [SOLVED] qt5-base broken

$ falkon
Fatal: Cannot mix incompatible Qt library (5.15.2) with this library (5.15.3)
Aborted (core dumped)
frabjous wrote:

For me, I had to reinstall qt5-styleplugins (after deleting it from my paru cache so it would rebuild from scratch). YMMV.

Thank you. That solved my problem.

Scimmia wrote:

This nearly always means you have some Qt library installed from the AUR or elsewhere. Styles are a common cause. Whatever it is, it needs rebuit.

May you please provide a command which can list packages from AUR starting with "qt"?

Offline

#8 2022-03-08 12:30:50

Slithery
Administrator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 5,776

Re: [SOLVED] qt5-base broken

RedArcher wrote:

May you please provide a command which can list packages from AUR starting with "qt"?

pacman -Qqm | grep ^qt

No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#9 2022-03-08 13:50:21

RedArcher
Member
From: South Africa
Registered: 2009-09-03
Posts: 110

Re: [SOLVED] qt5-base broken

I think it's worthy to make this Sticky

Offline

#10 2022-03-08 13:56:36

Slithery
Administrator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 5,776

Re: [SOLVED] qt5-base broken

It already is...

Forum rules wrote:

IF YOUR SYSTEM IS NOT UP TO DATE - YOU ARE DOING IT WRONG. PACMAN -Syu *BEFORE* POSTING

(Note that this only updates packages in repositories. You should also ensure foreign packages from the AUR and other locations are also updated. Similarly, if you have replaced an official package with an unsupported variant, try to reproduce the problem with the official package before creating a topic.)


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#11 2022-03-10 01:53:40

afader
Member
Registered: 2013-09-12
Posts: 162

Re: [SOLVED] qt5-base broken

Ha, true. TBH, I don't know why I didn't remember that there was such a thing as qt5-styleplugins, probably because I use mostly Gnome and a lot of Gtk apps or whatever they are, so I guess Opensnitch-Ui needing qt5-styleplugins to be rebuilt didn't occur to me because I forgot that I had installed the package to make qt5ct use the gtk3 theme or whatever... a pretty random implementation detail. If pressed I would probably have recalled about qt5ct and having to set an env var but not that it was a separate AUR package since i don't use plasma or KDE.

How would we fix that? I don't know, I have rebuild-detector installed but it didn't do anything in this case, although it does tell me when firefox-nightly or obs-studio-git need to be rebuilt. I guess this incompatible qt error message could maybe tell me it was coming from qt5styleplugins or whichever qt program that package installs. Either way, yeah it's kind of user error but it's also a flaw in the usability of implementation of qt packages.

Offline

#12 2022-03-11 19:16:05

wetTshirt
Member
Registered: 2014-10-17
Posts: 20

Re: [SOLVED] qt5-base broken

Hi guys,

even this is solved I would like to hang myself on that topic as I have the same error message without a AUR package in use. For me same error message appears for xca which is in community repo. Could that anyhow be related? The filed bug was closed due to belief in incompatible qt style. See https://bugs.archlinux.org/task/74096

Offline

#13 2022-03-11 21:46:48

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 21,892

Re: [SOLVED] qt5-base broken

Are you sure you don't have another qt style?

pacman -Qm | grep ^qt5

which qt theme are you using?

Offline

#14 2022-03-11 22:30:05

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,644

Re: [SOLVED] qt5-base broken

wetTshirt wrote:

Hi guys,

even this is solved I would like to hang myself on that topic as I have the same error message without a AUR package in use. For me same error message appears for xca which is in community repo. Could that anyhow be related? The filed bug was closed due to belief in incompatible qt style. See https://bugs.archlinux.org/task/74096

Get a backtrace, that should tell you what's being loaded.

Online

#15 2022-03-12 00:31:38

wetTshirt
Member
Registered: 2014-10-17
Posts: 20

Re: [SOLVED] qt5-base broken

pacman -Qm | grep ^qt5

return nothing. Empty response what is expected as I checked the AUR packages. qt theme is Breeze. Consequent set in all options in KDE.

Regarding backtrace: Do I understand https://wiki.archlinux.org/title/Debugg … ing_traces right that I either need to rebuild full qt packages or install debug packages from a different mirror?

Offline

#16 2022-03-12 00:36:13

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,644

Re: [SOLVED] qt5-base broken

No, we don't need symbols, only what libs are being loaded.

Online

#17 2022-03-13 12:06:42

n-tchen
Member
Registered: 2017-03-07
Posts: 17

Re: [SOLVED] qt5-base broken

frabjous wrote:

For me, I had to reinstall qt5-styleplugins (after deleting it from my paru cache so it would rebuild from scratch). YMMV.

I had a similar problem: https://bbs.archlinux.org/viewtopic.php?id=274830

Cleanbuilding qt5-styleplugins also worked for me, like frabjous already posted. I haven't tried it the following way (but without --rebuild, see linked thread), but in the comments in AUR it is described this way:

yay -S --rebuild qt5-styleplugins

Thanks for posting this!

Regards,
Markus

Offline

#18 2022-03-13 23:55:53

wetTshirt
Member
Registered: 2014-10-17
Posts: 20

Re: [SOLVED] qt5-base broken

qt5-styleplugins isn't even installed, so rebuilding can not be a solution. I generated a easy backtrace via gdb and also queried the shared libraries:

[user@system ~]$ gdb xca
[...LICENSE...]
Reading symbols from xca...
(No debugging symbols found in xca)
(gdb) run
Starting program: /usr/bin/xca 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0x7ffff3022640 (LWP 13390)]
[New Thread 0x7fffebfff640 (LWP 13391)]
   003 Warning: QSqlDatabase: QTDS driver not loaded
   003 Warning: QSqlDatabase: available drivers: QIBASE QSQLITE QSQLITE3 QMARIADB QMYSQL QMYSQL3 QODBC QODBC3 QPSQL QPSQL7 QTDS QTDS7 QSQLCIPHER
   003 Warning: QSqlDatabase: QTDS7 driver not loaded
   003 Warning: QSqlDatabase: available drivers: QIBASE QSQLITE QSQLITE3 QMARIADB QMYSQL QMYSQL3 QODBC QODBC3 QPSQL QPSQL7 QTDS QTDS7 QSQLCIPHER
   003 Fatal: Cannot mix incompatible Qt library (5.15.2) with this library (5.15.3)

Thread 1 "xca" received signal SIGABRT, Aborted.
0x00007ffff65ef34c in __pthread_kill_implementation () from /usr/lib/libc.so.6
(gdb) backtrace
#0  0x00007ffff65ef34c in __pthread_kill_implementation () from /usr/lib/libc.so.6
#1  0x00007ffff65a24b8 in raise () from /usr/lib/libc.so.6
#2  0x00007ffff658c534 in abort () from /usr/lib/libc.so.6
#3  0x00007ffff6a58ee4 in QMessageLogger::fatal(char const*, ...) const () from /usr/lib/libQt5Core.so.5
#4  0x00007ffff6a76c55 in ?? () from /usr/lib/libQt5Core.so.5
#5  0x00007fffe9f8d8a0 in ?? () from /usr/lib/qt/plugins/sqldrivers/qsqlcipher.so
#6  0x00007fffe9f8bc29 in ?? () from /usr/lib/qt/plugins/sqldrivers/qsqlcipher.so
#7  0x00007ffff6ef6310 in QSqlDatabase::QSqlDatabase(QString const&) () from /usr/lib/libQt5Sql.so.5
#8  0x00007ffff6ef7097 in QSqlDatabase::addDatabase(QString const&, QString const&) () from /usr/lib/libQt5Sql.so.5
#9  0x00005555555bffd0 in ?? ()
#10 0x00007ffff658d310 in __libc_start_call_main () from /usr/lib/libc.so.6
#11 0x00007ffff658d3c1 in __libc_start_main_impl () from /usr/lib/libc.so.6
#12 0x00005555555c4995 in ?? ()
(gdb) info sharedlibrary
From                To                  Syms Read   Shared Object Library
0x00007ffff7fc8000  0x00007ffff7fee535  Yes (*)     /lib64/ld-linux-x86-64.so.2
0x00007ffff7d26000  0x00007ffff7ecb290  Yes (*)     /usr/lib/libcrypto.so.1.1
0x00007ffff7c5c020  0x00007ffff7c959bf  Yes (*)     /usr/lib/libQt5Help.so.5
0x00007ffff76e9020  0x00007ffff7aae7b5  Yes (*)     /usr/lib/libQt5Widgets.so.5
0x00007ffff7013020  0x00007ffff746e2d3  Yes (*)     /usr/lib/libQt5Gui.so.5
0x00007ffff6eef020  0x00007ffff6f0e3e2  Yes (*)     /usr/lib/libQt5Sql.so.5
0x00007ffff6a58020  0x00007ffff6d20a2f  Yes (*)     /usr/lib/libQt5Core.so.5
0x00007ffff682a020  0x00007ffff69320e3  Yes         /usr/lib/libstdc++.so.6
0x00007ffff6787020  0x00007ffff678b39d  Yes (*)     /usr/lib/libltdl.so.7
0x00007ffff676d020  0x00007ffff677e455  Yes         /usr/lib/libgcc_s.so.1
0x00007ffff658c440  0x00007ffff670069d  Yes (*)     /usr/lib/libc.so.6
0x00007ffff655c020  0x00007ffff655c0f5  Yes (*)     /usr/lib/libdl.so.2
0x00007ffff6557020  0x00007ffff65570f5  Yes (*)     /usr/lib/libpthread.so.0
0x00007ffff647c020  0x00007ffff64f5e18  Yes (*)     /usr/lib/libm.so.6
0x00007ffff6428020  0x00007ffff642aa1d  Yes (*)     /usr/lib/libGL.so.1
0x00007ffff63b5020  0x00007ffff63d88da  Yes (*)     /usr/lib/libpng16.so.16
0x00007ffff6398020  0x00007ffff63a519c  Yes (*)     /usr/lib/libz.so.1
0x00007ffff62b1020  0x00007ffff6359d23  Yes (*)     /usr/lib/libharfbuzz.so.0
0x00007ffff6292020  0x00007ffff629f82a  Yes (*)     /usr/lib/libmd4c.so.0
0x00007ffff61c8020  0x00007ffff624bcd1  Yes (*)     /usr/lib/libsystemd.so.0
0x00007ffff619f020  0x00007ffff61a9e68  Yes (*)     /usr/lib/libdouble-conversion.so.3
0x00007ffff5f63020  0x00007ffff60f9f86  Yes (*)     /usr/lib/libicui18n.so.70
0x00007ffff5ce2020  0x00007ffff5dd3348  Yes (*)     /usr/lib/libicuuc.so.70
0x00007ffff5bf0020  0x00007ffff5c4f7b9  Yes (*)     /usr/lib/libpcre2-16.so.0
0x00007ffff5b43040  0x00007ffff5bda3b2  Yes (*)     /usr/lib/libzstd.so.1
0x00007ffff5a1c020  0x00007ffff5aad1b3  Yes (*)     /usr/lib/libglib-2.0.so.0
0x00007ffff5988020  0x00007ffff5989f57  Yes (*)     /usr/lib/libGLdispatch.so.0
0x00007ffff5917020  0x00007ffff5930aa1  Yes (*)     /usr/lib/libGLX.so.0
0x00007ffff5857020  0x00007ffff58d5e2c  Yes (*)     /usr/lib/libfreetype.so.6
0x00007ffff5827020  0x00007ffff5840462  Yes (*)     /usr/lib/libgraphite2.so.3
0x00007ffff57fc020  0x00007ffff58132d3  Yes (*)     /usr/lib/liblzma.so.5
0x00007ffff57d9020  0x00007ffff57f3c97  Yes (*)     /usr/lib/liblz4.so.1
0x00007ffff57cd020  0x00007ffff57d17bb  Yes (*)     /usr/lib/libcap.so.2
0x00007ffff569d040  0x00007ffff577df88  Yes (*)     /usr/lib/libgcrypt.so.20
                                        Yes (*)     /usr/lib/libicudata.so.70
0x00007ffff39fb020  0x00007ffff3a50ce2  Yes (*)     /usr/lib/libpcre.so.1
0x00007ffff38d3020  0x00007ffff395c77e  Yes (*)     /usr/lib/libX11.so.6
0x00007ffff38a6020  0x00007ffff38b2452  Yes (*)     /usr/lib/libbz2.so.1.0
0x00007ffff3897020  0x00007ffff389e432  Yes (*)     /usr/lib/libbrotlidec.so.1
0x00007ffff3874050  0x00007ffff38894f2  Yes (*)     /usr/lib/libgpg-error.so.0
0x00007ffff384f020  0x00007ffff3861b86  Yes (*)     /usr/lib/libxcb.so.1
0x00007ffff3821020  0x00007ffff3821b5e  Yes (*)     /usr/lib/libbrotlicommon.so.1
0x00007ffff381c040  0x00007ffff381cd52  Yes (*)     /usr/lib/libXau.so.6
0x00007ffff3815020  0x00007ffff3816882  Yes (*)     /usr/lib/libXdmcp.so.6
0x00007ffff7fbc020  0x00007ffff7fbc3ca  Yes (*)     /usr/lib/qt/plugins/platforms/libqxcb.so
0x00007ffff32b5020  0x00007ffff334c091  Yes (*)     /usr/lib/libQt5XcbQpa.so.5
0x00007ffff3238020  0x00007ffff326401e  Yes (*)     /usr/lib/libfontconfig.so.1
0x00007ffff31c6020  0x00007ffff3214f72  Yes (*)     /usr/lib/libQt5DBus.so.5
0x00007ffff7fb6020  0x00007ffff7fb610b  Yes (*)     /usr/lib/libX11-xcb.so.1
0x00007ffff7fb1020  0x00007ffff7fb1f1a  Yes (*)     /usr/lib/libxcb-icccm.so.4
0x00007ffff7faa020  0x00007ffff7fab6e5  Yes (*)     /usr/lib/libxcb-image.so.0
0x00007ffff7fa5020  0x00007ffff7fa5b44  Yes (*)     /usr/lib/libxcb-shm.so.0
0x00007ffff7fa0020  0x00007ffff7fa086e  Yes (*)     /usr/lib/libxcb-keysyms.so.1
0x00007ffff31a5020  0x00007ffff31a9c41  Yes (*)     /usr/lib/libxcb-randr.so.0
0x00007ffff7f9b020  0x00007ffff7f9be58  Yes (*)     /usr/lib/libxcb-render-util.so.0
0x00007ffff3194020  0x00007ffff3198b7f  Yes (*)     /usr/lib/libxcb-render.so.0
0x00007ffff7f95020  0x00007ffff7f95c06  Yes (*)     /usr/lib/libxcb-shape.so.0
0x00007ffff3187020  0x00007ffff31891b2  Yes (*)     /usr/lib/libxcb-sync.so.1
0x00007ffff317d020  0x00007ffff317f6cc  Yes (*)     /usr/lib/libxcb-xfixes.so.0
0x00007ffff3176020  0x00007ffff3176726  Yes (*)     /usr/lib/libxcb-xinerama.so.0
0x00007ffff3162020  0x00007ffff316dda6  Yes (*)     /usr/lib/libxcb-xkb.so.1
0x00007ffff3141020  0x00007ffff314cd87  Yes (*)     /usr/lib/libxcb-xinput.so.0
0x00007ffff312a020  0x00007ffff312df86  Yes (*)     /usr/lib/libSM.so.6
0x00007ffff3110020  0x00007ffff311d7ea  Yes (*)     /usr/lib/libICE.so.6
0x00007ffff3104020  0x00007ffff31069dc  Yes (*)     /usr/lib/libxkbcommon-x11.so.0
0x00007ffff30bd020  0x00007ffff30db2eb  Yes (*)     /usr/lib/libxkbcommon.so.0
0x00007ffff308b020  0x00007ffff30a9357  Yes (*)     /usr/lib/libexpat.so.1
0x00007ffff3042020  0x00007ffff307056a  Yes (*)     /usr/lib/libdbus-1.so.3
0x00007ffff302f020  0x00007ffff302fddd  Yes (*)     /usr/lib/libxcb-util.so.1
0x00007ffff3025020  0x00007ffff302883e  Yes (*)     /usr/lib/libuuid.so.1
0x00007ffff2819020  0x00007ffff281dc3e  Yes (*)     /usr/lib/libXcursor.so.1
0x00007ffff280b020  0x00007ffff28113a3  Yes (*)     /usr/lib/libXrender.so.1
0x00007ffff2802020  0x00007ffff28045e6  Yes (*)     /usr/lib/libXfixes.so.3
0x00007ffff27b8020  0x00007ffff27e9305  Yes (*)     /usr/lib/qt/plugins/platformthemes/KDEPlasmaPlatformTheme.so
0x00007ffff26f5020  0x00007ffff2768fcb  Yes (*)     /usr/lib/libKF5KIOFileWidgets.so.5
0x00007ffff25d4020  0x00007ffff2678661  Yes (*)     /usr/lib/libKF5KIOWidgets.so.5
0x00007ffff253f020  0x00007ffff256511d  Yes (*)     /usr/lib/libKF5Notifications.so.5
0x00007ffff2496020  0x00007ffff24ead89  Yes (*)     /usr/lib/libKF5WaylandClient.so.5
0x00007ffff2421020  0x00007ffff2432688  Yes (*)     /usr/lib/libQt5QuickControls2.so.5
0x00007ffff22f6020  0x00007ffff23bdd44  Yes (*)     /usr/lib/libKF5KIOCore.so.5
0x00007ffff2290020  0x00007ffff22a43cd  Yes (*)     /usr/lib/libKF5JobWidgets.so.5
0x00007ffff225c020  0x00007ffff227584b  Yes (*)     /usr/lib/libKF5Completion.so.5
0x00007ffff21b6020  0x00007ffff2219cc1  Yes (*)     /usr/lib/libKF5XmlGui.so.5
0x00007ffff2153020  0x00007ffff21715f7  Yes (*)     /usr/lib/libKF5IconThemes.so.5
0x00007ffff20f9020  0x00007ffff21240b6  Yes (*)     /usr/lib/libKF5ConfigWidgets.so.5
0x00007ffff20be020  0x00007ffff20cc25c  Yes (*)     /usr/lib/libKF5ConfigGui.so.5
0x00007ffff206d020  0x00007ffff209fb78  Yes (*)     /usr/lib/libKF5I18n.so.5
0x00007ffff1f7f020  0x00007ffff201995f  Yes (*)     /usr/lib/libKF5WidgetsAddons.so.5
0x00007ffff1ecc020  0x00007ffff1efcd43  Yes (*)     /usr/lib/libKF5ConfigCore.so.5
0x00007ffff1e7a020  0x00007ffff1ea0575  Yes (*)     /usr/lib/libKF5WindowSystem.so.5
0x00007ffff1e5e020  0x00007ffff1e5f43d  Yes (*)     /usr/lib/libQt5X11Extras.so.5
0x00007ffff1dd7020  0x00007ffff1e3327c  Yes (*)     /usr/lib/libKF5CoreAddons.so.5
0x00007ffff1d8a020  0x00007ffff1da6eda  Yes (*)     /usr/lib/libKF5Bookmarks.so.5
0x00007ffff1cdc020  0x00007ffff1d3af84  Yes (*)     /usr/lib/libKF5Solid.so.5
0x00007ffff1c8f020  0x00007ffff1ca8006  Yes (*)     /usr/lib/libKF5ItemViews.so.5
0x00007ffff1b49020  0x00007ffff1c28101  Yes (*)     /usr/lib/libQt5Network.so.5
0x00007ffff1ae8020  0x00007ffff1afa17a  Yes (*)     /usr/lib/libKF5GuiAddons.so.5
0x00007ffff1aaa020  0x00007ffff1abcbe8  Yes (*)     /usr/lib/libKF5Codecs.so.5
0x00007ffff1a6d020  0x00007ffff1a90fbd  Yes (*)     /usr/lib/libQt5Xml.so.5
0x00007ffff1a32020  0x00007ffff1a4d91c  Yes (*)     /usr/lib/libKF5KIOGui.so.5
0x00007ffff19b6020  0x00007ffff1a05c0c  Yes (*)     /usr/lib/libKF5Service.so.5
0x00007ffff198c020  0x00007ffff199591a  Yes (*)     /usr/lib/libcanberra.so.0
0x00007ffff197f020  0x00007ffff19832fc  Yes (*)     /usr/lib/libQt5TextToSpeech.so.5
0x00007ffff1974020  0x00007ffff1976a1c  Yes (*)     /usr/lib/libXtst.so.6
0x00007ffff1949020  0x00007ffff19645d1  Yes (*)     /usr/lib/libdbusmenu-qt5.so.2
0x00007ffff1935020  0x00007ffff193a570  Yes (*)     /usr/lib/libwayland-client.so.0
0x00007ffff1511020  0x00007ffff17edf1b  Yes (*)     /usr/lib/libQt5Quick.so.5
0x00007ffff108c020  0x00007ffff130b8cb  Yes (*)     /usr/lib/libQt5Qml.so.5
0x00007ffff0ed1020  0x00007ffff0f7c798  Yes (*)     /usr/lib/libQt5QuickTemplates2.so.5
0x00007ffff0e3e020  0x00007ffff0e41a36  Yes (*)     /usr/lib/libKF5Crash.so.5
0x00007ffff0e29020  0x00007ffff0e3207a  Yes (*)     /usr/lib/libKF5AuthCore.so.5
0x00007ffff0e1a020  0x00007ffff0e1dc36  Yes (*)     /usr/lib/libacl.so.1
0x00007ffff0ddf050  0x00007ffff0e086f2  Yes (*)     /usr/lib/libmount.so.1
0x00007ffff0dbd020  0x00007ffff0dcbb79  Yes (*)     /usr/lib/libKF5GlobalAccel.so.5
0x00007ffff0d69020  0x00007ffff0d98b9c  Yes (*)     /usr/lib/libQt5PrintSupport.so.5
0x00007ffff0d04020  0x00007ffff0d34b3c  Yes (*)     /usr/lib/libQt5Svg.so.5
0x00007ffff0cbe020  0x00007ffff0cde9c5  Yes (*)     /usr/lib/libKF5Archive.so.5
0x00007ffff0c8a020  0x00007ffff0ca3e51  Yes (*)     /usr/lib/libudev.so.1
0x00007ffff0c63020  0x00007ffff0c7966d  Yes (*)     /usr/lib/libimobiledevice-1.0.so.6
0x00007ffff0c49020  0x00007ffff0c530c8  Yes (*)     /usr/lib/libplist-2.0.so.3
0x00007ffff0bfd020  0x00007ffff0c347d9  Yes (*)     /usr/lib/libgssapi_krb5.so.2
0x00007ffff0b7c020  0x00007ffff0bc8257  Yes (*)     /usr/lib/libssl.so.1.1
0x00007ffff0a79020  0x00007ffff0b14cdb  Yes (*)     /usr/lib/libQt5WaylandClient.so.5
0x00007ffff0a00020  0x00007ffff0a0bcba  Yes (*)     /usr/lib/libKF5DBusAddons.so.5
0x00007ffff09ee020  0x00007ffff09f2650  Yes (*)     /usr/lib/libvorbisfile.so.3
0x00007ffff09d7020  0x00007ffff09e384f  Yes (*)     /usr/lib/libtdb.so.1
0x00007ffff09c2020  0x00007ffff09cc33e  Yes (*)     /usr/lib/libXext.so.6
0x00007ffff09ad020  0x00007ffff09b8319  Yes (*)     /usr/lib/libXi.so.6
0x00007ffff09a0040  0x00007ffff09a5636  Yes (*)     /usr/lib/libffi.so.8
0x00007ffff0938020  0x00007ffff0981963  Yes (*)     /usr/lib/libQt5QmlModels.so.5
0x00007ffff08ed050  0x00007ffff090c1b2  Yes (*)     /usr/lib/libblkid.so.1
0x00007ffff08e1020  0x00007ffff08e1227  Yes (*)     /usr/lib/librt.so.1
0x00007ffff0725040  0x00007ffff084edfd  Yes (*)     /usr/lib/libgnutls.so.30
0x00007ffff06de020  0x00007ffff06e99ef  Yes (*)     /usr/lib/libtasn1.so.6
0x00007ffff06d0020  0x00007ffff06d5577  Yes (*)     /usr/lib/libusbmuxd-2.0.so.6
0x00007ffff060a020  0x00007ffff0673106  Yes (*)     /usr/lib/libkrb5.so.3
0x00007ffff05bb020  0x00007ffff05d6e97  Yes (*)     /usr/lib/libk5crypto.so.3
0x00007ffff05b2020  0x00007ffff05b2bf9  Yes (*)     /usr/lib/libcom_err.so.2
0x00007ffff05a4020  0x00007ffff05aaf5c  Yes (*)     /usr/lib/libkrb5support.so.0
0x00007ffff059b020  0x00007ffff059c123  Yes (*)     /usr/lib/libkeyutils.so.1
0x00007ffff0589020  0x00007ffff05911da  Yes (*)     /usr/lib/libresolv.so.2
0x00007ffff057d020  0x00007ffff057ed9f  Yes (*)     /usr/lib/libwayland-cursor.so.0
0x00007ffff0551020  0x00007ffff05677e8  Yes (*)     /usr/lib/libvorbis.so.0
0x00007ffff0544020  0x00007ffff05463be  Yes (*)     /usr/lib/libogg.so.0
0x00007ffff0438050  0x00007ffff04d6630  Yes (*)     /usr/lib/libp11-kit.so.0
0x00007ffff03ef020  0x00007ffff03f2f80  Yes (*)     /usr/lib/libidn2.so.0
0x00007ffff027c020  0x00007ffff02b0e79  Yes (*)     /usr/lib/libunistring.so.2
0x00007ffff0230020  0x00007ffff0250fa8  Yes (*)     /usr/lib/libnettle.so.8
0x00007ffff01e4020  0x00007ffff01f60fd  Yes (*)     /usr/lib/libhogweed.so.6
0x00007ffff014c080  0x00007ffff01bfaf1  Yes (*)     /usr/lib/libgmp.so.10
0x00007ffff33dc020  0x00007ffff33dce75  Yes (*)     /usr/lib/qt/plugins/platforminputcontexts/libcomposeplatforminputcontextplugin.so
0x00007ffff00cc020  0x00007ffff011c9c8  Yes (*)     /usr/lib/qt/plugins/styles/breeze.so
0x00007ffff33cc020  0x00007ffff33cdc49  Yes (*)     /usr/lib/libbreezecommon5.so.5
0x00007ffff33c2020  0x00007ffff33c4df6  Yes (*)     /usr/lib/libKF5Style.so.5
0x00007ffff33b6020  0x00007ffff33b93da  Yes (*)     /usr/lib/qt/plugins/imageformats/libqgif.so
0x00007ffff009a020  0x00007ffff009e6b4  Yes (*)     /usr/lib/qt/plugins/imageformats/libqicns.so
0x00007ffff0091020  0x00007ffff00932fa  Yes (*)     /usr/lib/qt/plugins/imageformats/libqico.so
0x00007ffff0087020  0x00007ffff00899f7  Yes (*)     /usr/lib/qt/plugins/imageformats/libqjp2.so
0x00007fffeb7a7040  0x00007fffeb7ebe52  Yes (*)     /usr/lib/libjasper.so.4
0x00007fffeb720020  0x00007fffeb768400  Yes (*)     /usr/lib/libjpeg.so.8
0x00007ffff007b020  0x00007ffff007f7fa  Yes (*)     /usr/lib/qt/plugins/imageformats/libqjpeg.so
0x00007ffff0072020  0x00007ffff0073179  Yes (*)     /usr/lib/qt/plugins/imageformats/libqmng.so
0x00007fffeb6c1020  0x00007fffeb70579c  Yes (*)     /usr/lib/libmng.so.2
0x00007fffeb64f020  0x00007fffeb68c14b  Yes (*)     /usr/lib/liblcms2.so.2
0x00007ffff006a020  0x00007ffff006b575  Yes (*)     /usr/lib/qt/plugins/imageformats/libqpdf.so
0x00007fffeb341b40  0x00007fffeb4a4390  Yes (*)     /usr/lib/libQt5Pdf.so.5
0x00007ffff0062020  0x00007ffff006327f  Yes (*)     /usr/lib/qt/plugins/imageformats/libqsvg.so
0x00007ffff005a020  0x00007ffff005b22a  Yes (*)     /usr/lib/qt/plugins/imageformats/libqtga.so
0x00007ffff0050020  0x00007ffff005390a  Yes (*)     /usr/lib/qt/plugins/imageformats/libqtiff.so
0x00007fffeb290140  0x00007fffeb2e00cf  Yes (*)     /usr/lib/libtiff.so.5
0x00007ffff0049020  0x00007ffff0049efa  Yes (*)     /usr/lib/qt/plugins/imageformats/libqwbmp.so
0x00007ffff0042020  0x00007ffff0043d68  Yes (*)     /usr/lib/qt/plugins/imageformats/libqwebp.so
0x00007ffff0006020  0x00007ffff000c049  Yes (*)     /usr/lib/libwebpmux.so.3
0x00007fffeb281020  0x00007fffeb282eb5  Yes (*)     /usr/lib/libwebpdemux.so.2
0x00007fffeb215020  0x00007fffeb269e0b  Yes (*)     /usr/lib/libwebp.so.7
0x00007fffea522020  0x00007fffea52f559  Yes (*)     /usr/lib/qt/plugins/sqldrivers/libqsqlibase.so
0x00007fffea20f0a0  0x00007fffea419630  Yes (*)     /usr/lib/libfbclient.so.2
0x00007fffea1b9020  0x00007fffea1c5d68  Yes (*)     /lib/libtommath.so.1
0x00007fffea50d020  0x00007fffea515d60  Yes (*)     /usr/lib/qt/plugins/sqldrivers/libqsqlite.so
0x00007fffea03d020  0x00007fffea1234e6  Yes (*)     /usr/lib/libsqlite3.so.0
0x00007fffea4fa020  0x00007fffea5010ca  Yes (*)     /usr/lib/qt/plugins/sqldrivers/libqsqlite3.so
0x00007fffea187020  0x00007fffea18f9fa  Yes (*)     /usr/lib/qt/plugins/sqldrivers/libqsqlmysql.so
0x00007fffe9fb2020  0x00007fffe9fd5824  Yes (*)     /usr/lib/libmariadb.so.3
0x00007fffea004020  0x00007fffea01209a  Yes (*)     /usr/lib/qt/plugins/sqldrivers/libqsqlodbc.so
0x00007fffe9f02020  0x00007fffe9f4e602  Yes (*)     /usr/lib/libodbc.so.2
0x00007fffea16f020  0x00007fffea179052  Yes (*)     /usr/lib/qt/plugins/sqldrivers/libqsqlpsql.so
0x00007fffe9eb5020  0x00007fffe9ed65fc  Yes (*)     /usr/lib/libpq.so.5
0x00007fffe9e5a020  0x00007fffe9e9356f  Yes (*)     /usr/lib/libldap.so.2
0x00007fffe9ff0020  0x00007fffe9ff7126  Yes (*)     /usr/lib/liblber.so.2
0x00007fffe9e30020  0x00007fffe9e40db7  Yes (*)     /usr/lib/libsasl2.so.3
0x00007fffe9f8b020  0x00007fffe9f953c4  Yes (*)     /usr/lib/qt/plugins/sqldrivers/qsqlcipher.so
0x00007fffe9d1e020  0x00007fffe9dd0c5c  Yes (*)     /usr/lib/libsqlcipher.so.0

Offline

#19 2022-03-14 00:04:10

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,644

Re: [SOLVED] qt5-base broken

Based on that, I would look at /usr/lib/qt/plugins/sqldrivers/qsqlcipher.so, which is from kmymoney. If you uninstall that, does xca work again? Alternatively, you could rebuild the kmymoney package and see if that works instead of removing it.

Edit: also make sure you're using the kmymoney package from Community, not a git package from the AUR or a self-built one. I suspect the package is actually bad, but just to make sure.

Last edited by Scimmia (2022-03-14 00:14:20)

Online

#20 2022-03-14 00:25:53

wetTshirt
Member
Registered: 2014-10-17
Posts: 20

Re: [SOLVED] qt5-base broken

Indeed, uninstalling kmymoney is fixing the problem. Was anyhow not in use for longer. Thanks for the help.
BTW is this a bug to report for the kmymoney package?

Offline

#21 2022-03-14 00:27:13

Scimmia
Fellow
Registered: 2012-09-01
Posts: 11,644

Re: [SOLVED] qt5-base broken

Yes, it is. I'll ping arojas to let him know not to close it.

Online

#22 2022-03-14 00:43:50

wetTshirt
Member
Registered: 2014-10-17
Posts: 20

Re: [SOLVED] qt5-base broken

Offline

Board footer

Powered by FluxBB