You are not logged in.

#1 2022-03-22 08:22:40

MSco
Member
Registered: 2021-12-01
Posts: 6

[SOLVED] Cannot save connection due to error Invalid VPN:IPSec gateway

When I try to add a new vpn connection with NetworkManager, I get the following error (and the save button is greyed out):

Cannot save connection due to error: Invalid setting VPN: IPSec gateway

My libraries:
- nm-connection-editor 1.24.0-1
- networkmanager: 1.36.2-1.0
- linnm: 1.36.2-1.0
- networkmanager-vpnc: 1.2.8-1

Last edited by MSco (2022-05-05 10:35:41)

Offline

#2 2022-05-05 10:04:31

Bubbel
Member
Registered: 2015-04-16
Posts: 7

Re: [SOLVED] Cannot save connection due to error Invalid VPN:IPSec gateway

Got the same problem (VPNC for fritzbox).
Solved it by adding the tunnel Interface name (tun0):
1. On the VPN tab, there is an "Advanced" button.
2. In the advanced settings, there is a setting: "Tunnel Interface Name"  under section "Transport and security". Enter "tun0" here.
3. Fill out settings as normal and you're good to go.

Notes: I used nm-connection-editor for this.
I also installed Strongswan, but I don't think this is related.

And there is a similar post on the German forum site: forums.archlinux.de, if i'm correct. Maybe someone can add this to that site? (My german isn't that stellar...)

Offline

#3 2022-05-05 10:11:00

MSco
Member
Registered: 2021-12-01
Posts: 6

Re: [SOLVED] Cannot save connection due to error Invalid VPN:IPSec gateway

@Bubbel
Great, thank you! This solved my issue!
Thank you very much! smile

Offline

#4 2022-05-05 10:15:44

Bubbel
Member
Registered: 2015-04-16
Posts: 7

Re: [SOLVED] Cannot save connection due to error Invalid VPN:IPSec gateway

You're very welcome. Please mark this thread as solved, so the solution is easier to find.

Offline

Board footer

Powered by FluxBB