You are not logged in.

#1 2022-11-13 19:42:16

dad2four
Member
Registered: 2022-11-13
Posts: 13

OPENSSL_3.0.0 required by lynx and w3m and irssi

Hello and thanks in advance.

I've installed lynx/w3m/and irssi and all three gave me the same error

/usr/lib/libcrypto.so.3: version 'OPENSSL_3.0.0' not found (required by irssi)
/usr/lib/libssl.so.3: version 'OPENSSL_3.0.0' not found (required by irssi)

I attemped to modify links in an attempt to fix, I've done much searching and can not find a solution.

I'm all ears if anyone has any ideas for me.

Last edited by dad2four (2022-11-13 19:43:27)

Offline

#2 2022-11-13 19:44:32

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 30,287
Website

Re: OPENSSL_3.0.0 required by lynx and w3m and irssi

pacman -Syu

Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#3 2022-11-13 19:45:09

Slithery
Administrator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 5,624

Re: OPENSSL_3.0.0 required by lynx and w3m and irssi

dad2four wrote:

I attemped to modify links in an attempt to fix

That's a sure-fire way to break your system even more than you've already broken it.

https://bbs.archlinux.org/viewtopic.php?id=130309
Read the second bolded line.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#4 2022-11-13 20:02:03

dad2four
Member
Registered: 2022-11-13
Posts: 13

Re: OPENSSL_3.0.0 required by lynx and w3m and irssi

Thanks for your help. I ran pacman -Syu failed to commit transaction (conflicting files) /usr/lib/libcrypto.so.3 exists in filesystem and the same with libssl. no packages were upgraded due to the errors.

Offline

#5 2022-11-13 20:07:16

Slithery
Administrator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 5,624

Re: OPENSSL_3.0.0 required by lynx and w3m and irssi

That's because you broke your system even more by symlinking libraries.
Undo your attempted 'fix' and then update your system properly.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#6 2022-11-13 20:12:41

dad2four
Member
Registered: 2022-11-13
Posts: 13

Re: OPENSSL_3.0.0 required by lynx and w3m and irssi

I have no idea how to reverse what I did. if I ls -l libssl* in the /usr/lib directory I show

libssl3.so
libssl.so.1.1
libssl.so.3 -> libssl3.so

Does this look correct?

Offline

#7 2022-11-13 20:25:57

Slithery
Administrator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 5,624

Re: OPENSSL_3.0.0 required by lynx and w3m and irssi

dad2four wrote:

I have no idea how to reverse what I did.

Then post your shell history for the commands that you ran.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#8 2022-11-13 20:37:59

dad2four
Member
Registered: 2022-11-13
Posts: 13

Re: OPENSSL_3.0.0 required by lynx and w3m and irssi

Totally cool, had no idea history would stick around after reboots.

I'm looking at history but I can't post since I have no browser/email etc yet. I've just installed arch and am trying to get things going.

I'm on a different machine accessing the forum.

Offline

#9 2022-11-13 20:43:35

seth
Member
Registered: 2012-09-03
Posts: 33,338

Re: OPENSSL_3.0.0 required by lynx and w3m and irssi

Does this look correct?

pacman -Qo /usr/lib/libssl3.so /usr/lib/libssl.so.1.1

Does it?

I can't post since I have no browser/email

1st link below.

Offline

#10 2022-11-13 20:51:52

dad2four
Member
Registered: 2022-11-13
Posts: 13

Re: OPENSSL_3.0.0 required by lynx and w3m and irssi

pacman -Qo /usr/lib/libssl3.so /usr/lib/libssl.so.1.1

returns

/usr/lib/libssl3.so is owned by nss 3.84-1
/usr/lib/libssl.so.1.1 is owned by openssl 1.1.1.q-1

I'm working on uploading history

Offline

#11 2022-11-13 20:59:08

seth
Member
Registered: 2012-09-03
Posts: 33,338

Re: OPENSSL_3.0.0 required by lynx and w3m and irssi

I know what that returns - the question for you was whether it looks correct to symlink libssl.so.whatever at libssl3.so …

Offline

#12 2022-11-13 21:01:21

dad2four
Member
Registered: 2022-11-13
Posts: 13

Re: OPENSSL_3.0.0 required by lynx and w3m and irssi

History is posted below

http://0x0.st/o608.txt

Last edited by dad2four (2022-11-13 21:04:06)

Offline

#13 2022-11-13 21:03:29

dad2four
Member
Registered: 2022-11-13
Posts: 13

Re: OPENSSL_3.0.0 required by lynx and w3m and irssi

If there is supposed to be a link from /usr/lib/libssl3.so to /usr/lib/libssl.so.1.1 then no it does not look correct to me.

Offline

#14 2022-11-13 21:08:21

dad2four
Member
Registered: 2022-11-13
Posts: 13

Re: OPENSSL_3.0.0 required by lynx and w3m and irssi

I would think that we need a link from libssl.so -> libssl3.so

Offline

#15 2022-11-13 21:12:43

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 30,287
Website

Re: OPENSSL_3.0.0 required by lynx and w3m and irssi

Stop using `-Sy $package` it breaks things.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#16 2022-11-13 21:18:01

dad2four
Member
Registered: 2022-11-13
Posts: 13

Re: OPENSSL_3.0.0 required by lynx and w3m and irssi

jasonwryan wrote:

Stop using `-Sy $package` it breaks things.

Ok I won't do it again

Offline

#17 2022-11-13 22:19:38

dad2four
Member
Registered: 2022-11-13
Posts: 13

Re: OPENSSL_3.0.0 required by lynx and w3m and irssi

dad2four wrote:

I would think that we need a link from libssl.so -> libssl3.so

Was this incorrect?

Offline

#18 2022-11-13 22:31:06

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 27,515
Website

Re: OPENSSL_3.0.0 required by lynx and w3m and irssi

Yes that was incorrect.  Remove *all* the links you've manually created.  Then update your system properly.

Last edited by Trilby (2022-11-13 22:32:53)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#19 2022-11-13 23:11:39

dad2four
Member
Registered: 2022-11-13
Posts: 13

Re: OPENSSL_3.0.0 required by lynx and w3m and irssi

Trilby wrote:

Yes that was incorrect.  Remove *all* the links you've manually created.  Then update your system properly.

Does "update your system properly mean pacman -Syu ?

Offline

#20 2022-11-14 00:07:50

dad2four
Member
Registered: 2022-11-13
Posts: 13

Re: OPENSSL_3.0.0 required by lynx and w3m and irssi

I don't want to mess this up any worse than I have.

Offline

#21 2022-11-14 01:07:21

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,704

Re: OPENSSL_3.0.0 required by lynx and w3m and irssi

dad2four wrote:
Trilby wrote:

Yes that was incorrect.  Remove *all* the links you've manually created.  Then update your system properly.

Does "update your system properly mean pacman -Syu ?

Yes.


CLI Paste | How To Ask Questions

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Wireless 8265/8275 | US keyboard w/ Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#22 2022-11-23 01:22:48

dad2four
Member
Registered: 2022-11-13
Posts: 13

Re: OPENSSL_3.0.0 required by lynx and w3m and irssi

Thanks to all of you that helped me on this. All is well now.

Happy Thanksgiving!

Offline

#23 2022-11-23 08:37:25

seth
Member
Registered: 2012-09-03
Posts: 33,338

Re: OPENSSL_3.0.0 required by lynx and w3m and irssi

Please always remember to mark resolved threads by editing your initial posts subject - so others will know that there's no task left, but maybe a solution to find.
Thanks.

Offline

Board footer

Powered by FluxBB