You are not logged in.

#1 2012-06-19 19:33:37

radiomist
Member
From: superposicion
Registered: 2009-11-27
Posts: 62

Networkmanager Applet

I can't launch the networkmanager applet or NM plasmoid, got this error:

lepton@Potato ~]$ nm-applet

** (nm-applet:2002): WARNING **: Could not initialize NMClient /org/freedesktop/NetworkManager: Rejected send message, 2 matched rules; type="method_call", sender=":1.44" (uid=1000 pid=2002 comm="nm-applet ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination="org.freedesktop.NetworkManager" (uid=0 pid=516 comm="/usr/sbin/NetworkManager --no-daemon ")
** Message: applet now removed from the notification area
** Message: applet now embedded in the notification area
** Message: applet now removed from the notification area

But sudo nm-applet works :S

My user is on Network Group

Offline

#2 2012-06-20 18:31:59

radiomist
Member
From: superposicion
Registered: 2009-11-27
Posts: 62

Re: Networkmanager Applet

Any idea for this ???

Offline

#3 2012-06-23 07:47:30

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: Networkmanager Applet

Read the wiki page for NetworkManager.

https://wiki.archlinux.org/index.php/NetworkManager


If you still have problems, can you tell me which DE/WM and login manager are you using? Also, post your ~/.xinitrc and /etc/rc.conf (preferably using pastebin.com).


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#4 2012-06-23 14:55:32

radiomist
Member
From: superposicion
Registered: 2009-11-27
Posts: 62

Re: Networkmanager Applet

I'm using KDE,
i think is a Systemd issue cause, when i boot with the default init scripts, Networkmanager works fine.
But booting with systemd causes the strange behavior.

Offline

#5 2012-06-27 13:02:46

anafor
Member
Registered: 2012-02-20
Posts: 2

Re: Networkmanager Applet

The same issue: no icon if running as normal user, and no interfaces if running as root.
The only difference I see between init and systemd implementations is "--no-daemon" in last one. Still, running NetworkManager w/o this option as root gave no result. What can be done more?

Using Systemd, lightdm, xfce with latest updates.
~/.xinitrc is standard:

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  done
  unset f
fi

Offline

#6 2012-06-27 13:28:03

progandy
Member
Registered: 2012-05-17
Posts: 2,146

Re: Networkmanager Applet

I had the same problem with Systemd / lightdm / xfce4.

I modified dbus-access rights to get it working again. In /etc/dbus-1/system.d/org.freedesktop.NetworkManager.conf, I changed <deny to <allow for the entries with "Sleep", "sleep", "wake", and  send_destination="org.freedesktop.NetworkManager"/> in the section <policy context="default">

Last edited by progandy (2012-06-27 13:33:52)

Offline

#7 2012-06-27 14:34:41

radiomist
Member
From: superposicion
Registered: 2009-11-27
Posts: 62

Re: Networkmanager Applet

progandy wrote:

I had the same problem with Systemd / lightdm / xfce4.

I modified dbus-access rights to get it working again. In /etc/dbus-1/system.d/org.freedesktop.NetworkManager.conf, I changed <deny to <allow for the entries with "Sleep", "sleep", "wake", and  send_destination="org.freedesktop.NetworkManager"/> in the section <policy context="default">


That fix the problem. Txs!

Offline

#8 2012-07-19 01:53:42

tomasabril
Member
From: Brazil
Registered: 2011-11-28
Posts: 25

Re: Networkmanager Applet

Is this file /etc/dbus-1/system.d/org.freedesktop.NetworkManager.conf part of NetworkManager or systemd? It should get fixed upstream. (or in arch as it is just a configuration).
Its funny that it works in gnome.

Offline

#9 2012-07-19 13:44:30

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: Networkmanager Applet

radiomist wrote:

That fix the problem. Txs!

Don't forget to mark it as solved (by editing the first post).


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#10 2012-08-05 11:39:34

ffjia
Member
Registered: 2009-08-26
Posts: 94

Re: Networkmanager Applet

progandy wrote:

I had the same problem with Systemd / lightdm / xfce4.

I modified dbus-access rights to get it working again. In /etc/dbus-1/system.d/org.freedesktop.NetworkManager.conf, I changed <deny to <allow for the entries with "Sleep", "sleep", "wake", and  send_destination="org.freedesktop.NetworkManager"/> in the section <policy context="default">

Thanks, this fix my problem, too. Is this a NetworkManager bug?

Offline

#11 2012-08-20 09:11:46

mtrath
Member
Registered: 2011-06-14
Posts: 5

Re: Networkmanager Applet

Thanks, fixed for me, too. Same setup: systemd 188-2, lightdm 1.3.2-3, XFCE4.10

Changed deny to allow at the send_destination lines in /etc/dbus-1/system.d/org.freedesktop.NetworkManager.conf.

$ pacman -Qo /etc/dbus-1/system.d/org.freedesktop.NetworkManager.conf
/etc/dbus-1/system.d/org.freedesktop.NetworkManager.conf is owned by networkmanager 0.9.4.0-6

Offline

#12 2012-08-21 11:59:39

Loosefish
Member
Registered: 2012-08-21
Posts: 2

Re: Networkmanager Applet

I had the same problem while switching to systemd but only with my desktop, on my laptop nm-applet started just fine.
The problem was with lxdm and pam, after changing /etc/pam.d/lxdm from

#%PAM-1.0
auth            requisite       pam_nologin.so
auth            required        pam_env.so
auth            required        pam_unix.so
auth            optional        pam_gnome_keyring.so
account         required        pam_unix.so
session         required        pam_limits.so
session         required        pam_unix.so
session         optional        pam_gnome_keyring.so auto_start
password        required        pam_unix.so

to

#%PAM-1.0
auth            requisite       pam_nologin.so
auth            required        pam_env.so
auth            required        pam_unix.so
account         required        pam_unix.so
session         required        pam_limits.so
session         required        pam_unix.so
password        required        pam_unix.so
-session optional pam_systemd.so

nm-applet started again (and the keyring seemed to unlock as well). Somehow the new /etc/pam.d/lxdm was not installed correctly on my desktop.

Offline

#13 2012-08-21 12:46:21

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,397
Website

Re: Networkmanager Applet

You probably want to readd those gnome_keyring lines...   Assuming you added them there for a reason.


Edit: BTW, I used that "fix" too.  I'm not 100% sure the dbus one is safe.

Online

#14 2012-08-21 13:26:21

Loosefish
Member
Registered: 2012-08-21
Posts: 2

Re: Networkmanager Applet

Allan wrote:

You probably want to readd those gnome_keyring lines...   Assuming you added them there for a reason.


Edit: BTW, I used that "fix" too.  I'm not 100% sure the dbus one is safe.

You're correct, the keyring lines are still needed to unlock the keyring upon login.

Offline

#15 2012-10-31 20:11:37

r0b0t
Member
From: /tmp
Registered: 2009-05-24
Posts: 342

Re: Networkmanager Applet

progandy wrote:

I had the same problem with Systemd / lightdm / xfce4.

I modified dbus-access rights to get it working again. In /etc/dbus-1/system.d/org.freedesktop.NetworkManager.conf, I changed <deny to <allow for the entries with "Sleep", "sleep", "wake", and  send_destination="org.freedesktop.NetworkManager"/> in the section <policy context="default">


yep this really fixed it.

Offline

#16 2012-10-31 23:24:19

pingpong
Member
From: Los Angeles
Registered: 2010-12-30
Posts: 104

Re: Networkmanager Applet

I wish I can say that.

I have a similar problem NM runs but I cannot join any new networks it complains: "Failed to add/activate" connection (32) Insufficient privileges.
Also, I cannot enable/disable wireless (or network) from nm-applet.

I modified the dbus-access rights are described above but it does not solve the problem.
I'm not using lxdm so I don't know what I should look into in pam.d.

I don't use any graphic login manager, just boot to a console and start openbox using xinit
It sounds like a premission issue (I recently removed gnome since I don't use it)... several people had helped me in https://bbs.archlinux.org/viewtopic.php?id=151848
But I still cannot get NM to work correctly again.

Help help to fix this problem is great appreciated.

Offline

#17 2012-11-09 22:52:23

michaelrx226
Member
Registered: 2012-11-09
Posts: 1

Re: Networkmanager Applet

When I upgraded my system today (using Archlinux as a secondary system to play and observe what's new, while my main system is Debian testing),
I've also experienced this strange behaviour. Networkmanager daemon was already running, but I was unable to control it and it also had
a problem with dbus access, therefore network management applet in KDE (package kdeplasma-applets-networkmanagement)
was throwing at me an error saying "networkmanager is not running" - although daemon was started correctly.

I've SOLVED this by migrating to systemd.

After installing systemd, you should modify your /etc/default/grub to use it - by adding systemd as a kernel boot parameter.
After modification it should look something like this:
GRUB_CMDLINE_LINUX_DEFAULT="quiet init=/usr/lib/systemd/systemd"

then don't forget to update grub configuration:
sudo grub-mkconfig -o /boot/grub/grub.cfg

and of course enable networkmanager service by
sudo systemctl enable NetworkManager.service

Now I have fully working NM applet again in my KDE smile

Useful links:
Systemd
Networkmanager

{MRX}

Offline

#18 2012-11-17 11:10:29

Ashren
Member
From: Denmark
Registered: 2007-06-13
Posts: 1,221
Website

Re: Networkmanager Applet

If you experience problems with nm-applet in combination with lightdm and xfce. Update lightdm and lightdm-gtk-greeter.

Offline

#19 2014-04-30 16:11:40

sagirfahmid3
Member
From: Planet Kerbin
Registered: 2012-09-16
Posts: 3

Re: Networkmanager Applet

progandy wrote:

I had the same problem with Systemd / lightdm / xfce4.

I modified dbus-access rights to get it working again. In /etc/dbus-1/system.d/org.freedesktop.NetworkManager.conf, I changed <deny to <allow for the entries with "Sleep", "sleep", "wake", and  send_destination="org.freedesktop.NetworkManager"/> in the section <policy context="default">

You, sir, are DA MAAAAAN. I logged in just to thank you. I'm a Debian user mostly tongue
Cheers!

I hope this crap gets fixed already. It's April 2014 already and it still isn't fixed.

Offline

#20 2014-04-30 21:18:03

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,071

Re: Networkmanager Applet

sagirfahmid3, Read the forum rules. Do Not Necrobump threads especially with empty posts as yours.


Closing...


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

Board footer

Powered by FluxBB