You are not logged in.

#1 2013-01-20 15:56:14

dancer69
Banned
Registered: 2011-08-05
Posts: 66

console mode language problems

Please help me to fix localization problems in console mode.
In graphical enviroment display language, fonts, keyboard layouts, layout toggle are all fine, but on tty console there are problems.
The english messages and input are fine, but I cannot change keyboard layout to local language(greek), except if I manually input the command: loadkeys gr. Then I can change to greek, but the character aren't readable(appear not greek but ieroglyphycs).
I've set the locale with localectl:
localectl set-locale "LANG=el_GR.utf8", "LC_MESSAGES=el_GR.utf8"
and also the keymap with:
localectl set-keymap en gr

But still I cannot toggle layouts, or have readable characters.
What I'm missing? I've searched but I only found older results with editing rc.conf, which I tried but don't work either.

Offline

#2 2013-01-20 18:06:31

Alber
Member
From: Spain - España
Registered: 2011-11-11
Posts: 174

Re: console mode language problems

Have you edited or created /etc/vconsole.conf
It must have the next line:

KEYMAP=gr

Offline

#3 2013-01-20 19:12:31

dancer69
Banned
Registered: 2011-08-05
Posts: 66

Re: console mode language problems

Yes, this is what "localectl set keymap" does.

Offline

#4 2013-01-20 20:10:19

Alber
Member
From: Spain - España
Registered: 2011-11-11
Posts: 174

Re: console mode language problems

Maybe it is because you have 2 languages selected
Your first post:

 localectl set-keymap en gr 

Could you see how is your file /etc/vconsole.conf?

Sorry I've read your post again. It could be your console font have not greek chars.

Edit:
It could be  UTF-8, not utf8. So you haven't unicode chars in console.
Edit 2:
Here are keymaps, I don't see Greek to know the exact typo.
https://wiki.archlinux.org/index.php/KEYMAP

It is for KEYMAP variable in vconsole.conf (Edit 3)

Last edited by Alber (2013-01-20 21:11:39)

Offline

#5 2013-01-20 20:36:08

dancer69
Banned
Registered: 2011-08-05
Posts: 66

Re: console mode language problems

This is my vconsole.conf:

KEYMAP=en
KEYMAP_TOGGLE=gr
FONT=iso07u-16
FONT_MAP=

I don't think that the 2 languages cause the problem(I tried and only with gr, but no change).
The font is for greek language. I added it to vconsole.conf. For FONT_MAP I don't know what to put, and I didn't find something about it on wiki.

Last edited by dancer69 (2013-01-20 20:57:12)

Offline

#6 2013-01-20 20:38:08

Alber
Member
From: Spain - España
Registered: 2011-11-11
Posts: 174

Re: console mode language problems

Could you try UTF-8 and regenerate locals.
Sorry about the edits.

Offline

#7 2013-01-20 20:39:27

dancer69
Banned
Registered: 2011-08-05
Posts: 66

Re: console mode language problems

What you mean?
I already have generate locale for el.GR.utf8.

Offline

#8 2013-01-20 20:49:02

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,670

Re: console mode language problems

utf8 may not equal UTF8. The suggestion is to try the latter.

What does locale -a give?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#9 2013-01-20 20:53:01

Alber
Member
From: Spain - España
Registered: 2011-11-11
Posts: 174

Re: console mode language problems

In /etc/locale.conf, I have

LANG="es_ES.UTF-8"

Could you try:

LANG="el_GR.UTF-8"

And later:

locale-gen

Edit:
NO neet to do a locale-gen, it is whe you edit /etc/locale.gen.

Last edited by Alber (2013-01-20 23:37:14)

Offline

#10 2013-01-20 20:56:42

dancer69
Banned
Registered: 2011-08-05
Posts: 66

Re: console mode language problems

Okay, seems that vconsole.conf just ignored on boot, because, with
loadkeys gr
I can change layouts, and with
setfont iso07-16.pfsu.gz(which is the same font I have on vconsole.conf) the greek characters displayed fine.

EDIT:
I found this thread:
https://bbs.archlinux.org/viewtopic.php?pid=1183507
which seems is same with my problem. It has a working solution, but I don't know how to do it(especially order systemd thing), but I'll try to find some info.

Last edited by dancer69 (2013-01-20 21:13:29)

Offline

#11 2013-01-20 21:15:22

Alber
Member
From: Spain - España
Registered: 2011-11-11
Posts: 174

Re: console mode language problems

I think it could be help. I didn't do a deep reading. A bit is using rc.conf [about yhe next link)
https://bbs.archlinux.org/viewtopic.php?id=138956

Last edited by Alber (2013-01-20 21:28:38)

Offline

#12 2013-01-26 10:53:25

dancer69
Banned
Registered: 2011-08-05
Posts: 66

Re: console mode language problems

After a lot search, following the directions of above link posts, I have still problem with wrong greek characters on tty consoles. I've made some progress though.
Right now my vconsole.conf is this:

KEYMAP=us
KEYMAP_TOGGLE=gr
FONT=iso07u-16
FONT_MAP=8859-7

and the HOOKS on mkinitcpio.conf is:

HOOKS="base udev plymouth autodetect modconf block filesystems usbinput fsck consolefont keymap"

With above settings I can swich keyboard layouts and write in both english/greek. The problem is that still the greek characters don't appear correct.
Some characters are correct and other(most) appear as white squares and strange symbols. If I login to my account and run:

setfont iso07u-16.psfu.gz

then all greek characters appear correct. If I login as root and type the above command, then again I get wrong characters but now the white squares replaced by ωωω with some strange accents. I can still write greek correct though.
Is something more that need to be done?

Offline

Board footer

Powered by FluxBB