You are not logged in.

#1 2013-04-04 00:01:43

barto
Member
From: Budapest, Hungary
Registered: 2009-10-22
Posts: 88

LibreOffice and others play an annoying blindfold game with me

Hello,

some recent update resulted in LibreOffice forcing me to play some kind of weird blindfold game.  Let there be any letters in any menu headers, menu entries or dialog boxes, text entry boxes, they don’t show up.  However, the icons and the underscores indicating hot-keys for a given menu entry are still visible.  If I open a menu, some labels reappear, but disappear after not more than a tenth of a second.  If I start to drag the whole window of LibreOffice, everything reappears and looks fine, but if I try to click a menu, the labels disappear again (seemingly as they would like to change their appearance, e.g. foreground or background colour).  Phew, it’s quite exhausting to apply any changes! smile

If I take a screenshot, everything looks fine; the screenshot below is retouched to show exactly what I see:

http://anyanyelvapolo.hu/~barci/loblindfold.png

The same applies to other suites (Calc, Impress, Draw), other user accounts (even root), other langpacks (besides my native hu, I tried en-US).

No other apps show this phenomenon. Googling brought some similar issues with LO, but those were about the text being written into Writer, not LO’s own labels.

I don’t know whether it is relevant, but I use Openbox.

So, what next?  Any ideas?

Thanks in advance.

Last edited by barto (2013-04-16 18:35:41)


“First principle, Clarice. Simplicity” – Dr. Hannibal Lecter

Offline

#2 2013-04-05 11:11:58

barto
Member
From: Budapest, Hungary
Registered: 2009-10-22
Posts: 88

Re: LibreOffice and others play an annoying blindfold game with me

Now I think it must somehow be related to desktop environments.  Or not using one. smile

If libreoffice-gnome is installed, the menu headers still don’t show up (unless I drag the window), and if I click a menu header, the menu is still empty (except icons and underscores), but if I move the mouse to any menu item, mysteriously all other menu items show up.  Much nearer to being usable, still far from being solved.

Installing libreoffice-kde4 instead of libreoffice-gnome has no effect, however.


“First principle, Clarice. Simplicity” – Dr. Hannibal Lecter

Offline

#3 2013-04-05 15:04:25

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,071

Re: LibreOffice and others play an annoying blindfold game with me

Try getting rid of all the extensions that you might have installed. See if that helps. I am not sure which extension might be causing the problem, so you can install them again one by one to figure that out.


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#4 2013-04-06 03:26:35

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: LibreOffice and others play an annoying blindfold game with me

If you are using any non-default theme for OpenBox/windows whatever, disable them to test. I tried a theme for KDE at one point which worked great in everything except LO where it seemed to use black text on black background - not very readable! And it also caused some of the weird things you are seeing like menus looking OK if hovered over (or not) or showing up when moving or whatever.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#5 2013-04-10 12:21:44

barto
Member
From: Budapest, Hungary
Registered: 2009-10-22
Posts: 88

Re: LibreOffice and others play an annoying blindfold game with me

Thank you for your hints.

@Inxsible
Removing my only extension, the spell checker, had no effect.  (I suppose by extensions you mean those listed below Tools > Extension Manager…)

@cfr
I use the default Clearlooks theme for Openbox and the default Raleigh theme for GTK with the Oxygen icon theme.  Changing them doesn’t have any effect.  Following this lead I’ve even purged my ~/.gtkrc-2.0 for anything seemingly unnecessary and deleted the directories ~/.config/gtk* to possibly improve “defaultness”, but in vain.

The ArchWiki about LO has also something about themes.  Starting e.g. Writer with different environments has the following effect (libreoffice-gnome is installed when not stated otherwise):

SAL_USE_VCLPLUGIN=gen lowriter

Looks and behaves like if libreoffice-gnome wasn’t installed.

SAL_USE_VCLPLUGIN=gtk lowriter

Looks and behaves like if environment wasn’t set.

SAL_USE_VCLPLUGIN=kde4 lowriter

Looks and behaves like if environment wasn’t set. If libreoffice-kde4 is installed, looks something different, but behaves like if libreoffice-gnome wasn’t installed.

SAL_USE_VCLPLUGIN=gtk3 lowriter

Looks something different, the menus behave almost normal, except that the background becomes black, so just the inactive menu entries are visible.
But some further issues emerge.  It takes several seconds to refresh screen to follow changes, and refreshing is often just partial.  By change I mean highlighting another menu entry as the mouse is moved, or refreshing contents at switching to another tab in a dialog box.  The CPU seemingly gets under quite a heavy load, and the console is filled with a bunch of error messages, most of which looks like this one:

Unhandled is native supported for Type: 120, Part 1

Quite strange.  Any ideas?

Last edited by barto (2013-04-11 18:04:01)


“First principle, Clarice. Simplicity” – Dr. Hannibal Lecter

Offline

#6 2013-04-10 14:51:08

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,640

Re: LibreOffice and others play an annoying blindfold game with me

You are probably missing some required true type font. Check all the hints in our wiki and pacman post.install msg!

Offline

#7 2013-04-11 17:06:18

barto
Member
From: Budapest, Hungary
Registered: 2009-10-22
Posts: 88

Re: LibreOffice and others play an annoying blindfold game with me

As I see I have all necessary and recommended packages installed:

$ pacman -Q | grep -E "libreoffice|ttf|artwiz|hunspell|hyphen|mythes"
artwiz-fonts 1.3-7
hunspell 1.3.2-2
hunspell-hu 1.6.1-2
hyphen 2.8.6-1
hyphen-hu 20100506-3
libmythes 1:1.2.3-1
libreoffice-base 4.0.2-2
libreoffice-calc 4.0.2-2
libreoffice-common 4.0.2-2
libreoffice-draw 4.0.2-2
libreoffice-en-US 4.0.2-2
libreoffice-gnome 4.0.2-2
libreoffice-hu 4.0.2-1
libreoffice-impress 4.0.2-2
libreoffice-kde4 4.0.2-2
libreoffice-math 4.0.2-2
libreoffice-postgresql-connector 4.0.2-2
libreoffice-sdk 4.0.2-2
libreoffice-sdk-doc 4.0.2-2
libreoffice-writer 4.0.2-2
mythes-hu 1.0-3
ttf-bitstream-vera 1.10-9
ttf-dejavu 2.33-4
ttf-inconsolata 20090215-3
ttf-isabella 1.2-2
ttf-linux-libertine 5.3.0-2
ttf-linux-libertine-g 20120116-1
ttf-ms-fonts 2.0-3
ttf-vista-fonts 1-3

The only, at least seemingly relevant hint in the wiki (besides themes) is font substitution.  Tried, no change.

Let me describe the problem from another approach (considering the case when libreoffice-gnome is installed, cause this is the least faulty): sometimes parts of a window get hidden.  This is common if a floating WM is in use, but can occur also inside a sole window when a drop-down menu or dialog box is displayed.  After we get rid of the covering window, menu, dialog box etc., the contents behind them has to be redrawn, but in case of LO this process is just partial and restricts to graphical elements; text is not redrawn.  So it is actually possible to selectively “rubber” out text from the LO window with dragging an XTerm (or any other) window over it.  (Redrawing of the text can be triggered with dragging the LO window itself, however, but only temporarily.)  So I would think that the problem must reside in a lower level than a font package not being installed.


“First principle, Clarice. Simplicity” – Dr. Hannibal Lecter

Offline

#8 2013-04-16 18:35:03

barto
Member
From: Budapest, Hungary
Registered: 2009-10-22
Posts: 88

Re: LibreOffice and others play an annoying blindfold game with me

Ok, now I see that the problem doesn’t restrict to LibreOffice.  Abiword deals with similar issues, but actually it’s the opposite: the text written into the main writing field can be selectively wiped out with another window and Abiword’s own labels are static.

But that’s not all!  Now even xev!  You know the little black-border square in the upper left corner of the event tester window?  At starting xev, this square border is just transparent, and I can’t really wipe it out, because the window used as a rubber acts more like a brush: the square border takes the colour (and even some pattern) of the brush window.  Dragging the xev window itself restores the border to black.  As expected. smile


“First principle, Clarice. Simplicity” – Dr. Hannibal Lecter

Offline

#9 2013-05-15 21:14:51

barto
Member
From: Budapest, Hungary
Registered: 2009-10-22
Posts: 88

Re: LibreOffice and others play an annoying blindfold game with me

Add qucs to that list of failing applications.  Nothing can be made visible inside the menus in anyway, except by taking a screenshot.


“First principle, Clarice. Simplicity” – Dr. Hannibal Lecter

Offline

#10 2013-05-16 02:07:30

twelveeighty
Member
From: Alberta, Canada
Registered: 2011-09-04
Posts: 317

Re: LibreOffice and others play an annoying blindfold game with me

I hate to suggest it to you, but you may want to try to run Xfce or another lightweight desktop environment. It may have something to do with a gnome theme engine that needs to be installed, but that's a wild guess.

Offline

#11 2013-05-16 18:39:59

barto
Member
From: Budapest, Hungary
Registered: 2009-10-22
Posts: 88

Re: LibreOffice and others play an annoying blindfold game with me

Thank you for your hint, but I’d rather rule out the possibility of some kind of Gnome/GTK theme issue, since qucs is also affected, which is a QT application, not to mention xev, which is pure X11.

Actually a reply to a thread about a somewhat similar problem gave me a useful lead, so thank you, omeringen, it is going to be some kind of video driver problem!
Inserting

Option "NoAccel" "true"

into /etc/X11/xorg.conf successfully eliminated all the described annoyances (although video bacame very laggy in return, so I wouldn’t mark this solved yet).  I have been using the nv video driver, because it has just worked for me; nouveau would be a viable option too, it doesn’t have the annoyances, isn’t laggy, but can’t really get the proper resolution.  So some further testing needs to be done.

(my video card: VGA compatible controller: NVIDIA Corporation NV18 [GeForce4 MX 4000] (rev c1))


“First principle, Clarice. Simplicity” – Dr. Hannibal Lecter

Offline

Board footer

Powered by FluxBB