You are not logged in.

#1 2013-04-15 22:18:12

PAdu92
Member
Registered: 2008-06-04
Posts: 101

[Netctl] can't get a basic DHCP to work [solved]

Hi all,

eth1-ethernet:
Description='A basic dhcp ethernet connection'
Interface=eth1
Connection=ethernet
IP=dhcp

netctl start eth1-ethernet:
A depedency job for netctl@eth1\x2dethernet.service failed. See 'journaltcl -xn' for details.

journaltcl -xn gives me a "Dependency failed for a basic dhcp ethernet connection" with not much more info....
I only have dhcpd installed.
Any ideas? Did I miss something?

Last edited by PAdu92 (2013-04-16 19:21:11)

Offline

#2 2013-04-15 23:40:33

progandy
Member
Registered: 2012-05-17
Posts: 2,151

Re: [Netctl] can't get a basic DHCP to work [solved]

Does eth1 exist? the current udev configuration names the network cards differently. use "ip link" to list the names.

Offline

#3 2013-04-16 10:28:48

PAdu92
Member
Registered: 2008-06-04
Posts: 101

Re: [Netctl] can't get a basic DHCP to work [solved]

Yeah it does! I have lo, eth0, eth1 and virbr0 when I do a ip link
Also tried with static IP same result

Last edited by PAdu92 (2013-04-16 10:31:29)

Offline

#4 2013-04-16 11:22:24

PAdu92
Member
Registered: 2008-06-04
Posts: 101

Re: [Netctl] can't get a basic DHCP to work [solved]

here is a full log:

[root@Serveur ~]# journalctl -xn
-- Logs begin at mar. 2012-12-25 16:52:51 CET, end at mar. 2013-04-16 14:18:45 CEST. --
avril 16 14:17:05 Serveur systemd[1]: netctl@ethernet\x2dstatic.service: main process exited, code=exited, status=1/FAILURE
avril 16 14:17:05 Serveur systemd[1]: Failed to start Networking for netctl profile ethernet-static.
-- Subject: Unit netctl@ethernet\x2dstatic.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- Documentation: http://www.freedesktop.org/wiki/Software/systemd/catalog/be02cf6855d2428ba40df7e9d022f03d
-- 
-- Unit netctl@ethernet\x2dstatic.service has failed.
-- 
-- The result is failed.
avril 16 14:17:05 Serveur systemd[1]: Unit netctl@ethernet\x2dstatic.service entered failed state
avril 16 14:17:13 Serveur systemd[1]: Reloading.
avril 16 14:17:15 Serveur systemd[1]: Expecting device sys-subsystem-net-devices-eth1.device...
-- Subject: Unit sys-subsystem-net-devices-eth1.device has begun with start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit sys-subsystem-net-devices-eth1.device has begun starting up.
avril 16 14:18:45 Serveur systemd[1]: Job sys-subsystem-net-devices-eth1.device/start timed out.
avril 16 14:18:45 Serveur systemd[1]: Timed out waiting for device sys-subsystem-net-devices-eth1.device.
-- Subject: Unit sys-subsystem-net-devices-eth1.device has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- Documentation: http://www.freedesktop.org/wiki/Software/systemd/catalog/be02cf6855d2428ba40df7e9d022f03d
-- 
-- Unit sys-subsystem-net-devices-eth1.device has failed.
-- 
-- The result is timeout.
avril 16 14:18:45 Serveur systemd[1]: Dependency failed for A basic static ethernet connection.
-- Subject: Unit netctl@ethernet\x2dstatic.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- Documentation: http://www.freedesktop.org/wiki/Software/systemd/catalog/be02cf6855d2428ba40df7e9d022f03d
-- 
-- Unit netctl@ethernet\x2dstatic.service has failed.
-- 
-- The result is dependency.

I do get ethernet connection throught dhcpd thought.....

Offline

#5 2013-04-16 11:45:50

PAdu92
Member
Registered: 2008-06-04
Posts: 101

Re: [Netctl] can't get a basic DHCP to work [solved]

Ok, here is something weird:
ifconfig shows me only lo and virbr0 interfaces

ip link shows lo, eth0 eth1 and virbr0. eth0 and eth1 are down.....
please help me guys!

Offline

#6 2013-04-16 17:55:57

PAdu92
Member
Registered: 2008-06-04
Posts: 101

Re: [Netctl] can't get a basic DHCP to work [solved]

I deleted /etc/udev/rules.d/80-net-name-slot.rules now eth1 is called enp3s0 but still the same error with netctl.....

Offline

#7 2013-04-16 19:00:26

ancleessen4
Member
From: Luxembourg
Registered: 2009-11-22
Posts: 120
Website

Re: [Netctl] can't get a basic DHCP to work [solved]

Here is my /etc/netctl/ethernet-dhcp profile.
I had to change 'eth0' to 'enp0s20' as per 'ip link' info;

Description='A basic dhcp ethernet connection'
Interface=enp0s20
Connection=ethernet
IP=dhcp

Offline

#8 2013-04-16 19:20:53

PAdu92
Member
Registered: 2008-06-04
Posts: 101

Re: [Netctl] can't get a basic DHCP to work [solved]

ancleessen4 wrote:

Here is my /etc/netctl/ethernet-dhcp profile.
I had to change 'eth0' to 'enp0s20' as per 'ip link' info;

Description='A basic dhcp ethernet connection'
Interface=enp0s20
Connection=ethernet
IP=dhcp

Yeap I did so....
Anyways, somehow I finally got it to work thanks guys!

Offline

#9 2013-04-16 19:22:19

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,079

Re: [Netctl] can't get a basic DHCP to work [solved]

PAdu92 wrote:

Yeap I did so....
Anyways, somehow I finally got it to work thanks guys!

Please share your solution so that others in the same situation may benefit as well.


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#10 2013-04-16 19:27:06

ancleessen4
Member
From: Luxembourg
Registered: 2009-11-22
Posts: 120
Website

Re: [Netctl] can't get a basic DHCP to work [solved]

@PAdu92
@Inxsible
Yes...it would be interesting...as a lot of us are new to netctl.

Thanks in advance.

Offline

#11 2013-04-16 20:31:38

PAdu92
Member
Registered: 2008-06-04
Posts: 101

Re: [Netctl] can't get a basic DHCP to work [solved]

No idea actually..... there was another file in /etc/udev/rules.d/ that forced my interface to be called eth1 deleted it....

Offline

#12 2013-06-15 18:46:02

Jim Snyder
Member
Registered: 2013-06-15
Posts: 2

Re: [Netctl] can't get a basic DHCP to work [solved]

I had a similar problem with both ether and wifi.

You might try adding your interface to the BindsTo array in the interface profile like so:

<code>
Description='Wireless with wpa_supplicant.conf'
Interface=wlp12s0
BindsTo=(wlp12s0)
Connection=wireless
Security=wpa-config
WPAConfigFile='/etc/wpa_supplicant/wpa_supplicant.conf'
IP=dhcp
</code>

The netctl.profile man page says this isn't necessary, but the netctl/systemd unit file that gets generated was bogus without the BindsTo line.

Perhaps more to the point, it works for me if I fill in BindsTo in the profile, but not if I leave it unset.

To see what changes, run:

<code>
du -a /etc/systemd | grep netctl
</code>

then look at the BindsTo and the After parameters in those files when BindsTo in the corresponding netctl profiles is set vs. not set.

I forget what happened to my ether interface, but for wifi the systemd file fingered wlan0.device, not wlp12s0.

Offline

#13 2013-06-15 18:55:10

karol
Archivist
Registered: 2009-05-06
Posts: 25,432

Re: [Netctl] can't get a basic DHCP to work [solved]

PAdu92 wrote:

No idea actually..... there was another file in /etc/udev/rules.d/ that forced my interface to be called eth1 deleted it....

Maybe it was https://wiki.archlinux.org/index.php/Ne … vice_names

Offline

Board footer

Powered by FluxBB