You are not logged in.

#1 2013-04-22 14:38:21

senorsmile
Member
Registered: 2010-12-12
Posts: 67

gnome-games-extra-data: requires gnome-games

Getting the following error when trying to upgrade:

error: failed to prepare transaction (could not satisfy dependencies)
:: gnome-games-extra-data: requires gnome-games

I removed gnome-games-extra-data

sudo pacman -R gnome-games-extra-data

and upgrades seem to be going fine now.  I have never played a single gnome game any way, so even if I broke something, I'll probably never notice.

Offline

#2 2013-04-22 14:46:54

aorith
Member
Registered: 2013-04-19
Posts: 10

Re: gnome-games-extra-data: requires gnome-games

I just did that today, had the system fully upgraded from yesterday, and now it hangs on boot while checking partitions...

Offline

#3 2013-04-22 14:58:00

senorsmile
Member
Registered: 2010-12-12
Posts: 67

Re: gnome-games-extra-data: requires gnome-games

I just rebooted and also have a hanged system.  Going to start a new thread as I believe this COULD be related to gnome 3.8 upgrade.

Offline

#4 2013-04-22 15:00:34

senorsmile
Member
Registered: 2010-12-12
Posts: 67

Re: gnome-games-extra-data: requires gnome-games

Just upgraded system, which included new linux-3.8.8 and gnome3.8 packages, among others.  My systems now hangs with systemd message:

reached target graphical interface

and the entire systemd boot text on the screen is flashing.  It doesn't appear to be a hard freeze as I can hit the power button and a shutdown initiates but displays tons of errors and never actually shuts down.

Offline

#5 2013-04-22 15:02:11

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,079

Re: gnome-games-extra-data: requires gnome-games

that's because you figured you could get away with a problem by doing something that would solve the temporary problem... which led to a bigger problem. If gnome-games-extra-data is required by other packages, and you remove it, things are bound to break.

Partial upgrades are not supported.  (I am not sure if any other packages do depend on it)


Merging both your threads for context...


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#6 2013-04-22 15:38:08

Joel
Member
From: Tijuana, BC, México
Registered: 2011-12-21
Posts: 84

Re: gnome-games-extra-data: requires gnome-games

You'll have to remove first gnome-games-extra-data and gnome-games:

# pacman -Rs gnome-games-extra-data gnome-games

upgrade system

# pacman -Syu

later, install the games according to the new package names, see gnome-extras.

Last edited by Joel (2013-04-22 15:41:32)


* PC: Intel Core 2 DUO E6550 @ 2.33 GHz with 2 GB RAM: Archlinux-i686 with xfce4.
* Laptop: Intel Core 2 DUO T6600 @ 2.20 GHz with 4 GB RAM: Archlinux-x86-64 with xfce4.
* AUR contributor.

Offline

#7 2013-04-23 23:46:48

mgeiger
Member
Registered: 2013-04-23
Posts: 2

Re: gnome-games-extra-data: requires gnome-games

Hey sensorsmile,
I got the same behaviour after updating today. After trying out a couple of things I found out, that my GDM is broken.

Here's what I did to get my machine running again:
1. when grub screen appears press "e" to edit the additional commands.
2. after "ro quiet ..." enter "single" to make the kernel boot only into the console and avoid GDM.
3. boot with F10
4. login in terminal mode
5. as root type "systemctl disable gdm"
6. install slim (read about it in wiki, especially the part with xinitrc)
8. as root type "systemctl enable slim"
9. reboot

Well I don't know if you're using gnome, but if so, you can try these steps. good luck

Offline

#8 2013-04-24 01:29:41

senorsmile
Member
Registered: 2010-12-12
Posts: 67

Re: gnome-games-extra-data: requires gnome-games

I figured it was something to do with either gnome or gdm.  I have a couple other machines that I haven't yet upgraded and will have to go through this.  I wonder what the deal is with GDM?

Unfortunately I didn't have time to troubleshoot at work and just booted to an opensuse 12.3 KDE CD I was given to try out.  First time for both opensuse and KDE for me. 

If I figure out anything else concerning GDM I'll post back.

mgeiger wrote:

Hey sensorsmile,
I got the same behaviour after updating today. After trying out a couple of things I found out, that my GDM is broken.

Here's what I did to get my machine running again:
1. when grub screen appears press "e" to edit the additional commands.
2. after "ro quiet ..." enter "single" to make the kernel boot only into the console and avoid GDM.
3. boot with F10
4. login in terminal mode
5. as root type "systemctl disable gdm"
6. install slim (read about it in wiki, especially the part with xinitrc)
8. as root type "systemctl enable slim"
9. reboot

Well I don't know if you're using gnome, but if so, you can try these steps. good luck

Offline

#9 2013-04-24 10:15:32

mgeiger
Member
Registered: 2013-04-23
Posts: 2

Re: gnome-games-extra-data: requires gnome-games

It's a common problem:
https://bbs.archlinux.org/viewtopic.php?pid=1262876
Most of the other guys recommend to install slim as a first fix and then wait for a gdm update.

Offline

#10 2013-04-24 15:38:33

Thomas_Do
Member
Registered: 2011-08-12
Posts: 53

Re: gnome-games-extra-data: requires gnome-games

mgeiger wrote:

After trying out a couple of things I found out, that my GDM is broken.

https://bbs.archlinux.org/viewtopic.php … 4#p1263433

Offline

Board footer

Powered by FluxBB