You are not logged in.

#1 2013-05-11 18:15:54

killsto
Member
Registered: 2008-12-09
Posts: 35

Extremely choppy internet

My internet is extremely choppy. Every once in a while it will just be really slow or disconnect. However the wifi stays connected. This occurs on my home router (WPA2) and work (WPA2 enterprise). I think it also has a problem on wired, but I haven't been able to try in the past month or two.

ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=47 time=91.7 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=47 time=105 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=47 time=46.4 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=47 time=556 ms
64 bytes from 8.8.8.8: icmp_seq=5 ttl=47 time=375 ms
64 bytes from 8.8.8.8: icmp_seq=6 ttl=47 time=44.6 ms
64 bytes from 8.8.8.8: icmp_seq=7 ttl=47 time=73.8 ms
64 bytes from 8.8.8.8: icmp_seq=8 ttl=47 time=55.1 ms
64 bytes from 8.8.8.8: icmp_seq=9 ttl=47 time=59.8 ms
64 bytes from 8.8.8.8: icmp_seq=10 ttl=47 time=40.4 ms
64 bytes from 8.8.8.8: icmp_seq=11 ttl=47 time=47.3 ms
64 bytes from 8.8.8.8: icmp_seq=12 ttl=47 time=207 ms
64 bytes from 8.8.8.8: icmp_seq=14 ttl=47 time=231 ms
64 bytes from 8.8.8.8: icmp_seq=13 ttl=47 time=1240 ms
64 bytes from 8.8.8.8: icmp_seq=15 ttl=47 time=251 ms
64 bytes from 8.8.8.8: icmp_seq=16 ttl=47 time=308 ms
64 bytes from 8.8.8.8: icmp_seq=17 ttl=47 time=511 ms
64 bytes from 8.8.8.8: icmp_seq=18 ttl=47 time=226 ms
64 bytes from 8.8.8.8: icmp_seq=19 ttl=47 time=63.1 ms
64 bytes from 8.8.8.8: icmp_seq=20 ttl=47 time=831 ms
64 bytes from 8.8.8.8: icmp_seq=21 ttl=47 time=194 ms
64 bytes from 8.8.8.8: icmp_seq=22 ttl=47 time=501 ms
64 bytes from 8.8.8.8: icmp_seq=23 ttl=47 time=160 ms
#
# /etc/hosts: static lookup table for host names
#

#<ip-address>   <hostname.domain.org>   <hostname>
127.0.0.1       localhost.localdomain   localhost
127.0.0.1       killarch.localdomain    killarch
::1             localhost.localdomain   localhost

# End of file
uname -a
Linux killarch 3.8.11-1-ARCH #1 SMP PREEMPT Wed May 1 20:18:57 CEST 2013 x86_64 GNU/Linux
Network controller: Intel Corporation Centrino Wireless-N 100
        Subsystem: Intel Corporation Centrino Wireless-N 100 BGN
        Flags: bus master, fast devsel, latency 0, IRQ 50
        Memory at ddc00000 (64-bit, non-prefetchable) [size=8K]
        Capabilities: <access denied>
        Kernel driver in use: iwlwifi
        Kernel modules: iwlwifi

I just tried pinging 8.8.8.8 again and got response times ~<40ms. So it's being really weird. This has been happening in previous kernels as well - since I reinstalled arch again actually which was 3.7.something I think.

Offline

#2 2013-05-11 18:40:32

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Extremely choppy internet

Is this an older card?  Not necessarily too old, but if it is not the newest generation of wireless devices, you might need to be using one of the other intel wireless modules... not sure though.

I have seen reports of many poeple having issues with iwlwifi, but I have had nothing but awesomeness with it.  It would seem that for most others it works quite well, but certainly not for everyone.

Offline

#3 2013-05-11 19:27:53

killsto
Member
Registered: 2008-12-09
Posts: 35

Re: Extremely choppy internet

According to this it is supported by iwlwifi.

Forgot to mention another thing is that a webpage might be not loading, but if I open a new tab and go to a different site they both load instantly. I can't determine if this is a coincidence or not because sometime it does not happen.

Last edited by killsto (2013-05-11 19:29:51)

Offline

#4 2013-05-11 19:55:48

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Extremely choppy internet

You know that because of the nss-myhostname addition to systemd, there is no need to have your hosts file edited.  So you should try going back to the stock /etc/hosts file.

Offline

#5 2013-05-11 20:20:02

killsto
Member
Registered: 2008-12-09
Posts: 35

Re: Extremely choppy internet

I actually just added that recently. It seemed to be worse before, but that may be just in my head.

Offline

#6 2013-05-11 20:32:07

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Extremely choppy internet

Yeah, I forgot to mention that that probably would not fix the issue.  But it might prevent problems down the road.

Offline

Board footer

Powered by FluxBB