You are not logged in.

#51 2016-05-11 09:07:13

raggerv8
Member
Registered: 2010-07-01
Posts: 87

Re: Xyne's repos: news and discussion

The repo is offline D:

http://isup.me/xyne.archlinux.ca

Edit: Up again, see post below.

Last edited by raggerv8 (2016-05-11 11:49:40)

Offline

#52 2016-05-11 11:48:45

runical
Member
From: The Netherlands
Registered: 2012-03-03
Posts: 871

Re: Xyne's repos: news and discussion

It was a temporary lapse it seems. It is up again.

By the way, Xyne, wouldn't it be better to remove packages which are no longer maintained or needed from your repos? Like makedep?

Offline

#53 2016-05-11 22:15:08

Xyne
Moderator/TU
Registered: 2008-08-03
Posts: 6,215
Website

Re: Xyne's repos: news and discussion

I had forgotten about makedep. I've updated it for now. I'll remove it later if it no longer serves a purpose.


My Arch Linux StuffForum EtiquetteCommunity Ethos - Arch is not for everyone

Offline

#54 2016-05-20 14:33:12

cmsigler
Member
Registered: 2013-11-18
Posts: 12

Re: Xyne's repos: news and discussion

Hi,

FYI, when upgrading python3-memoizedb to version 2016.4.24.1-1 via AUR, the source code isn't available/updated.  The last source posted on the project page at xyne.archlinux.ca is 2016.4.6.

Thank you for maintaining so many useful (essential smile ) Arch Linux utilities.

Clemmitt

Offline

#55 2017-05-18 11:15:04

raggerv8
Member
Registered: 2010-07-01
Posts: 87

Re: Xyne's repos: news and discussion

Any idea why this started happening today?

error: GPGME error: No data
error: xyne-x86_64: missing required signature
:: Synchronizing package databases...
 core                                                                            125.2 KiB  6.11M/s 00:00 [--------------------------------------------------------------] 100%
 extra                                                                          1684.5 KiB  9.68M/s 00:00 [--------------------------------------------------------------] 100%
 community                                                                         3.8 MiB  9.82M/s 00:00 [--------------------------------------------------------------] 100%
 multilib                                                                        176.1 KiB  8.60M/s 00:00 [--------------------------------------------------------------] 100%
 repo-ck                                                                          51.5 KiB   271K/s 00:00 [--------------------------------------------------------------] 100%
error: failed retrieving file 'xyne-x86_64.db' from xyne.archlinux.ca : The requested URL returned error: 403
error: failed to update xyne-x86_64 (unexpected error)
error: database 'xyne-x86_64' is not valid (invalid or corrupted database (PGP signature))

Yesterday I updated gnupg, then today I was going to update system again. I tried to add your key specifically, and I think that's causing the top two messages. Not sure if it's upstream issue on your end or my end since I updated gnupg.

Last edited by raggerv8 (2017-05-18 11:15:32)

Offline

#56 2017-05-18 22:53:58

GSF1200S
Member
Registered: 2008-12-24
Posts: 463

Re: Xyne's repos: news and discussion

raggerv8 wrote:

Any idea why this started happening today?

error: GPGME error: No data
error: xyne-x86_64: missing required signature
:: Synchronizing package databases...
 core                                                                            125.2 KiB  6.11M/s 00:00 [--------------------------------------------------------------] 100%
 extra                                                                          1684.5 KiB  9.68M/s 00:00 [--------------------------------------------------------------] 100%
 community                                                                         3.8 MiB  9.82M/s 00:00 [--------------------------------------------------------------] 100%
 multilib                                                                        176.1 KiB  8.60M/s 00:00 [--------------------------------------------------------------] 100%
 repo-ck                                                                          51.5 KiB   271K/s 00:00 [--------------------------------------------------------------] 100%
error: failed retrieving file 'xyne-x86_64.db' from xyne.archlinux.ca : The requested URL returned error: 403
error: failed to update xyne-x86_64 (unexpected error)
error: database 'xyne-x86_64' is not valid (invalid or corrupted database (PGP signature))

Yesterday I updated gnupg, then today I was going to update system again. I tried to add your key specifically, and I think that's causing the top two messages. Not sure if it's upstream issue on your end or my end since I updated gnupg.

I get:

:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community                  3.8 MiB   399K/s 00:10 [######################] 100%
 multilib is up to date
error: failed retrieving file 'xyne-x86_64.db' from xyne.archlinux.ca : The requested URL returned error: 403
error: failed to update xyne-x86_64 (unexpected error)

No database invalid stuff though. I took it as something wrong with his server. Wouldnt a gnupg error print something like:

error: failed to commit transaction (invalid or corrupted package (PGP signature))

We'll see what Xyne has to say.

Offline

#57 2017-05-19 11:13:54

raggerv8
Member
Registered: 2010-07-01
Posts: 87

Re: Xyne's repos: news and discussion

error: xyne-x86_64: key "1D1F0DC78F173680" is unknown
:: Import PGP key 4096R/EC3CBE7F607D11E663149E811D1F0DC78F173680, "Xyne. (key #3) <xyne@archlinux.ca>", created: 2013-09-15? [Y/n] y
error: xyne-x86_64: signature from "Xyne. (key #3) <xyne@archlinux.ca>" is invalid
:: Synchronizing package databases...
 core                                                              125.2 KiB  6.11M/s 00:00 [------------------------------------------------------] 100%
 extra                                                            1684.3 KiB  10.3M/s 00:00 [------------------------------------------------------] 100%
 community                                                           3.8 MiB  9.57M/s 00:00 [------------------------------------------------------] 100%
 multilib                                                          176.1 KiB  8.60M/s 00:00 [------------------------------------------------------] 100%
 repo-ck                                                            51.5 KiB   271K/s 00:00 [------------------------------------------------------] 100%
error: failed retrieving file 'xyne-x86_64.db' from xyne.archlinux.ca : The requested URL returned error: 403
error: failed to update xyne-x86_64 (unexpected error)
error: database 'xyne-x86_64' is not valid (invalid or corrupted database (PGP signature))

Unrelated to the above but still related to powerpill, aria2 updated, so now this error with powerpill

ERROR: could not open file /var/lib/pacman/sync/xyne-x86_64.db: Unrecognized archive format

05/19 13:07:49 [NOTICE] Downloading 3 item(s)

05/19 13:07:50 [ERROR] CUID#8 - Download aborted. URI=http://xyne.archlinux.ca/repos/xyne/xyne-x86_64.db
Exception: [AbstractCommand.cc:351] errorCode=22 URI=http://xyne.archlinux.ca/repos/xyne/xyne-x86_64.db
  -> [HttpSkipResponseCommand.cc:239] errorCode=22 The response status is not successful. status=403

05/19 13:07:50 [NOTICE] Download GID#c4be1ff79e18bc17 not complete: /var/lib/pacman/sync/xyne-x86_64.db

05/19 13:07:50 [NOTICE] Download complete: /var/lib/pacman/sync/xyne-x86_64.db.sig

05/19 13:07:50 [NOTICE] Download complete: /var/lib/pacman/sync/repo-ck.db

Download Results:
gid   |stat|avg speed  |path/URI
======+====+===========+=======================================================
c4be1f|ERR |       0B/s|/var/lib/pacman/sync/xyne-x86_64.db
2dc9da|OK  |        n/a|/var/lib/pacman/sync/xyne-x86_64.db.sig
86dcba|OK  |   275KiB/s|/var/lib/pacman/sync/repo-ck.db

Status Legend:
(OK):download completed.(ERR):error occurred.

aria2 will resume download if the transfer is restarted.
If there are any errors, then see the log file. See '-l' option in help/man page for details.
receiving incremental file list
community.db
      4,014,763 100%   10.43MB/s    0:00:00 (xfr#1, to-chk=3/4)
extra.db
      1,724,752 100%    3.21MB/s    0:00:00 (xfr#2, to-chk=1/4)
[2017-05-19 13:07:51] ERROR: PowerpillError: aria2c exited with 22

Offline

#58 2017-05-19 11:30:58

outarcher
Member
Registered: 2017-05-19
Posts: 1

Re: Xyne's repos: news and discussion

Hi to everybody)
A day ago my attempt to update repositories started to return me the following:
i'm quoting:

pacman -Suy
...
error: failed retrieving file 'xyne-any.db' from xyne.archlinux.ca : The requested URL returnd error: 403
error: failed to update xyne-any (unexpected error)

end of quoting...)

My pacman.conf is:
#Powerpill repository
[xyne-any]
SigLevel = Never
Server = http://xyne.archlinux.ca/repos/xyne

Before that time everyting was responding just fine... Now requests are (403 error) forbidden.

My short and sheer question is: What's up?

Last edited by outarcher (2017-05-19 11:31:38)

Offline

#59 2017-05-19 11:33:11

raggerv8
Member
Registered: 2010-07-01
Posts: 87

Re: Xyne's repos: news and discussion

outarcher wrote:

Hi to everybody)
A day ago my attempt to update repositories started to return me the following:
i'm quoting:

pacman -Suy
...
error: failed retrieving file 'xyne-any.db' from xyne.archlinux.ca : The requested URL returnd error: 403
error: failed to update xyne-any (unexpected error)

end of quoting...)

My pacman.conf is:
#Powerpill repository
[xyne-any]
SigLevel = Never
Server = http://xyne.archlinux.ca/repos/xyne

Before that time everyting was responding just fine... Now requests are (403 error) forbidden.

My short and sheer question is: What's up?

I should have probably used this thread, not the powerpill thread, I forgot this existed (because apparently I am subscribed to this thread).

Related: https://bbs.archlinux.org/viewtopic.php … 2#p1711902

Same issue, started happening yesterday.

Offline

#60 2017-05-20 01:13:13

fiddlinmacx
Member
Registered: 2011-03-02
Posts: 78

Re: Xyne's repos: news and discussion

outarcher wrote:

error: failed retrieving file 'xyne-any.db' from xyne.archlinux.ca : The requested URL returnd error: 403
error: failed to update xyne-any (unexpected error)


I'm getting the exact same thing since yesterday. I tried using https. No luck.
When I use my browser and browse the repo I seem to be able to download anything except the 3 .db files. I get a 403 on those only.

Offline

#61 2017-05-21 21:31:46

ArchLinuxGeek
Member
From: Redding, California
Registered: 2017-05-21
Posts: 1

Re: Xyne's repos: news and discussion

I am getting the same error, I cannot download the .db files at all and get a 403 error when i try to. What happened?


i3-6100    Asrock Z170-Pro Motherboard    16 GB Ram    Nvidia Geforce 1050Ti    Intel 600P nvme m.2 120 GB ssd   1 TB WD Blue HDD    Phanteks Enthoo Pro Case

Offline

#62 2017-05-21 22:41:36

fiddlinmacx
Member
Registered: 2011-03-02
Posts: 78

Re: Xyne's repos: news and discussion

I'm pretty sure it's just a matter of file permissions for the 3 .db files on the web server. I think the web server daemon doesn't have rights to them and so can't share them with us. We'll just have to wait until xyne or someone else with root on the server can fix it.

Offline

#63 2017-05-23 04:26:46

Xyne
Moderator/TU
Registered: 2008-08-03
Posts: 6,215
Website

Re: Xyne's repos: news and discussion

I'm getting weird warning screens when visiting the site (protected by Imunify, weird activity from your address, captcha, etc.), the same 403 errors as everyone else, and the ftp sync is slow.

I'll contact Dusty (the host) to see what's going on. I hope this isn't the end of the gravy train. I have no temporary solution at the moment. I'll post an update once I know more.

edit
It seems that there is some global filter to return a 403 error for all files with the ".db" extension. The database and matching sig are still available under http://xyne.archlinux.ca/repos/xyne/xyn … .db.tar.xz and http://xyne.archlinux.ca/repos/xyne/xyn … tar.xz.sig

Dirty kludge to update the databases while waiting:

#!/bin/bash
arch_="${1:-x86_64}"
wget "http://xyne.archlinux.ca/repos/xyne/xyne-${arch_}.db.tar.xz" -O "xyne-${arch_}.db"
wget "http://xyne.archlinux.ca/repos/xyne/xyne-${arch_}.db.sig" -O "xyne-${arch_}.db.sig"
sudo mv -t '/var/lib/pacman/sync' "xyne-${arch_}.db"*

Last edited by Xyne (2017-05-23 05:17:37)


My Arch Linux StuffForum EtiquetteCommunity Ethos - Arch is not for everyone

Offline

#64 2017-05-23 16:01:35

raggerv8
Member
Registered: 2010-07-01
Posts: 87

Re: Xyne's repos: news and discussion

Xyne wrote:

(protected by Imunify, weird activity from your address, captcha, etc.)

Yeah, I got this too.

Xyne wrote:

It seems that there is some global filter to return a 403 error for all files with the ".db" extension. The database and matching sig are still available under http://xyne.archlinux.ca/repos/xyne/xyn … .db.tar.xz and http://xyne.archlinux.ca/repos/xyne/xyn … tar.xz.sig

Dirty kludge to update the databases while waiting:

#!/bin/bash
arch_="${1:-x86_64}"
wget "http://xyne.archlinux.ca/repos/xyne/xyne-${arch_}.db.tar.xz" -O "xyne-${arch_}.db"
wget "http://xyne.archlinux.ca/repos/xyne/xyne-${arch_}.db.sig" -O "xyne-${arch_}.db.sig"
sudo mv -t '/var/lib/pacman/sync' "xyne-${arch_}.db"*

Using pacman, it still produces the error

error: failed retrieving file 'xyne-x86_64.db' from xyne.archlinux.ca : The requested URL returned error: 403
error: failed to update xyne-x86_64 (unexpected error)

This might be normal, though. However using powerpill doesn't work;

Status Legend:
(OK):download completed.(ERR):error occurred.

aria2 will resume download if the transfer is restarted.
If there are any errors, then see the log file. See '-l' option in help/man page for details.
receiving incremental file list
community.db
      4,023,620 100%    8.10MB/s    0:00:00 (xfr#1, to-chk=3/4)
PowerpillError: aria2c exited with 22

It might just need a rebuild since building from AUR works fine.

Offline

#65 2017-05-23 16:11:58

Xyne
Moderator/TU
Registered: 2008-08-03
Posts: 6,215
Website

Re: Xyne's repos: news and discussion

Based on my own tests and the messages that I have received, this is not a transient error. The website is a subdomain on someone else's server and it seems that a global rule has been set to return 403 errors for files with the .db extension. I can't override it with htaccess mod_rewrite rules. No reply from the host so far. I'm testing workarounds but the repo may be inaccessible for a few days (or even indefinitely).



raggerv8 wrote:

Using pacman, it still produces the error

The script can't circumvent the 403 errors with pacman/powerpill/any other database downloader. It just updates the local files so that you can run "pacman -Su" afterwards and download packages as usual.


edit
Reply from Dusty: we just have to wait it out until the host realizes the issue and fixes it, which they normally do "eventually".

Last edited by Xyne (2017-05-23 18:10:25)


My Arch Linux StuffForum EtiquetteCommunity Ethos - Arch is not for everyone

Offline

#66 2017-05-25 16:05:45

Klystro
Member
Registered: 2017-05-01
Posts: 6

Re: Xyne's repos: news and discussion

whoops. Ignore this

Last edited by Klystro (2017-05-25 16:13:34)

Offline

#67 2017-05-25 16:13:01

Klystro
Member
Registered: 2017-05-01
Posts: 6

Re: Xyne's repos: news and discussion

Wait it out? Why don't you ask him to contact the host and tell them that he's having an issue?


Current Known Issues

The server is refusing to serve files with the .db extension. I have contacted the host and am waiting for a reply.

^ you might want to update the message on your site btw. Maybe a link to this thread would be convenient as well

Also, I love the layout of your site, especially that message. It's really nice to know what's going on.

Offline

#68 2017-05-25 19:16:58

Xyne
Moderator/TU
Registered: 2008-08-03
Posts: 6,215
Website

Re: Xyne's repos: news and discussion

Klystro wrote:

Wait it out? Why don't you ask him to contact the host and tell them that he's having an issue?

He flat out told me that he has no time to deal with this. Given that he's been hosting the site for free for ~9 years, I can't really insist. I'm exploring other options to mirror the repo (or move the site).


Klystro wrote:

^ you might want to update the message on your site btw. Maybe a link to this thread would be convenient as well

Also, I love the layout of your site, especially that message. It's really nice to know what's going on.

I've changed the message and added a link to this thread.


My Arch Linux StuffForum EtiquetteCommunity Ethos - Arch is not for everyone

Offline

#69 2017-05-25 20:38:18

Klystro
Member
Registered: 2017-05-01
Posts: 6

Re: Xyne's repos: news and discussion

Xyne wrote:

He flat out told me that he has no time to deal with this. Given that he's been hosting the site for free for ~9 years, I can't really insist. I'm exploring other options to mirror the repo (or move the site).

Ah well... fair enough. Have you considered talking to his host for him?



Xyne wrote:

I'm exploring other options to mirror the repo (or move the site).

Would it be possible to place a redirect or something similar (http response: page permanently moved?) to get whatever the mechanism is to look for the .db files in another location? I'm assuming that it would be easier to find a new home for 3 files rather than the whole repo.

Or is it possible to rename the files and get either the update scripts or perhaps the webserver to translate the name? If the block is on filenames rather than the network requests that might work.

I'm a web admin noob but in my dabblings I've found that the wikimedia software uses a url rewrite (?) to make it look prettier in the address bar. Maybe I'm misunderstanding how it works but I thought it basically just translated the requested url into the underlying php requests

Last edited by Klystro (2017-05-25 20:42:35)

Offline

#70 2017-05-26 00:37:55

Xyne
Moderator/TU
Registered: 2008-08-03
Posts: 6,215
Website

Re: Xyne's repos: news and discussion

Klystro wrote:

Have you considered talking to his host for him?

I am in no position to do so and even suggesting it would be completely out of place. I've sent an email to kindly ask that he inform the host of the issue when he has a moment.

Klystro wrote:

Would it be possible to place a redirect or something similar (http response: page permanently moved?) to get whatever the mechanism is to look for the .db files in another location? I'm assuming that it would be easier to find a new home for 3 files rather than the whole repo.

Or is it possible to rename the files and get either the update scripts or perhaps the webserver to translate the name? If the block is on filenames rather than the network requests that might work.

I'm a web admin noob but in my dabblings I've found that the wikimedia software uses a url rewrite (?) to make it look prettier in the address bar. Maybe I'm misunderstanding how it works but I thought it basically just translated the requested url into the underlying php requests

I have already tried to use mod_rewrite magic to redirect *.db requests to the equivalent *.db.tar.xz files but whatever the host has implemented supersedes mod_rewrite. Pacman will always request the .db file so there is no way to work around it that way.


Workaround

After some more tinkering I have found a temporary solution. Replace the Server parameter in your pacman.conf file with the corresponding setting on the repos page. If you get further errors, check that page for updates.


My Arch Linux StuffForum EtiquetteCommunity Ethos - Arch is not for everyone

Offline

#71 2017-05-27 14:33:36

fiddlinmacx
Member
Registered: 2011-03-02
Posts: 78

Re: Xyne's repos: news and discussion

That works. Thanks!

Just an aside, SSL works fine for your site. Is there any reason I shouldn't use https://xyne.archlinux.ca?

Offline

#72 2017-05-29 08:19:04

Xyne
Moderator/TU
Registered: 2008-08-03
Posts: 6,215
Website

Re: Xyne's repos: news and discussion

fiddlinmacx wrote:

That works. Thanks!

Just an aside, SSL works fine for your site. Is there any reason I shouldn't use https://xyne.archlinux.ca?

That's new too. I'll update.


My Arch Linux StuffForum EtiquetteCommunity Ethos - Arch is not for everyone

Offline

#73 2017-06-06 15:45:33

ayushjsh
Member
Registered: 2013-03-21
Posts: 8

Re: Xyne's repos: news and discussion

I still get errors with the workaround.

error: failed retrieving file 'xyne-x86_64.db' from xyne.archlinux.ca : could not resolve host: xyne.archlinux.ca

Offline

#74 2017-06-06 15:55:32

raggerv8
Member
Registered: 2010-07-01
Posts: 87

Re: Xyne's repos: news and discussion

ayushjsh wrote:

I still get errors with the workaround.

error: failed retrieving file 'xyne-x86_64.db' from xyne.archlinux.ca : could not resolve host: xyne.archlinux.ca

Show your pacman.conf?

Offline

#75 2017-06-06 22:26:16

ayushjsh
Member
Registered: 2013-03-21
Posts: 8

Re: Xyne's repos: news and discussion

raggerv8 wrote:
ayushjsh wrote:

I still get errors with the workaround.

error: failed retrieving file 'xyne-x86_64.db' from xyne.archlinux.ca : could not resolve host: xyne.archlinux.ca

Show your pacman.conf?

[xyne-x86_64]
Siglevel = Required
Server = https://xyne.archlinux.ca/bin/repo.php?file=

Offline

Board footer

Powered by FluxBB