You are not logged in.

#1 2006-08-05 03:50:45

rasat
Forum Fellow
From: Finland, working in Romania
Registered: 2002-12-27
Posts: 2,176
Website

Kernel reads sda instead of hda

When installing Arch on a laptop the HD device showns as /dev/sda instead of /dev/hda. This causes problem for USB devices using same /dev/sda. When I tried with an old Knoppix live CD with kernel 2.4.x shows /dev/hda. How to fix?

Offline

#2 2006-08-05 16:13:38

rasat
Forum Fellow
From: Finland, working in Romania
Registered: 2002-12-27
Posts: 2,176
Website

Re: Kernel reads sda instead of hda

> If you are using SATA drives, be aware that your drive
>  designation may
> change when you upgrade to kernel 2.6.8.1

Found the above answer. Then what's the /dev/ designation for a USB device?

Offline

#3 2006-08-05 17:13:04

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: Kernel reads sda instead of hda

My USB kit still shows up as /dev/sdX. Presumably, if the hard disk takes sda, your USB devices will start with sdb?

Offline

#4 2006-08-05 18:26:19

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,751

Re: Kernel reads sda instead of hda

sata here /dev/sda<number>

everything else b > ....

watch your udev rules ;-)


Mr Green

Offline

#5 2006-08-05 20:29:33

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: Kernel reads sda instead of hda

USB devices should be assigned as sdb,sdc, etc.
Is the disk IDE or SATA?
What usb devices want to use /dev/sda ?
Any custom udev rules for sda ?

Offline

#6 2006-08-06 17:52:45

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,751

Re: Kernel reads sda instead of hda

ok ok ...

like my sata drive shows as sda ... now why not have usb devices show as uda etc?

makes more sense

Would that be a kernel or udev thing?


Mr Green

Offline

#7 2006-08-07 11:28:15

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: Kernel reads sda instead of hda

Using udev you can change it to:
/dev/mrgreen
/dev/mryellow
/dev/mrred
... :-D
but you need to have something to distinguish between usb and non usb devices (like "BUS" or something else).

Offline

#8 2006-08-07 11:49:41

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,751

Re: Kernel reads sda instead of hda

only I use udev rule from wiki (auto mount usb devices) which is great but it clashes with my other rule/s for me mp3player....

emmm

sata = sda

usb (ports) = uda ?

seems to make more sense

/dev/mrgreen I no dev rofl  lol


Mr Green

Offline

#9 2006-08-08 17:59:40

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: Kernel reads sda instead of hda

Why don't you place mp3 player rules before the general usb aoutomount rules and use OPTIONS="last_rule" ?

And how should it work when you have external sata disk connected through usb ? :-)

From the automounting point of view the name under /dev doesn't matter at all. The only name which is important is used in /media (and/or /mnt). The problem is you have to use %k (the name of the device given by the kernel) in an udev rule because other parameters are empty when you unplug the device and the umount rules don't work.

Offline

#10 2006-08-08 19:07:22

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,751

Re: Kernel reads sda instead of hda

sata drive is internal ..... sda (like ide hda!)

Will try what you say ....

just thought to get a clear divide between the two uda etc... was a way of showing a usb device .... (ala Knoppix!)

At the moment usb connected devices show as sdb ... but of course they can be called anything even Lanrat ;-)

I was just thinking aloud again something I must stop doing lol


Mr Green

Offline

Board footer

Powered by FluxBB