You are not logged in.

#1 2019-04-12 16:42:57

poseidon
Member
Registered: 2012-06-07
Posts: 66

CUPS: Authentication required for printing document "...".

I installed Arch about a month ago on a new notebook. I installed a samba-printer using the drivers of aur/konica-minolta-bizhub-bhc360. Everything worked fine.

A few days ago I upgraded the system and now I can't print anymore. Printing looks good in the first seconds and it seems as if the dox are sent over the network. Then a dialog window pops up reading "Authentication required for printing document "..."." The dialog contains a field "negotiate" and a checkbox "Remember password". It doesn't matter what I enter into the "negotiate" text box, none seems right, neither the local user's or root's passwd, nor the passwd of the account creds' passwd I'm supplied with. The only option that makes the dialog vanish is Cancel. A look into the printer queue then shows an entry reading "Tree connect failed (NT_STATUS_ACCESS_DENIED)".

A look into /etc/cups/printer.conf tells me that "AuthInfoRequired none" has changed to "AuthInfoRequired negotiate". When I stop cups and the change that entry back to "none", start cups, the same happens again: The dialog pops up and the entry in /etc/cups/printers.conf has been overwritten and reads "AuthInfoRequired negotiate" again.

What could be wrong here? Where should I dig deeper?

Cheers
Paul

Offline

#2 2019-04-13 13:21:31

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,040

Re: CUPS: Authentication required for printing document "...".

Looks like samba was upgraded several times recently and cups also a few days.

Did you configure the printer through the cups webinterface or through some other method ?
Please post /var/log/pacman.log .

Last edited by Lone_Wolf (2019-04-13 13:21:46)


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2019-04-14 18:00:34

poseidon
Member
Registered: 2012-06-07
Posts: 66

Re: CUPS: Authentication required for printing document "...".

I did it through the web interface.

The log is rather long. Shoudl I paste into the post or is there an option to attach files?

Paul

Offline

#4 2019-04-14 18:51:03

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 2,573

Re: CUPS: Authentication required for printing document "...".

poseidon wrote:

The log is rather long. Shoudl I paste into the post or is there an option to attach files?

Use a pastebin client (not pastebin.com).

https://wiki.archlinux.org/index.php/Li … in_clients

Offline

#5 2019-04-15 14:51:17

Peg-leg
Member
Registered: 2013-06-04
Posts: 2

Re: CUPS: Authentication required for printing document "...".

I'm having the same issue.

It looks like smbspool does not support this connection string format anymore:

smb://domain\username:password@server[:port]/printer

I switch to using smbclient for printing instead of smbspool.

Offline

#6 2019-04-23 02:54:39

Cakegg
Member
Registered: 2017-04-27
Posts: 3

Re: CUPS: Authentication required for printing document "...".

Hi, @Peg-leg, I also have the same issue. I tried to use smbclient by symlinking smbclient to the cups backend with

sudo ln -sf $(which smbclient) /usr/lib/cups/backend/smb

But it still did not work ...

Could you show that how you solved this issue by switching to smbclient?

Offline

#7 2019-04-23 12:22:36

esonn
Member
From: Austria
Registered: 2015-10-01
Posts: 55

Re: CUPS: Authentication required for printing document "...".

I was having that exact problem. Stopping CUPS, manually editing /etc/cups/printers.conf, changing AuthInfoRequired negotiate to AuthInfoRequired username,password, and putting username+credentials directly in the smb:// string worked for me. (I'm on an arch box, sending print jobs to a shared networked printer within an Microsoft AD-controlled office environment).

Strangely enough, my backups from a few months ago show me, that that's the exact same config I had before anyway, before CUPS automatically changed AuthInfoRequred from username,password to negotiate all the time. I initially thought it was caused by the -Syu I did on the day the "negotiate" thing first appeared (19.4.19), but then I noticed something odd...

With the steps above, I can print without problems from e.g. evince and LibreOffice. However, as soon as I send a print job from Acroread (which I did on that day the first time in history because of a seemingly broken PDF), the same troubles start again: The "negotiate" dialog appears, and printers.conf is again changed automatically (also when printing from other programs from that point onwards), until I reset things like given above and simply don't use Acroread again.

Is it plausible that Acroread freaks out CUPS to act that way, e.g. via weird constructed lpr statements?

EDIT: One minor issue remains, don't know if related or not. Suddenly, when I print documents, a 5-digit number "00001" is printed on ea ch page of a document in the lower right corner, see here for an example (don't punish me for the code, is a student's submission...). I have no idea where this comes from.

Last edited by esonn (2019-04-23 12:36:55)


Anyone who quotes me in their sig is an idiot. -- Rusty Russell

Offline

#8 2019-04-23 14:11:56

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 16,608

Re: CUPS: Authentication required for printing document "...".

esonn wrote:

(don't punish me for the code, is a student's submission...)..

Be sure you tell them about hear vs here wink


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#9 2019-04-24 08:30:56

Cakegg
Member
Registered: 2017-04-27
Posts: 3

Re: CUPS: Authentication required for printing document "...".

esonn wrote:

I was having that exact problem. Stopping CUPS, manually editing /etc/cups/printers.conf, changing AuthInfoRequired negotiate to AuthInfoRequired username,password, and putting username+credentials directly in the smb:// string worked for me. (I'm on an arch box, sending print jobs to a shared networked printer within an Microsoft AD-controlled office environment).

Strangely enough, my backups from a few months ago show me, that that's the exact same config I had before anyway, before CUPS automatically changed AuthInfoRequred from username,password to negotiate all the time. I initially thought it was caused by the -Syu I did on the day the "negotiate" thing first appeared (19.4.19), but then I noticed something odd...

With the steps above, I can print without problems from e.g. evince and LibreOffice.

Thanks! I find that your solution works. Printing from evince works just fine.

However, other than printing from Acroread, clicking Print Test Page in the system-config-printer (v1.5.11) would always modify the printers.conf file and change AuthInfoRequired username,password to AuthInfoRequired negotiate.

Hoping someone can resolve this issue completely.

Offline

#10 2019-04-24 11:19:03

xerxes_
Member
Registered: 2018-04-29
Posts: 44

Re: CUPS: Authentication required for printing document "...".

You can change attribute of printers.conf to immutable, so it won't be overwritten (but this is just workaround, check if your file system support this (I know that ext2/3/4, btrfs and xfs support this)):

chattr +i /etc/cups/printers.conf

Last edited by xerxes_ (2019-04-24 11:21:01)

Offline

#11 2019-04-24 18:15:32

poseidon
Member
Registered: 2012-06-07
Posts: 66

Re: CUPS: Authentication required for printing document "...".

"chattr +i /etc/cups/printers.conf" doesn't do the trick. Well, it does if I print from e.g. Firefox, but not if I print from Okular: The file isn't changed, but the "negotiate dialog" appears again. Anyway, I upgraded right now (sudo pacman -Syu) and everything seems good again. I'll mark this as SOLVED within the next days, if no other experiences are posted, okay?

Offline

#12 2019-04-25 13:45:18

poseidon
Member
Registered: 2012-06-07
Posts: 66

Re: CUPS: Authentication required for printing document "...".

Nope, issue still pending: It really seems to depend on the app, which is printing: Evolution ok, LibreWriter nok :-(

Offline

#13 2019-05-02 01:36:26

dmiranda
Member
Registered: 2019-05-02
Posts: 1

Re: CUPS: Authentication required for printing document "...".

It seems to be a problem in the integration of samba and kerberos:
Seens that it's necessary to  build Samba with MIT Kerberos Support
From the release notes for the 4.10 release at https://www.samba.org/samba/history/samba-4.10.0.html, there is an interesting snippet included.

Offline

#14 2019-05-03 12:42:24

bred
Member
Registered: 2011-01-04
Posts: 44

Re: CUPS: Authentication required for printing document "...".

Cakegg wrote:
esonn wrote:

I was having that exact problem. Stopping CUPS, manually editing /etc/cups/printers.conf, changing AuthInfoRequired negotiate to AuthInfoRequired username,password, and putting username+credentials directly in the smb:// string worked for me. (I'm on an arch box, sending print jobs to a shared networked printer within an Microsoft AD-controlled office environment).

Strangely enough, my backups from a few months ago show me, that that's the exact same config I had before anyway, before CUPS automatically changed AuthInfoRequred from username,password to negotiate all the time. I initially thought it was caused by the -Syu I did on the day the "negotiate" thing first appeared (19.4.19), but then I noticed something odd...

With the steps above, I can print without problems from e.g. evince and LibreOffice.

Thanks! I find that your solution works. Printing from evince works just fine.

However, other than printing from Acroread, clicking Print Test Page in the system-config-printer (v1.5.11) would always modify the printers.conf file and change AuthInfoRequired username,password to AuthInfoRequired negotiate.

Hoping someone can resolve this issue completely.

I've the same problem:
https://bbs.archlinux.org/viewtopic.php?id=245943

I've correctly installed a printer via SMB.
The printer has always worked: With driver and SMB login.
So my configuration I assume that is correct!

But a few days ago the printer has stopped working and in CUPS I see this message:
Session setup failed: NT_STATUS_ACCESS_DENIED

I've read the wiki regarding CUPS and searched on the web but I've not found any solution!

The used driver is: Canon LBP6780/3580 PXL

Some notes:

If I list all shared printers with:
> smbclient -L printserver.example.com -U something\\myname

It works and it lists all shared printers.

Note that the username is in the form: something\myname

In the printers.conf the DeviceURI is set to this .....

DeviceURI smb://something\myname:MYpasswd@printserver.example.com/Printer_nn_33

The printer is not yet working .....

Any idea????


The solution above does not work at all for me !!!!

Last edited by bred (2019-05-03 12:44:12)

Offline

#15 2019-05-03 12:57:33

loqs
Member
Registered: 2014-03-06
Posts: 7,865

Re: CUPS: Authentication required for printing document "...".

Can you identify which package update first caused the issue?

Offline

#16 2019-05-03 12:58:03

bred
Member
Registered: 2011-01-04
Posts: 44

Re: CUPS: Authentication required for printing document "...".

In the github CUPS page I've found this:

https://github.com/apple/cups/issues/5573

It's seems to be as issue with the ArchLinux build.

Offline

#17 2019-05-03 13:12:15

ledidi
Member
Registered: 2019-05-03
Posts: 4

Re: CUPS: Authentication required for printing document "...".

dmiranda wrote:

It seems to be a problem in the integration of samba and kerberos:
Seens that it's necessary to  build Samba with MIT Kerberos Support
From the release notes for the 4.10 release at https://www.samba.org/samba/history/samba-4.10.0.html, there is an interesting snippet included.

Just registered to say: Thank you for the hint!

loqs wrote:

Can you identify which package update first caused the issue?

I downgraded smbclient, libwbclient and samba to Version 4.9.5 and it's working again cool

DOWNGRADE_FROM_ALA=1 downgrade ... 

Last edited by ledidi (2019-05-03 13:27:18)

Offline

#18 2019-05-03 13:12:27

bred
Member
Registered: 2011-01-04
Posts: 44

Re: CUPS: Authentication required for printing document "...".

loqs wrote:

Can you identify which package update first caused the issue?

No.
But the command:
> smbclient -L printserver.example.com -U something\\myname
works correctly

So I think that the problem is with cups.

Offline

#19 2019-05-03 13:49:26

bred
Member
Registered: 2011-01-04
Posts: 44

Re: CUPS: Authentication required for printing document "...".

dmiranda wrote:

....

I downgraded smbclient, libwbclient and samba to Version 4.9.5 and it's working again cool

DOWNGRADE_FROM_ALA=1 downgrade ... 

It works also for me.
Somebody must open a bug related to this issue ...

Offline

#20 2019-05-03 17:00:25

loqs
Member
Registered: 2014-03-06
Posts: 7,865

Re: CUPS: Authentication required for printing document "...".

bred wrote:

Somebody must open a bug related to this issue ...

https://bugs.archlinux.org/task/62521
Edit:
@dmiranda did you try rebuilding with --with-experimental-mit-ad-dc ?  I would not expect it to make a difference as --with-system-mitkrb5 is commented out in the PKGBUILD.

Last edited by loqs (2019-05-03 17:39:11)

Offline

#21 2019-05-05 12:36:06

ledidi
Member
Registered: 2019-05-03
Posts: 4

Re: CUPS: Authentication required for printing document "...".

loqs wrote:
bred wrote:

Somebody must open a bug related to this issue ...

https://bugs.archlinux.org/task/62521
Edit:
@dmiranda did you try rebuilding with --with-experimental-mit-ad-dc ?  I would not expect it to make a difference as --with-system-mitkrb5 is commented out in the PKGBUILD.

Rebuilding it with

--with-experimental-mit-ad-dc

and with

--with-experimental-mit-ad-dc \
--with-system-mitkrb5

doesn't seem to make any difference here. I went back to 4.9.5

For those who are interested: I used `yay -G samba` → edited PKGBUILD → `makepkg -si`

Offline

#22 2019-05-06 07:01:53

bred
Member
Registered: 2011-01-04
Posts: 44

Re: CUPS: Authentication required for printing document "...".

ledidi wrote:

For those who are interested: I used `yay -G samba` → edited PKGBUILD → `makepkg -si`

Try to edit the smbclient package (I've not tried; but CUPS uses smbclient and not samba)

Offline

#23 2019-05-06 09:09:11

ledidi
Member
Registered: 2019-05-03
Posts: 4

Re: CUPS: Authentication required for printing document "...".

bred wrote:
ledidi wrote:

For those who are interested: I used `yay -G samba` → edited PKGBUILD → `makepkg -si`

Try to edit the smbclient package (I've not tried; but CUPS uses smbclient and not samba)

Building Samba this way creates packages for samba, smbclient and libwbclient. I installed all three, so unfortunately... hmm

Offline

#24 2019-05-06 15:01:21

loqs
Member
Registered: 2014-03-06
Posts: 7,865

Re: CUPS: Authentication required for printing document "...".

Can you bisect samba between 4.9 and 4.10 to find the causal commit?
Then work with upstream to resolve the issue.

Offline

#25 2019-05-07 02:02:27

Salkay
Member
Registered: 2014-05-22
Posts: 408

Re: CUPS: Authentication required for printing document "...".

I'm also hitting this issue.

ledidi wrote:

I downgraded smbclient, libwbclient and samba to Version 4.9.5 and it's working again cool

@ledidi, was this all you did? I tried to downgrade these packages, which also included reinstalling the gamin dependency, but it's still not printing for me. FWIW I also tried reverting /etc/cups/printers.conf.

Offline

Board footer

Powered by FluxBB