You are not logged in.

#26 2019-08-16 08:38:59

Registered: 2014-09-10
Posts: 20

Re: NetworkManager cannot connect Wifi

The relevant networkmanager packages:

$ pacman -Qs networkmanager
local/libnm 1.20.0-1
    NetworkManager client library
local/libnm-glib 1.18.2-1
    NetworkManager client library (legacy)
local/libnma 1.8.22-1
    NetworkManager GUI client library
local/networkmanager 1.20.0-1 (gnome)
    Network connection manager and user applications
local/networkmanager-qt 5.60.0-1 (kf5)
    Qt wrapper for NetworkManager API
local/nm-connection-editor 1.8.22-1
    NetworkManager GUI connection editor and widgets

$ pacman -Qikk networkmanager
Name            : networkmanager
Version         : 1.20.0-1
Description     : Network connection manager and user applications
Architecture    : x86_64
URL             :
Licenses        : GPL2  LGPL2.1
Groups          : gnome
Provides        : None
Depends On      : libnm  iproute2  polkit  wpa_supplicant  libmm-glib  libnewt  libndp  libteam  curl  bluez-libs  libpsl
Optional Deps   : dnsmasq: connection sharing [installed]
                  bluez: Bluetooth support [installed]
                  ppp: dialup connection support [installed]
                  modemmanager: cellular network support [installed]
                  iwd: wpa_supplicant alternative
Required By     : networkmanager-qt
Optional For    : blueman  deepin-daemon  firefox  libproxy
Conflicts With  : None
Replaces        : None
Installed Size  : 15.05 MiB
Packager        : Jan Alexander Steffens (heftig) <>
Build Date      : Tue Aug 6 21:53:38 2019
Install Date    : Tue Aug 13 15:36:10 2019
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : SHA-256 Sum

backup file: networkmanager: /etc/NetworkManager/NetworkManager.conf (Modification time mismatch)
networkmanager: 490 total files, 0 altered files

$ cat /etc/NetworkManager/NetworkManager.conf
# Configuration file for NetworkManager.
# See "man 5 NetworkManager.conf" for details.


#27 2019-09-14 09:05:53

Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 12,111

Re: NetworkManager cannot connect Wifi

br4no originally suggested a possible solution in this topic (now split to here):

In my case I've found the solution myself. The only thing I did is that I went to my router settings and changed SSID name from "Kralicek" to "kralicek" and voila I can connect. So, in my case the SSID cannot contain (or start with) upper case letter. I have tried also completelly different names which were starting with upper case. None of them worked and it always returned the above error. Whatever SSID starting with lower case works......

Mobo: MSI MAG X570S TORPEDO MAX // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.


#28 2020-02-29 07:56:50

Registered: 2020-02-29
Posts: 1

Re: NetworkManager cannot connect Wifi

I had the same problem and i am also using Deepin DE. I found that this is because deepin intercepts NetworkManager.

When I tried to connect using nmcli before deepin starts, it connects fine.

nmcli connection up 61e0c0dd-e681-424b-89e8-bee0e9624dee

I also found that if we disable random mac address, we can also connect with deepin.
edit /etc/NetworkManager/conf.d/wifi_rand_mac.conf as follows



Board footer

Powered by FluxBB