You are not logged in.

#1 2019-10-09 09:07:44

valgio
Member
Registered: 2017-11-30
Posts: 18

[SOLVED]Arch Linux doesn't start anymore

Hi every one!
I did a mess and my istallation of arch linux stops during boot.

Let me explain what i did.

I wanted to install pytorch so i followed this guide

https://medium.com/@k_efth/deep-learnin … 873c2252ed

but just the second part about set up for pytorch. I installed arch linux a years ago following official guide on arch wiki and everything went fine.
so I followed the guide. Now i dont know what is the problem but I  think it could be about modification on grub config file and mkinicpio.conf:

To enable add the nvidia-drm.modeset=1 kernel parameter in etc/defaults/grub, and add nvidia, nvidia_modeset, nvidia_uvm and nvidia_drm to your initramfs in /etc/mkinicpio.conf. The following will update grub, initramfs and also configure Xorg.

I modified the files according to the guide and i ran that script

# grub-mkconfig -o /boot/grub/grub.cfg
# mkinitcpio -p linux
# nvidia-xconfig

Nothing bad until here. But when I restarted the system it stunned.
Now I have arch linux in dual boot with windows so when I boot the system grub starts fine. I select Arch Linux from menu and it starts booting the system but this phase doesn't come to an end.

What I tried:

I get my USB with arch iso
I entered in live session
I mounted the partition with all my files in /mnt
I switched to arch-chroot /mnt
I cleaned the previously modified files
I ran

mkinitcpio -P

But nothing worked.

I'm here to ask you how can i solve this problem. If you have any hints or suggestions I'll be glad.
For any other information ask me. I'll be here

Thank you all

Last edited by valgio (2019-10-10 22:14:55)

Offline

#2 2019-10-09 09:17:11

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,562

Re: [SOLVED]Arch Linux doesn't start anymore

Post a

journalctl -b

and a xorg log from the chroot after an unsuccessful boot: https://wiki.archlinux.org/index.php/Li … in_clients What actual hardware is this? Check if you can boot into a terminal with

systemd.unit=multi-user.target

kernel parameter.

Also you should revert literally everything from that guide, all of these packages - including optimized tensorflow builds - exist in the normal repositories, just install them instead of breaking your system with global conda installations. if you have a lingering /etc/X11/xorg.conf from the nvidia-xconfig invocation remove it.

Last edited by V1del (2019-10-09 09:18:22)

Offline

#3 2019-10-09 16:59:33

valgio
Member
Registered: 2017-11-30
Posts: 18

Re: [SOLVED]Arch Linux doesn't start anymore

First of all thank for the replay

It's important to specify that i didn't do the entire guide. I didn't install conda

I found out a similar topic:

https://bbs.archlinux.org/viewtopic.php?id=239041

I read it all but rename xorg.conf not works.

This is my logs:

 cat /var/log/xorg0.log | grep EE 

http://ix.io/1Y9F

journalctl -r -b -p 5 --since="2 minutes ago"

http://ix.io/1Y9K

This is my xorg.conf file

http://ix.io/1Utd

Offline

#4 2019-10-09 17:12:56

loqs
Member
Registered: 2014-03-06
Posts: 8,733

Re: [SOLVED]Arch Linux doesn't start anymore

Please do not post filtered logs that remove all context https://bbs.archlinux.org/viewtopic.php?id=57855
Edit:
Also what is the output of

lspci | grep -e VGA -e 3D

Last edited by loqs (2019-10-09 17:28:58)

Online

#5 2019-10-10 11:27:21

valgio
Member
Registered: 2017-11-30
Posts: 18

Re: [SOLVED]Arch Linux doesn't start anymore

Hi guys

Well, I found out that deleting the file /etc/X11/xorg.conf something change.
when I execute sddm the screen turns black

These are the logs (not filtered) after sddm execution

Journalctl

http://ix.io/1YdZ

Xorg.0.log

http://ix.io/1Ye2

Offline

#6 2019-10-10 12:06:20

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,562

Re: [SOLVED]Arch Linux doesn't start anymore

You have an optimus system see: https://wiki.archlinux.org/index.php/NVIDIA_Optimus for configuration options.

Offline

#7 2019-10-10 16:14:35

valgio
Member
Registered: 2017-11-30
Posts: 18

Re: [SOLVED]Arch Linux doesn't start anymore

Ok I followed the guide to set Nvidia optimus works with sddm but it doesnt solve my problem

sddm.log after black screen

http://ix.io/1Yf0

this is my journalctl

http://ix.io/1Yf1

this is my xorg.0.log

http://ix.io/1Yf2

this is my xorg.conf

http://ix.io/1Yf5

Of i execute startkde it says: $DISPLAY is not set or cannot connect to the X server

Of i log as user and i run startkde i get the same message. If i do

 export DISPLAY=:0.0

I get a differen error

Invalid MIT-MAGIC-COOKIE-1 key

Last edited by valgio (2019-10-10 17:14:52)

Offline

#8 2019-10-10 18:37:30

loqs
Member
Registered: 2014-03-06
Posts: 8,733

Re: [SOLVED]Arch Linux doesn't start anymore

valgio wrote:

Ok I followed the guide to set Nvidia optimus works with sddm but it doesnt solve my problem

Why is the xorg.conf you posted generated by nvidia-xconfig instead of following the instructions from https://wiki.archlinux.org/index.php/NVIDIA_Optimus?

Online

#9 2019-10-10 22:14:20

valgio
Member
Registered: 2017-11-30
Posts: 18

Re: [SOLVED]Arch Linux doesn't start anymore

I solved my problem. Thank you all!!

I had xorg.conf cause I'm very newbie (Thats why I'm in this section) and I misunderstood these lines of the guide:

First, install the NVIDIA driver and xorg-xrandr. Then, configure xorg.conf. You will need to know the PCI address of the NVIDIA card, which you can find by issuing...

Reading them I thought to rebuild the file. My bad!

Thank again

Offline

Board footer

Powered by FluxBB