You are not logged in.

#251 2019-11-01 03:42:47

gee
Member
Registered: 2006-11-29
Posts: 300

Re: mesa-git - latest videodrivers & issues

Well that comes with using dev packages.
Best to bisect it and post it on fdo's bug tracker.
Using Vulkan with ACO would at least tell you if it's related to LLVM or not, and so that'd be one less package to build.

Last edited by gee (2019-11-01 03:44:20)

Offline

#252 2019-11-01 10:49:55

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,637

Re: mesa-git - latest videodrivers & issues

MaddyBoo, my aur mesa-git allows selection of several llvm variants to build against.
The default is to use extra llvm/clang , you could use it to see whether llvm-git is causing the error.


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#253 2019-11-01 20:02:43

raneon
Member
Registered: 2013-11-02
Posts: 49

Re: mesa-git - latest videodrivers & issues

I had some audio issues too, in my case no audio at all, but only in very few games...

@Lone_Wolf: I wonder is there any plan to enable and build Zink in the future?

Offline

#254 2019-11-02 10:43:37

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,637

Re: mesa-git - latest videodrivers & issues

https://aur.archlinux.org/cgit/aur.git/ … 0d01370810

Aur mesa-git has zink since 29 october.
I tried to add it to aur lib32-mesa-git  also, but there glxinfo32 crashes immediately.
No idea when I'll have time to look into it.


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#255 2019-11-14 21:39:16

raneon
Member
Registered: 2013-11-02
Posts: 49

Re: mesa-git - latest videodrivers & issues

Just did an update to the latest mesa-git+testing packages and OpenGL seems to be broken on Plasma Wayland and Plasma X11.

Offline

#256 2019-11-15 03:34:44

gee
Member
Registered: 2006-11-29
Posts: 300

Re: mesa-git - latest videodrivers & issues

That's probably because mesa-git was not updated (built?) but all other packages were.

Offline

#257 2019-11-16 19:29:34

gee
Member
Registered: 2006-11-29
Posts: 300

Re: mesa-git - latest videodrivers & issues

@lordheavy Thanks for the quick fix!
I'd like to suggest making the various mesa packages depend on the exact llvm packages they were built with, I think it would save people some trouble in situations like these. It makes sense to not do that in the AUR where there is a choice of llvm, but in your repo I don't see much of a benefit of not making that link mandatory.

Offline

#258 2019-12-12 00:59:29

gee
Member
Registered: 2006-11-29
Posts: 300

Re: mesa-git - latest videodrivers & issues

Hello,

has there been a change to the mesa-git repo? The URL I'm used to hasn't been updated in about a month, but with the change of servers maybe I should change the url for this?

Thank you!

Offline

#259 2019-12-13 04:29:11

Ashraaf
Member
From: Bangi, Malaysia
Registered: 2019-05-30
Posts: 5

Re: mesa-git - latest videodrivers & issues

@gee The repo didn't updated for almost a month already, https://pkgbuild.com/~lcarlier/mesa-git/x86_64/

You may want to try another unofficial repo, chaotic-aur which provide Lone_Wolf's mesa-git built using llvm-minimal-git and also have mesa-aco-git, you can check the list of package here https://lonewolf.pedrohlc.com/chaotic-a … 4/?C=M;O=D

Offline

#260 2019-12-13 06:33:06

gee
Member
Registered: 2006-11-29
Posts: 300

Re: mesa-git - latest videodrivers & issues

I know of chaotic's repo, but I kind of like using lordheavy's since he's also a maintainer of the official packages in Arch and is active on the Mesa bugtracker. It also is a repo with very few things so I don't have to ignore many packages, like I do with archlinuxcn right now.
But yeah maybe I'll wait a couple days to see if there's a reply here and then do that till LordHeavy fixes it.

Thank you!

Last edited by gee (2019-12-14 17:46:13)

Offline

#261 2019-12-14 10:43:55

raneon
Member
Registered: 2013-11-02
Posts: 49

Re: mesa-git - latest videodrivers & issues

Ashraaf wrote:

@gee The repo didn't updated for almost a month already, https://pkgbuild.com/~lcarlier/mesa-git/x86_64/

You may want to try another unofficial repo, chaotic-aur which provide Lone_Wolf's mesa-git built using llvm-minimal-git and also have mesa-aco-git, you can check the list of package here https://lonewolf.pedrohlc.com/chaotic-a … 4/?C=M;O=D

Thanks, for now I've switched to chaotic-aur. I guess that mesa-aco-git is obsolete and mesa-git should be enough.

Offline

#262 2019-12-14 12:37:16

Ashraaf
Member
From: Bangi, Malaysia
Registered: 2019-05-30
Posts: 5

Re: mesa-git - latest videodrivers & issues

@raneon yep, just dont forget to use RADV_PERFTEST=aco environment variable to enable RADV's ACO shader compiler as its not enabled by default on mesa-git.

Offline

#263 2019-12-16 20:07:58

gee
Member
Registered: 2006-11-29
Posts: 300

Re: mesa-git - latest videodrivers & issues

So I finally looked into using chaotic-aur for mesa, but it seems its llvm-git won't allow me to keep the standard stable llvm installed as well, which is no good since many packages depend on it hmm

Offline

#264 2019-12-16 22:20:24

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,637

Re: mesa-git - latest videodrivers & issues

gee wrote:

So I finally looked into using chaotic-aur for mesa, but it seems its llvm-git won't allow me to keep the standard stable llvm installed as well, which is no good since many packages depend on it hmm

Aur llvm-git is intended as a full development environment that completely replaces stable llvm/clang.
The conflict is intentional.

Look at the PKGBUILD for aur mesa-git and you'll see it allows building against 4 different llvm variants.
The one I normally use and also the one used to build mesa-git in chaotic-aur is llvm-minimal-git .
llvm-libs-minimal-git does coexist with stable llvm-libs.

just remove the mesa-git & llvm-git versions you got from from  LordHeavy' repo, and install mesa-git from chaotic-aur (it will pull in llvm-libs-minimal-git ).

Last edited by Lone_Wolf (2019-12-16 22:22:10)


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#265 2019-12-16 23:34:28

gee
Member
Registered: 2006-11-29
Posts: 300

Re: mesa-git - latest videodrivers & issues

Lone_Wolf wrote:
gee wrote:

So I finally looked into using chaotic-aur for mesa, but it seems its llvm-git won't allow me to keep the standard stable llvm installed as well, which is no good since many packages depend on it hmm

Aur llvm-git is intended as a full development environment that completely replaces stable llvm/clang.
The conflict is intentional.

Look at the PKGBUILD for aur mesa-git and you'll see it allows building against 4 different llvm variants.
The one I normally use and also the one used to build mesa-git in chaotic-aur is llvm-minimal-git .
llvm-libs-minimal-git does coexist with stable llvm-libs.

just remove the mesa-git & llvm-git versions you got from from  LordHeavy' repo, and install mesa-git from chaotic-aur (it will pull in llvm-libs-minimal-git ).

Hmmm,

I had tried something kind of like that but it did not work:

pacman -S chaotic-aur/lib32-llvm-minimal-git chaotic-aur/llvm-minimal-git
resolving dependencies...
looking for conflicting packages...
:: lib32-llvm-minimal-git and lib32-llvm-git are in conflict (lib32-llvm). Remove lib32-llvm-git? [y/N] y
:: llvm-minimal-git and llvm-git are in conflict (llvm). Remove llvm-git? [y/N] y
:: llvm-minimal-git and compiler-rt are in conflict. Remove compiler-rt? [y/N] y
:: llvm-minimal-git and clang are in conflict. Remove clang? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing clang breaks dependency 'clang' required by ccls
:: removing clang breaks dependency 'clang' required by clazy
:: removing clang breaks dependency 'clang=9.0.0' required by kdevelop
:: removing clang breaks dependency 'clang' required by lldb
:: removing clang breaks dependency 'clang=9.0.0' required by qtcreator

Are you sure llvm-minimal-git is supposed to allow me to keep all stable packages?

Thank you for the quick reply!

edit: actually maybe I don't need llvm-git, just the libs-git and that maybe would work as you suggested.

edit2: yup that works fine, sorry for the stupid question!

Last edited by gee (2019-12-16 23:47:43)

Offline

#266 2019-12-18 20:05:25

lordheavy
Developer
From: France
Registered: 2010-04-01
Posts: 287

Re: mesa-git - latest videodrivers & issues

Some news from the unofficial mesa-git repo.

As you noticed previously, mesa-git hadn't been update for a long time (mostly a month).
Packages were built on an Arch server with a developer homemade tool which is now broken because of the new server architecture.

After waiting for this to be fixed, i decided to create my own tool and sadly i don't have too many spare time for this, so it was a bit long! But now i have a basic tool that is enough to built llvm-git and mesa-git, and now these have been updated.
With this new tool repository should not be in a broken state anymore, because it allows me to deal with dependencies (no more updated llvm without updated mesa or without its multilib part) .

Sorry for the delay, for the lack of news and for grammar/apelling mistakes smile

Offline

#267 2019-12-18 20:44:11

gee
Member
Registered: 2006-11-29
Posts: 300

Re: mesa-git - latest videodrivers & issues

Awesome news!

I'm happy that now you won't offer unsynced packages too smile

I could be wrong since I had uninstalled it when I switched to chaotic's, but it seems your llvm-git is now incompatible with lldb, and I don't think it was before.

Thank you for all your work!

Offline

#268 2019-12-19 11:01:25

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,637

Re: mesa-git - latest videodrivers & issues

Glad to hear your mesa-git repo is back, LordHeavy

I intend to use the first post in this thread as the start for a mesa-git & llvm-git wiki page (probably 2 separate pages) to reflect the current situation .
The info is scattered through forum , wiki and aur comments .

Last edited by Lone_Wolf (2019-12-19 11:01:40)


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#269 2019-12-21 16:49:43

raneon
Member
Registered: 2013-11-02
Posts: 49

Re: mesa-git - latest videodrivers & issues

Good to read that mesa-git is getting updated again :-)

I've tried to use chaotic-aur, but overall there are some issues with llvm. If I use the proposed llvm-libs-minimal-git packages, then GPU accelerated Steam and Falkon do not work without extreme graphical glitches, some Feral launchers (OpenGL) are broken as well. If I enforce to update/overwrite llvm-libs 9 with git, then Falkon works, some Feral launcher work now, but Steam doesn't start anymore. Not sure what exactly is broken in this setup, but I'm glad I don't need to investigate further as I can switch back to mesa-git.

Edit: Ok, now I have the same issue with Mesa-git, seems like llvm is a little broken again :-(

Last edited by raneon (2019-12-21 17:09:14)

Offline

#270 2019-12-22 01:34:17

gee
Member
Registered: 2006-11-29
Posts: 300

Re: mesa-git - latest videodrivers & issues

That's why I'm stuck on llvm-libs-minimal-git 10.0.0_r334027.3b9715cb219-1 the next versions are bugged.

Offline

#271 2019-12-22 09:24:47

raneon
Member
Registered: 2013-11-02
Posts: 49

Re: mesa-git - latest videodrivers & issues

gee wrote:

That's why I'm stuck on llvm-libs-minimal-git 10.0.0_r334027.3b9715cb219-1 the next versions are bugged.

Good to know you have the same issue :-) Interestingly when downgrade do stable mesa but keeping llvm-libs-git I don't have these graphical glitches.

Last edited by raneon (2019-12-22 09:25:02)

Offline

#272 2019-12-22 12:06:12

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,637

Re: mesa-git - latest videodrivers & issues

That's because stable mesa uses llvm-libs from stable exclusively .

If you build my aur mesa-git without setting MESA_WHICH_LLVM it will default to building mesa-git against llvm stable .
That would help to verify if the issues are in mesa trunk or llvm trunk .


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#273 2019-12-31 17:09:41

lordheavy
Developer
From: France
Registered: 2010-04-01
Posts: 287

Re: mesa-git - latest videodrivers & issues

I have built mesa-git with llvm-9.x, please test. If it's stable, i will build it that way for some times.

Offline

#274 Yesterday 14:47:00

HanFox
Member
Registered: 2015-06-09
Posts: 9

Re: mesa-git - latest videodrivers & issues

lordheavy wrote:

I have built mesa-git with llvm-9.x, please test. If it's stable, i will build it that way for some times.

Did you give up on LLVM 9 already? I see that (lib32-)mesa-git and (lib32-)vulkan-radeon-git are back to wanting LLVM 11.

Offline

#275 Yesterday 15:31:53

lordheavy
Developer
From: France
Registered: 2010-04-01
Posts: 287

Re: mesa-git - latest videodrivers & issues

HanFox wrote:
lordheavy wrote:

I have built mesa-git with llvm-9.x, please test. If it's stable, i will build it that way for some times.

Did you give up on LLVM 9 already? I see that (lib32-)mesa-git and (lib32-)vulkan-radeon-git are back to wanting LLVM 11.

Yes, it's built against llvm-git again for some times now.

Offline

Board footer

Powered by FluxBB