You are not logged in.

#1 2020-03-03 23:31:19

Anonymous2020
Member
Registered: 2020-03-03
Posts: 18

[SOLVED]Troubles with wifi connection during installation on a laptop

I was following the Installation guide and stuck at Connect to the internet part. The laptop is asus ux333 and is supposed to work fine with arch and according to this page this page my wifi device is supported too. So what I was doing:

ip link

gives

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN mode DEFAULT group default qlen 1000
    link/ether d8:f2:ca:e8:6a:07 brd ff:ff:ff:ff:ff:ff

than

 ip link set wlan0 up 

gives nothing but the outcome of ip link does not change either.

 dmesg | grep iwlwifi 

gives a lot of info like Failed to start INIT ucode: -5 Firmware not running - cannot dump error etc. It also says that the adapter is Intel Dual Band Wireless AC 9560, REV=0x318, though it says Microcode SW error detected.

Last edited by Anonymous2020 (2020-03-05 11:02:15)

Offline

#2 2020-03-04 00:08:21

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 3,840

Re: [SOLVED]Troubles with wifi connection during installation on a laptop

retardedfuck wrote:
 ip link set wlan0 up 

gives nothing but the outcome of ip link does not change either.

What do you expect to happen? Your interface is already up.

 dmesg | grep iwlwifi 

gives a lot of info like Failed to start INIT ucode: -5 Firmware not running - cannot dump error etc. It also says that the adapter is Intel Dual Band Wireless AC 9560, REV=0x318, though it says Microcode SW error detected.

Have you actually install the linux-firmware package yet?

https://bbs.archlinux.org/viewtopic.php?id=57855


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#3 2020-03-04 00:13:21

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,611

Re: [SOLVED]Troubles with wifi connection during installation on a laptop

Setting the interface up is only a small part of making the connection, and is usually taken care of by whatever you use to configure the network. netctl (including wifi-menu) is what's included on the ISO if you want a full configuration suite, otherwise wpa_supplicant, iwd, and dhcpcd are all included if you want something more manual.

Last edited by Scimmia (2020-03-04 00:15:02)

Offline

#4 2020-03-04 02:40:10

fukawi2
Administrator
From: .vic.au
Registered: 2007-09-28
Posts: 5,902
Website

Re: [SOLVED]Troubles with wifi connection during installation on a laptop

retardedfuck wrote:

I was following the Installation guide and stuck at Connect to the internet part.

What instructions exactly have you tried so far to get your network connected?

Offline

#5 2020-03-05 11:01:46

Anonymous2020
Member
Registered: 2020-03-03
Posts: 18

Re: [SOLVED]Troubles with wifi connection during installation on a laptop

Thanks for replies, the problem was that I could not connect to wifi (via wifi-menu), but after I have rewritten the .iso on USB from which I boot arch it is working now.

Offline

Board footer

Powered by FluxBB