You are not logged in.

#1 2020-03-26 14:21:41

Kotrfa
Member
Registered: 2012-10-25
Posts: 175

Wifi connection lost and can't reinitialize

Hi,

I am having troubles with an unstable connection on my laptop. I can't find anything weird in the logs (see the gist below) - it just gets into a weird loop and can't reconnect again. Sometimes it works fine for hours, sometimes I have to restart netctl-auto (via `sudo systemctl restart netctl-auto@wlp4s0.service;sudo rfkill unblock wifi`), which helps. I can see it's only my device, are three other people on the same network are doing just fine.

The logs are here: https://gist.github.com/hnykda/6f0f79c1 … 2a32f3503f

Any idea where I can look? There is nothing recorded in the router log (although it's pretty low detailed). Anything else I can provide to help me to debug it?

Thank you a lot!

Last edited by Kotrfa (2020-03-26 14:24:49)

Offline

#2 2020-03-26 14:57:39

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 5,209
Website

Re: Wifi connection lost and can't reinitialize

How are you connecting? EDIT: sorry, you say you're using netctl. Have you checked for conflicting network services?

systemctl list-unit-files --state=enabled

The log shows dhcpcd flailing around trying to get a lease, have you tried static IP addresses?

You should probably provide information about the hardware itself, for example:

lspci -knn | grep -A2 Network

See the troubleshooting section on the "Network Configuration/Wireless" ArchWiki page, it has advice pertaining to various types of card.

Last edited by Head_on_a_Stick (2020-03-26 14:58:25)

Offline

#3 2020-03-26 15:34:51

Kotrfa
Member
Registered: 2012-10-25
Posts: 175

Re: Wifi connection lost and can't reinitialize

Thanks! I have a reserved address in the router for my MAC. I will now also try to set static address in my netctl profile and see what it does, report back if it solves the issues. Thank you for now.

Offline

Board footer

Powered by FluxBB