You are not logged in.

#1 2020-03-26 14:21:41

Kotrfa
Member
Registered: 2012-10-25
Posts: 178

Wifi connection lost and can't reinitialize

Hi,

I am having troubles with an unstable connection on my laptop. I can't find anything weird in the logs (see the gist below) - it just gets into a weird loop and can't reconnect again. Sometimes it works fine for hours, sometimes I have to restart netctl-auto (via `sudo systemctl restart netctl-auto@wlp4s0.service;sudo rfkill unblock wifi`), which helps. I can see it's only my device, are three other people on the same network are doing just fine.

The logs are here: https://gist.github.com/hnykda/6f0f79c1 … 2a32f3503f

Any idea where I can look? There is nothing recorded in the router log (although it's pretty low detailed). Anything else I can provide to help me to debug it?

Thank you a lot!

Last edited by Kotrfa (2020-03-26 14:24:49)

Offline

#2 2020-03-26 14:57:39

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 5,220
Website

Re: Wifi connection lost and can't reinitialize

How are you connecting? EDIT: sorry, you say you're using netctl. Have you checked for conflicting network services?

systemctl list-unit-files --state=enabled

The log shows dhcpcd flailing around trying to get a lease, have you tried static IP addresses?

You should probably provide information about the hardware itself, for example:

lspci -knn | grep -A2 Network

See the troubleshooting section on the "Network Configuration/Wireless" ArchWiki page, it has advice pertaining to various types of card.

Last edited by Head_on_a_Stick (2020-03-26 14:58:25)

Offline

#3 2020-03-26 15:34:51

Kotrfa
Member
Registered: 2012-10-25
Posts: 178

Re: Wifi connection lost and can't reinitialize

Thanks! I have a reserved address in the router for my MAC. I will now also try to set static address in my netctl profile and see what it does, report back if it solves the issues. Thank you for now.

Offline

#4 Yesterday 08:52:30

Kotrfa
Member
Registered: 2012-10-25
Posts: 178

Re: Wifi connection lost and can't reinitialize

> The log shows dhcpcd flailing around trying to get a lease, have you tried static IP addresses?


So I setup a static address via netctl but the problem stills persists. Here are the recent logs: https://gist.github.com/hnykda/3562d924 … 2a0e1e47f0 .


> How are you connecting? EDIT: sorry, you say you're using netctl. Have you checked for conflicting network services?
I don't have anything else but netctl to keep stuff simple.


$ systemctl list-unit-files --state=enabled

   1   │ UNIT FILE                 STATE  
   2   │ autovt@.service           enabled
   3   │ dhcpcd.service            enabled
   4   │ earlyoom.service          enabled
   5   │ getty@.service            enabled
   6   │ lm_sensors.service        enabled
   7   │ systemd-timesyncd.service enabled
   8   │ tlp.service               enabled
   9   │ remote-fs.target          enabled
  10   │ paccache.timer            enabled
  11   │ 
  12   │ 9 unit files listed.
───────┴──────────────────────────────────────

$ lspci -knn | grep -A2 Network
04:00.0 Network controller [0280]: Intel Corporation Wireless 8260 [8086:24f3] (rev 3a)
	Subsystem: Intel Corporation Wireless 8260 [8086:0130]
	Kernel driver in use: iwlwifi

I am now trying to disable ipv6 in dhcpcd as recommended here:

* https://bugs.archlinux.org/task/58457
* https://forum.manjaro.org/t/cannot-conn … rk/48326/3

Next thing will be too disabling 5G or 2.4G and see if it makes difference.

Related:
* https://bugzilla.kernel.org/show_bug.cgi?id=203709

Offline

#5 Yesterday 14:27:16

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 5,220
Website

Re: Wifi connection lost and can't reinitialize

See also https://wiki.archlinux.org/index.php/Ne … ss#iwlwifi (as I suggested earlier).

Offline

#6 Today 15:28:08

Kotrfa
Member
Registered: 2012-10-25
Posts: 178

Re: Wifi connection lost and can't reinitialize

I found out that the problem exists only on my 5GHz network. Any hints in that direction (none of the possible resolutions mentions 5GHz as a cause)?

I have exactly the same setting in my netctl profiles:

Description='Automatically generated profile by wifi-menu'
Interface=wlp4s0
Connection=wireless
Security=wpa
ESSID=interbrigada-ff-5G  # or no 5G when on 2GHz in a second profile
IP=static
Address=('192.168.0.52')
Gateway='192.168.0.1'
DNS=('192.168.0.1')
Key=***

Last edited by Kotrfa (Today 15:29:28)

Offline

#7 Today 16:33:20

seth
Member
Registered: 2012-09-03
Posts: 14,052

Re: Wifi connection lost and can't reinitialize

If you're using netctl, you should first and foremost stop and disable the dhcpcd.service

Offline

#8 Today 19:11:45

Kotrfa
Member
Registered: 2012-10-25
Posts: 178

Re: Wifi connection lost and can't reinitialize

Like, entirely? Does netctl-auto manage it by itself? Or would I have to setup a static URL on every site I login?

Or should I just do https://wiki.archlinux.org/index.php/Ne … HCP_client after disabling dhcpcd? thank you!

Offline

#9 Today 20:12:05

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 5,220
Website

Re: Wifi connection lost and can't reinitialize

Kotrfa wrote:

Does netctl-auto manage it by itself?

Yes, netctl should start dhcpcd independently. If you also have dhcpcd.service enabled then they will conflict.

Offline

#10 Today 20:12:38

seth
Member
Registered: 2012-09-03
Posts: 14,052

Re: Wifi connection lost and can't reinitialize

netctl invokes dhcpcd by default (unless oc. you configure a static IP for the NIC)
If you run the dhcpcd.service on top, they will suffer from the threetwo-stooges-syndrome

Edit: blast.

Last edited by seth (Today 20:12:55)

Offline

Board footer

Powered by FluxBB