You are not logged in.

#1 2020-07-23 05:19:15

Ehesh
Member
Registered: 2014-02-18
Posts: 6

Issues installing pamac

I tried following this guide to install pamac but after it was supposed to complete I couldn't find it. Then I watched this other video thinking that maybe I was following an outdated guide but it seems the same.

As far as u can tell yay was installed correctly without any issues and so was pamac.

Offline

#2 2020-07-23 05:31:38

TheSaint
Member
From: my computer
Registered: 2007-08-19
Posts: 1,507

Re: Issues installing pamac

I'd suggest to avoid follow videos, many times they aren't maintained and falling into obsolete status. Wiki is always the first to be consulted.
If you installed with pacman packaging the you will have the option to get the list of the files by

$ pacman -Ql pamac

Then you may find the executable located usually in /usr/bin.
Furthermore you may check the pacman.log to see what happened to your installation.

$ less /var/log/pacman.log

Press up or down to scroll the text and q to exit

Last edited by TheSaint (2020-07-23 05:32:52)


do it good first, it will be faster than do it twice the saint wink

Offline

#3 2020-07-23 07:54:34

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,875
Website

Re: Issues installing pamac

Learn how to use the AUR properly before you start relying on AUR helpers.

https://wiki.archlinux.org/index.php/Ar … Repository
https://wiki.archlinux.org/index.php/Makepkg

If you still can't build and install AUR packages, then post the exact steps you ran, as well as the output.

Mod note:moving to AUR Issues


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#4 2020-07-23 15:02:26

Ehesh
Member
Registered: 2014-02-18
Posts: 6

Re: Issues installing pamac

Hi, Thanks for replying.

$ pacman -Ql pamac

When entering this I got:

error: package 'pamac' was not found
TheSaint wrote:

Then you may find the executable located usually in /usr/bin.

I did not find any executable here. I believe that it was not installed at all.

The exact steps I ran were:

pacman -S --needed base-devel git wget yajl

cd /tmp

git clone https://aur.archlinux.org/yay.git

cd yay

makepkg -si

yay -S pacman-aur

Last edited by Ehesh (2020-07-23 15:17:53)

Offline

#5 2020-07-23 15:20:45

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 23,945
Website

Re: Issues installing pamac

WTF?!  You are trying to install one AUR helper just so you can use it to install another AUR helper?  And in trying to install that other aur-helper you made up a name for it that doesn't exist: what is "pacman-aur"??

Again:

WorMzy wrote:

Learn how to use the AUR properly before you start relying on AUR helpers.

And when you use the AUR properly, if something goes wrong, post complete commands and output.

Last edited by Trilby (2020-07-23 15:21:24)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#6 2020-07-23 16:49:11

Ehesh
Member
Registered: 2014-02-18
Posts: 6

Re: Issues installing pamac

So this is the 4th time I read the wiki on Arch User Repository. As I am understanding, instead of what I did, I needed to clone the https://aur.archlinux.org/pamac-aur.git and then

makepkg

. was this correct?

Offline

#7 2020-07-23 17:01:28

loqs
Member
Registered: 2014-03-06
Posts: 11,242

Re: Issues installing pamac

Offline

#8 2020-07-23 17:32:49

Ehesh
Member
Registered: 2014-02-18
Posts: 6

Re: Issues installing pamac

There is a pamac.install file in there, but it seems ok I dont think there is any issue. but when I run makepkg -si it aborts at the end

Offline

#9 2020-07-23 17:43:45

TheSaint
Member
From: my computer
Registered: 2007-08-19
Posts: 1,507

Re: Issues installing pamac

Probably the if you show what that output writes then we may give you more detailed answer.


do it good first, it will be faster than do it twice the saint wink

Offline

#10 2020-07-23 18:35:51

Ehesh
Member
Registered: 2014-02-18
Posts: 6

Re: Issues installing pamac

Sure, thanks!


    pamac-aur   git:(master) makepkg -si
==> Making package: pamac-aur 9.5.6-1 (Thu 23 Jul 2020 11:31:26 AM MST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found pamac-9.5.6-1.tar.gz
==> Validating source files with sha256sums...
    pamac-9.5.6-1.tar.gz ... Passed
==> Extracting sources...
  -> Extracting pamac-9.5.6-1.tar.gz with bsdtar
==> Starting prepare()...
==> Removing existing $pkgdir/ directory...
==> Starting build()...
Directory already configured.

Just run your build command (e.g. ninja) and Meson will regenerate as necessary.
If ninja fails, run "ninja reconfigure" or "meson --reconfigure"
to force Meson to regenerate.

If build failures persist, run "meson setup --wipe" to rebuild from scratch
using the same options as passed when configuring the build.
To change option values, run "meson configure" instead.
[1/64] Compiling Vala source ../src/alp...nfig.vala ../src/outdated_checker.vala.
FAILED: src/25a6634@@outdated-checker@exe/alpm_config.c src/25a6634@@outdated-checker@exe/outdated_checker.c 
valac -C --pkg posix --pkg posix --pkg gio-2.0 --pkg libalpm --pkg gobject-2.0 --color=always --directory src/25a6634@@outdated-checker@exe --basedir ../src --pkg=posix --target-glib=2.38 --vapidir=/home/ehesh/builds/pamac-aur/src/pamac-ba16075d617e3bfe356b28da03a3343f5f3d993c/vapi ../src/alpm_config.vala ../src/outdated_checker.vala
../src/outdated_checker.vala:33.7-33.20: error: The name `try_parse' does not exist in the context of `uint'
		if (uint.try_parse (args[1], out nb)) {
		    ^^^^^^^^^^^^^^
Compilation failed: 1 error(s), 0 warning(s)
[2/64] Compiling Vala source ../src/ver..._config_daemon.vala ../src/daemon.vala.
../src/alpm_package.vala:51.3-51.26: warning: method `Pamac.AlpmPackage.dup' never used
		internal AlpmPackage dup () {
		^^^^^^^^^^^^^^^^^^^^^^^^
../src/alpm_utils.vala:894.3-894.33: warning: method `Pamac.AlpmUtils.trans_check_prepare' never used
		public bool trans_check_prepare (bool sysupgrade,
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Compilation succeeded - 2 warning(s)
[3/64] Compiling Vala source ../src/pac...ce_daemon.vala ../src/transaction.vala.
../src/alpm_config.vala:350.2-350.18: warning: method `AlpmConfig.write' never used
	public void write (HashTable<string,Variant> new_conf) {
	^^^^^^^^^^^^^^^^^
../src/database.vala:2893.1-2893.27: warning: method `pkg_search_name' never used
private int pkg_search_name (Pamac.Package pkg, string name) {
^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/alpm_utils.vala:654.3-654.28: warning: method `Pamac.AlpmUtils.download_pkg' never used
		public string download_pkg (string sender, string url) {
		^^^^^^^^^^^^^^^^^^^^^^^^^^
Compilation succeeded - 3 warning(s)
ninja: build stopped: subcommand failed.
==> ERROR: A failure occurred in build().
    Aborting...

Offline

#11 2020-07-23 18:51:40

loqs
Member
Registered: 2014-03-06
Posts: 11,242

Re: Issues installing pamac

pacman -Qi vala

Offline

#12 2020-07-23 19:37:04

Ehesh
Member
Registered: 2014-02-18
Posts: 6

Re: Issues installing pamac

loqs wrote:
pacman -Qi vala

This came out

Name            : vala
Version         : 0.46.6-1
Description     : Compiler for the GObject type system
Architecture    : x86_64
URL             : https://wiki.gnome.org/Projects/Vala
Licenses        : LGPL
Groups          : None
Provides        : valadoc  libvala-0.46.so=0-64  libvaladoc-0.46.so=0-64
Depends On      : glib2  gtk-doc  graphviz  ttf-font  pkg-config  gcc
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : valadoc
Replaces        : valadoc
Installed Size  : 12.90 MiB
Packager        : Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
Build Date      : Sun 09 Feb 2020 12:38:13 PM MST
Install Date    : Thu 23 Jul 2020 09:41:09 AM MST
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

Last edited by Ehesh (2020-07-23 19:37:54)

Offline

#13 2020-07-23 19:40:38

loqs
Member
Registered: 2014-03-06
Posts: 11,242

Re: Issues installing pamac

vala in the repositories is version 0.48.7-1.

https://bbs.archlinux.org/viewtopic.php?id=130309
IF YOUR SYSTEM IS NOT UP TO DATE - YOU ARE DOING IT WRONG. PACMAN -Syu *BEFORE* POSTING

Offline

Board footer

Powered by FluxBB