You are not logged in.

#1 2012-05-18 05:39:26

Paanini
Member
From: Mumbai
Registered: 2011-12-29
Posts: 29
Website

Activation of Network Connection Failed

I'm on Arch Linux running, linux-3.3.5-1 and the my Wireless card is the Atheros AR9285 Wireless Network Adapter. I'm trying to connect to a secured Wifi network at work using the GNOME network-manager. When I select the wireless network, it asks me for my user password, and after authenticating it gives me an error saying 'Connection Failed: Activation of Network Connection Failed'.

This is the first time I'm getting such an error, since I've been able to connect to secured wifi networks in the past.

I'm not sure what to do, can someone please help me out?


Find me on    :     Twitter     Tumblr     Blogger

Offline

#2 2012-05-18 15:59:13

MadTux
Member
Registered: 2009-09-20
Posts: 553

Re: Activation of Network Connection Failed

Are you sure that the password is correct and that you enter it in the correct way (capslock on?)?

Offline

#3 2012-05-19 05:05:25

Paanini
Member
From: Mumbai
Registered: 2011-12-29
Posts: 29
Website

Re: Activation of Network Connection Failed

Yeah, it accepts my password (the root password) without any hiccups. As soon as I click on authenticate, the network fails. Is there any way to connect to the wifi network manually, without the aid of network-manager?


Find me on    :     Twitter     Tumblr     Blogger

Offline

#4 2012-05-19 05:08:21

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,142

Re: Activation of Network Connection Failed

Paanini wrote:

Yeah, it accepts my password (the root password) without any hiccups. As soon as I click on authenticate, the network fails. Is there any way to connect to the wifi network manually, without the aid of network-manager?

Wait you are entering your linux root password for your network ?

Shouldn't you be entering your wireless network password??


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#5 2012-05-23 08:09:23

Paanini
Member
From: Mumbai
Registered: 2011-12-29
Posts: 29
Website

Re: Activation of Network Connection Failed

The dialog explicitly asked for my root password. If I enter the password for the Wifi network, it tells me there's been an error and that I should try again.


Find me on    :     Twitter     Tumblr     Blogger

Offline

#6 2012-05-23 16:32:43

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,142

Re: Activation of Network Connection Failed

That's just wrong! A wireless network should never ask you for your unix passwords (user or root).

Show us the commands that you are entering & the error messages if any.


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#7 2012-05-23 18:42:59

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: Activation of Network Connection Failed

Inxsible wrote:

That's just wrong! A wireless network should never ask you for your unix passwords (user or root).

Right or wrong, thats how networkmanager polkit is setup. In default install only administrative  users can alter a network connection .. that is no more than what you need to edit wpa_supplicant.conf. If the connection is setup it can be activated by a normal user.
The OPs error must be somewhere else.

@Paanini: https://wiki.archlinux.org/index.php/Wi … nual_setup
gives you the manual steps to connect. As Inxsible asks provide the command and eventual errors you get using those steps.

Offline

#8 2021-01-29 21:33:32

gsucura
Member
Registered: 2021-01-29
Posts: 2

Re: Activation of Network Connection Failed

first check the running service with this command:
systemctl list-units --type=service --state=running

if NetworkManager.service, wpa_supplicant.service, systemd.networkd, systemd.resolved are running at the same time it'll give you this error.

The solution is quite simple, disable systemd.networkd and systemd.resolved, then reboot.

Hope it helped

Offline

#9 2021-01-29 23:32:54

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 3,577

Re: Activation of Network Connection Failed

gscura, this thread is nine years old and the OP has not been here since 2013. Please do not necrobump.

Closing.

Offline

Board footer

Powered by FluxBB