You are not logged in.

#1 2023-05-16 17:30:08

Registered: 2022-04-28
Posts: 14

Openvpn - No valid secrets

This connection worked for a very long time. I suspect that installing libreoffice-fresh may have messed something up because I do not have gnome or kde. I just use dwm and I mostly use terminal applications, and I suspect that openvpn got changed somewhere to expect some gnome keyring thing or something similiar to that. I think libreoffice has a dependency on gtk and gnome, but I am just guessing

Error: Connection activation failed: No valid secrets
Hint: use 'journalctl -xe NM_CONNECTION=  + NM_DEVICE=enp0s25' to get more details.
May 16 13:22:01 mycomp NetworkManager[504]: <info>  [1684257721.9401] vpn[ ,"mullvad_us_all"]: starting openvpn
May 16 13:22:24 mycomp NetworkManager[504]: <warn>  [1684257744.1685] vpn[ ,"mullvad_us_all"]: secrets: failed to request VPN secrets #4: No agents were available for this request.

The secrets are there, and I have the password set and the connection is available for all users. I cant see anything that has changed though. The section that mentions "agents" makes me think openvpn is now waiting for some gnome gui thing that isnt there. When I edit the connection properties everything looks the same as it was before? Does anyone have any ideas? I certainly ran out.

currently I am just using wireguard and that is working for the time being but I still want to fix this

Last edited by blah123213 (2023-05-16 17:31:32)


#2 2023-05-16 18:38:22

Registered: 2021-05-14
Posts: 40

Re: Openvpn - No valid secrets


I was having very similar issues (nearly exact same failure message), maybe something there can help.


#3 2023-05-22 19:47:15

From: Tbilisi, Georgia
Registered: 2010-04-03
Posts: 30

Re: Openvpn - No valid secrets

I am having a slightly different message after upgrading networkmanager-openconnect to 1.2.10-1:

secrets: failed to request VPN secrets #3: User canceled the secrets request.

After downgrading networkmanager-openconnect to 1.2.8-2 at least a password dialog shows up, but later fails with a different error.


#4 2023-05-22 21:22:05

Registered: 2022-08-15
Posts: 9

Re: Openvpn - No valid secrets

I'm getting the same error since upgrading networkmanager-openconnect to 1.2.10-1 as well this morning.  I have my credentials saved in keyring.

Via GUI:

The VPN connection ConnectionName failed because there were no valid VPN secrets.

Via CLI:

$ nmcli con up id ConnectionName
A password is required to connect to 'ConnectionName'.
Warning: password for 'vpn.secrets.gateway' not given in 'passwd-file' and nmcli cannot ask without '--ask' option.
Error: Connection activation failed: No valid secrets
Hint: use 'journalctl -xe NM_CONNECTION= + NM_DEVICE=eno1' to get more details.

Interestingly, vpn.secrets.gateway is definitely not my actual vpn gateway, so that might be the issue? Thankfully using --ask allows me to bypass the issue so I'm fine for now.


Board footer

Powered by FluxBB